MIDI Editor has no sound + More

Ernest-Hawkes wrote on 4/13/2019, 11:44 AM

So when I create an empty track and double click to get to the midi editor the sideways piano keys have no sound. Once I choose a virtual instrument I can not click on the play button to get any sound nor can the piano keys that are displayed on the virtual instrument such as vita be clicked on at all. The only time I get any sound from the midi editor is if it's a preloaded piece of music.

Last changed by Ernest-Hawkes

Operating System
    Windows 10 Home 64-bit
    Intel Core i7 4770 @ 3.40GHz    35 °C
    Haswell 22nm Technology
    12.0GB Dual-Channel DDR3 @ 797MHz (11-11-11-28)
    Hewlett-Packard 2AF3 (SOCKET 0)    30 °C
    ASUS PA238QR (1920x1080@60Hz)
    P223W (1680x1050@59Hz)
    2047MB NVIDIA GeForce GTX 750 Ti (Gigabyte)    26 °C
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))    29 °C
    1863GB Western Digital WDC WD20EZRZ-00Z5HB0 (SATA )    25 °C
    1863GB Seagate ST2000DM001-1CH164 (SATA )    26 °C
Optical Drives
    hp CDDVDW SH-216DB
    IDT High Definition Audio CODEC


ralftaro wrote on 4/15/2019, 9:00 AM

Hello Ernest,

Sounds like you might not be in ASIO driver mode right now. You might want to check that again in the program settings. Ever since the new Samplitude-derived audio engine was introduced in generation 27.x of Music Maker, you would no longer be able to get audio output when trying to trigger VST instruments in stop mode while using DirectSound or Wave drivers. (This was still possible in generation 25.x.) This is true for triggering the notes from the piano roll, the on-screen MIDI keyboard, as well as an external physical MIDI keyboard. It has caused a bit of confusion with some users. However, if you're working in any kind of MIDI recording scenario, ASIO drivers should be your weapon of choice anyway, and they are also the default driver type (starting in generation 25.x).

Hope this helps!