MIDI not working from USB Midi Keyboard out

robert-cacciatore wrote on 3/13/2019, 9:30 PM

Color me surprised. Magix2019 premium can identify my keyboard by manufacturer as a MIDI input device but just doesn't work. What yoga position do I need to learn to get MIDI notes onto a track?
 

Comments

browj2 wrote on 3/13/2019, 11:47 PM
  1. Start the external keyboard, then start MusicMaker
  2. Select an Asio Driver, ASIO4All or WASAPI in the Program Settings
  3. Make sure that your external keyboard is the selected input device in the Program Settings
  4. Select an instrument for the track
  5. Arm the track for MIDI recording
  6. Don't try to record using the keyboard at the bottom of an instrument
  7. Make sure the yellow bar at the top starts where you want to start recording and, preferably, ends beyond the length that you intend to record
  8. Press on record and play your external keyboard

Do you see the keys move on the on-screen keyboard (bottom window) when you press on a key on your external keyboard?

Without seeing your setup, it's hard to help more.

John CB

robert-cacciatore wrote on 3/14/2019, 1:38 AM

That wasn't working earlier BUT it is working now. Basically with MM closed I plugged in my USB Midi Kyb, heard the PC acknowledge the connection. Then started up MM. Oddly this time track 1 opened with a Piano instrument inserted with the MIDI RECORD red tab highlighted. I checked the Input (it defaults to my Behringer Asio UMC and it showed my kyb as the MIDI in and out). Worked perfectly. Expected that it wouldn't when I opened the project I was trying to record in earlier but it did. Hmm okay that was painless. Thanks - I'll report back if it gets lost again.

browj2 wrote on 3/14/2019, 8:48 AM

Hi Robert,

I just updated the list, as I had missed the most obvious problem. The external keyboard must be connected to the computer and started before starting MusicMaker.

The piano instrument is a default GM piano that Magix put in there. I suggest that you use a different instrument.

John CB

ralftaro wrote on 3/14/2019, 8:58 AM

Hi Robert,

Glad to hear this is working now. I believe this might be the crucial part:

Basically with MM closed I plugged in my USB Midi Kyb, heard the PC acknowledge the connection. Then started up MM. Oddly this time track 1 opened with a Piano instrument inserted with the MIDI RECORD red tab highlighted.

Unfortunately, it's currently a known problem that Music Maker may only pick up on the MIDI device correctly if it was already connected at the time of starting up the program. It's not supposed to remain this way, though. Development has already put this on their agenda, along with some other MIDI device input issues.

Here are some additional suggestions of things to try when having problems properly interfacing with (USB) MIDI device, based on things that have caused issues in the past:

  • Try different USB ports on your machine.
  • Avoid USB 3.0 ports for USB 2.0 devices. While, in theory, the 3.0 ports should be backward compatible with 2.0 generation devices, in practice there are sometimes problems with this configuration.
  • Temporarily remove other USB multimedia devices (e.g. webcams) while using the MIDI keyboard. There have been occasions on which they interfered with one another.

 

robert-cacciatore wrote on 3/15/2019, 12:25 AM

#ralftaro More detail on the MIDI problem. If I disconnect my keyboard's USB and reconnect before starting MM then a blank NEW project opens and MIDI from my keyboard works. I can record a track. I can save the file. But when I try to reload a previous project. The MIDI input is lost. I can see that the same ASIO and MIDI settings exist but simply loading a project is killing the MIDI input. I have changed USB inputs and will look to be sure I'm on a USB 2.0 tommorow. I'm using a HUB at the moment which has both 2.0 and 3.0 ports and I'm avoiding the 'blue' ones. Also just tried resetting the Keyboard MIDI USB then opening MM by clicking on the project file I want to add tracks to... same problem no MIDI.

Last changed by robert-cacciatore on 3/15/2019, 12:32 AM, changed a total of 1 times.

Music Maker Premium 2019 - Intel i5 PC with Windows 10, EVGA GeForce GTX 1060 6gB graphics and a Behringer U-phoria UMC404HD USB interface.

ralftaro wrote on 3/19/2019, 7:32 AM

Hi Robert,

The issue you're describing, especially with regard to the MIDI input being cut off after reloading an existing project, seems to tie into a problem I reported a few months ago. I just looked up the details again. With that problem, you would get the MIDI input to work again by simply briefly running the playback on the reloaded project. Does that work for you? Unfortunately, I don't actually seem to be able to replicate that problem on my new machine and when using version 27.0.3.32 now. So, that's a bit of a head scratcher. I'll just leave the bug report in our system, and wait until our testers and developers get to it. Maybe they have more luck replicating it.