Movie Studio 17 Platinum

Paul-Taylor1215 wrote on 1/14/2021, 4:45 AM

Hi All

I've just downloaded and installed MSP 17. I previously had 13. 13 worked basically ok. What prompted me to change it was that it was not showing some footage in the timeline for some reason. Just one particular piece of footage. Then also I thought there might be numerous other benefits to upgrading. But it's not working out so well so far.

So, I notice after installing MSP 17 that MSP 13 was still there. I tried to open a 13 project I was already working on. This seems to cause endless freezing and it won't show anything in the preview window.

So, I've now created a new project. This seems to be freezing less so far, but again I cannot see anything in the preview window. Can anyone suggest:

- Is the presence of old MSP 13 project causing any issues for me?

- How can I get things to show up in the preview window?

I am using a reasonable machine, with a Intel Core i7 processor and 8gb of Ram, with Windows 10 pro version 20H2.

 

Thanks

 

Paul

Comments

emmrecs wrote on 1/14/2021, 9:58 AM

@Paul-Taylor1215

Please read this pinned post and follow the advice given there.

This thread will be closed.

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D