Music Maker just locks up & becomes un-responsive

mongoose666 wrote on 5/27/2024, 10:07 PM

Music Maker just locks up & becomes un-responsive. I paid a lot of money over the years for MAGIX products and it used to work seamlessly. Now it just locks up and and I can't click anywhere or do anything. Sometimes it may become responsive again and it seems to be when it starts to go online to retrieve my VSTs and purchased content that it locks up.

I want this fixed as it is not functioning and basically renders the application un-usable. So I've paid for a bloody brick!!!
This is in violation of the software agreement. As it MUST "function", that is MAGIX' responsibility to me!!!

Extremely disappointed and bloody angry! Andy.

Comments

SP. wrote on 5/28/2024, 2:24 AM

@mongoose666 An extremely slow user interface is likely caused by the text cursor indicator or another program that accesses the text cursor, for example clipboard managers or password managers.

You can disable the text cursor indicator it in the Windows accessibility settings. Alternatively you can run Music Maker as administrator by right clicking on the program icon.

I'm not exactly sure why this happens. If you just bought a new computer this problem might be caused by the way your computer manufacturer set up your Windows user account. There could be a privileges problem between Music Maker and other programs and both fight over the text cursor which slows Music Maker down to a crawl.

If you run Music Maker as administrator no other programs can access its user interface. This is why it often helps to get the program back to speed.

mongoose666 wrote on 5/28/2024, 5:42 AM

@SP. I thank you for your reply.

As a software engineer with over 40 years experience 34+ professionally I know the issue lays within the design of Music Maker software itself. It's not slow it literally locks up and freezes, all other apps are fine.

I removed the files from the <user>/AppData/Roaming/MAGIX/mm32 directory and specifically the "ini" and the VST scan caches. This rectifies the issue and is clearly indicative that the issue is in the software's design.

Rather than fixing the issue MAGIX takes the line of forcing users to hack solutions. This is not proper and ethical practice for software design. I would "never" ignore such an issue in my own software that has clearly existed for quite some time. They need to fix the software rather expect end users to hack fixes.

That said the fix is explained above and is from another post in this forum, again indicating the problems existence for quite some time. Getting MAGIX to even have the decency to respond to e-mails & these issues is a joke and quite frankly the whole reason I am moving on to using Reaper.

Andy.

SP. wrote on 5/28/2024, 5:59 AM

@mongoose666 Magix technical support isn't active here and doesn't read the topics here. This is just a user forum where users like us help each other to solve questions and problems.

If you want to contact technical support open a support ticket.

browj2 wrote on 5/28/2024, 6:58 AM

@mongoose666

Hi,

It works fine here (32.1.0.18).

Did you try to disable the text cursor indicator in the Windows accessibility settings as suggested?

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

mongoose666 wrote on 5/28/2024, 7:02 AM

@browj2 The fix is stated in my previous comment. It has nothing to do with the accessibility options it is a problem with the VST scanning and the "ini" what exactly is only known by MAGIX. Again users should never have to perform hacks to get software working. Something I would never expect from my clients 👍😎

browj2 wrote on 5/28/2024, 8:55 AM

@mongoose666

Hi,

It wasn't clear to me that this was actually the solution. I have never had a problem like that with Music Maker. I have had the ini for one of the video programs go sour once over a dozen years.

It would be good to know if it was the VST ini or the MM ini.

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

mongoose666 wrote on 5/28/2024, 5:04 PM

@browj2 As stated the solution is from another post within this forum so the problem exists for many people. I guess count yourself lucky you've only had the issue once.

I have been using MAGIX for many years myself and it wasn't until the 2024 releases that I even started having this issue. It happens on multiple machines so the problem is not due to configuration it is due to a design flaw/bug plain and simple.

However the fix works and that's all I care about at the end of the day. I couldn't tell you which one fixes the issue & until the issue happens again, which it may do upon an update, I couldn't diagnose the issue ... I may have copied the files sideways so may be able to drop them back in and see if the issue returns. If this is the case I will post the results of my findings.

I can't for the life of me find where to raise support tickets on the MAGIX site? A link to where this is would be appreciated. As I will add my findings to the ticket I raise.

My only point is, is that MAGIX should address the issue not expect end user to perform hacks. I am a software engineer and I know the complexities in these things but I personally would never expect the end user to perform ***any*** kind of hack to circumvent a design flaw, I would debug the issue and produce a fix.

👍😎

SP. wrote on 5/28/2024, 5:18 PM

@mongoose666 As long as you're able you start the software, you can also reset the program settings under the File > Settings menu which also simply deletes the ini files. Deleting then manually is only necessary if the program no longer is able to start.

mongoose666 wrote on 5/28/2024, 5:30 PM

@SP. as stated it locks up and completely freezes so a manual deletion is necessary.

johnebaker wrote on 5/29/2024, 9:14 AM

@mongoose666

Hi

. . . . a problem with the VST scanning and the "ini" . . . .

Which ini file, when deleted, actually fixes the problem?

Did you delete the .scan files as well?

John EB
Forum Moderator

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

mongoose666 wrote on 5/29/2024, 4:02 PM

@johnebaker Yes I deleted the .scan files as well. As stated I got the fix from another post in this forum and I did say I deleted the scan caches 😎 ... Though I really should have stated the ".scan" files though 😞

I removed the files from the <user>/AppData/Roaming/MAGIX/mm32 directory and specifically the "ini" and the VST scan caches. This rectifies the issue and is clearly indicative that the issue is in the software's design.

Also @johnebaker you may be able to answer this for me?

I can't for the life of me find where to raise support tickets on the MAGIX site? A link to where this is would be appreciated. As I will add my findings to the ticket I raise.

browj2 wrote on 5/29/2024, 5:56 PM

@mongoose666

Hi,

Click on Support at the top of this forum. Select Audio, Music Maker, scroll to the bottom of the page (after having looked at all of the potential solutions, or not - the rest should be obvious.

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

mongoose666 wrote on 5/29/2024, 7:54 PM

@browj2 - Thanks for that. I did do that but as stated to no avail 😞

Getting MAGIX to even have the decency to respond to e-mails & these issues is a joke and quite frankly the whole reason I am moving on to using Reaper.

browj2 wrote on 5/29/2024, 9:15 PM

@mongoose666

When you sent in your request, did you receive a ticket number by email right away? If not, check your spam box.

John CB

John C.B.

VideoPro X(16); Movie Studio 2024 Platinum; MM2024 with MM2023 Premium Edition; Samplitude Pro X8 Suite; see About me for more.

Desktop System - Windows 10 Pro 22H2; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

mongoose666 wrote on 5/29/2024, 9:22 PM

@browj2 - Yes I did and that is why I said it was disappointing to get no response from MAGIX after about 2 months.

I am very proficient with using computers, as stated I am a software engineer with 40+ years experience - I work on large scale server technology but started my career as a firmware engineer so I know computers inside and out and don't get caught out by things like spam folders etc.

Trying not to be and sound rude ... sorry if it comes across that way.

SP. wrote on 5/29/2024, 9:55 PM

@mongoose666 If you don't send a follow-up email after a couple of days the support ticket will close itself automatically.

mongoose666 wrote on 5/29/2024, 10:06 PM

@SP. - Thanks for that ... I realised that too late as I was focused elsewhere with Unreal Engine & DaVinci Resolve for film/3D animation work and hadn't returned to my composed piece of music which is for the opening credits 😖😣

I am still using Music Maker now that I've managed to find a work around that fixes the issue.

@SP., @browj2, @johnebaker - The file that makes the difference is the Music Maker INI file. I had copied the files sideways and copied them back to trigger the issue & it did lock up again. I then removed 'only' the Music Maker INI file and the issue went away.

I am glad that Music Maker picked up the LABS by Spitfire Audio VST which I installed to use within Reaper.
I think I will be using both Reaper and Music Maker in conjunction with each other. Reaper is better in the automation arena + the MIDI export which I need so I can produce the sheet music for submission to APRA (Australasian Performance Rights Association) for any original music scores. Music Maker is much better with the plugins, VSTs and samples from with the application however - I just wish the MIDI export was better 😞😔