New Sound Forge 12 build 170 install on New Windows 10 64 bit Crashes

robert-p wrote on 1/8/2020, 12:31 PM

Hopefully someone has seen this and has a solution. Help?!#!@!




Version 12.1 build 170 64-bit

new fresh Windows 64 bit OS and new SF12 install on 1/8/2020

Since I have yet to get Magix tech support for this brand new SF12 software, I decided to create a new clean version of Windows 10 64 bit OS, then install SF12 insure it works, then load everything else on my computer until I find the reason why this software crashes out of the box (so to speak).

Loaded all the OS updates on a 64 bit 4.2GHz Intel with 1T disk space.

Loaded SF12 new and registered it.

Set SF12 preferences to make file assignments ask SF12  to open mp3 and wav.

Went to file explorer and  double-click  open mp3.  it opened the first mp3 ok.

If I try to double-click a 2nd  mp3   to open;    SF12 crashes every time.        Doesn't matter what mp3 file.  they are all short and no issues with the file itself.


here is a screen of error report.

Extra Information
   File:                C:\Users\me\AppData\Local\MAGIX\SOUND FORGE Pro\12.1\dx_grovel_x64.log
   File:                C:\Users\me\AppData\Local\MAGIX\SOUND FORGE Pro\12.1\vst_grovel.log

Problem Description
   Application Name:    SOUND FORGE Pro
   Application Version: Version 12.1 (Build 170) 64-bit
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\Program Files\SOUND FORGE\SOUND FORGE Pro 12.0\forgek.dll
   Fault Address:       0x00000001803727F1
   Fault Offset:        0x00000000003727F1

Fault Process Details
   Process Path:        C:\Program Files\SOUND FORGE\SOUND FORGE Pro 12.0\Forge120.exe
   Process Version:     Version 12.1 (Build 170) 64-bit
   Process Description: SOUND FORGE Pro

Then I reopened SF12  with blank workspace.   And highlighted three mp3 files and dragged/dropped  them into SF12 workspace. 


Bob audio music maker


rraud wrote on 1/8/2020, 2:47 PM

"If I try to double-click a 2nd mp3 to open;    SF12 crashes every time"

Are you appending to an already open MP3 file. Have you tried a 'drag and drop'. Do both files have the same attributes (sample rate, kbps, CBR/AVR, ect.) If your can open the secondary MP3 in a new window, try to copy / paste. Otherwise render the files to a PCM format then work on them. Either way, I cannot duplicate this behavior.

>> I recall recent abnormality if a file is encoded to MP3 (Save as), SF will crash on a subsequent encode unless the file is moved elsewhere.

robert-p wrote on 1/8/2020, 4:46 PM

Dear RRaud,

Thanks for trying to replicate this. I really appreciate that you took some time to see if you can duplicate this.

It's a shame that I've spent about ten days now trying to solve what I believe is some basic file system interface with SF12 software. I also expect that if MAGIX didn't get SF12 right, then I have no hope that SF13 will work any better.

As a background, all files were previously created/saved by SF11 or SF9. Typically 1-10 minutes in length. I was simply double-clicking one mp3 file, then another in a directory containing over 100 pre-made SF11 files in it. Not trying to edit or save anything at this point. After opening one mp3 successfully, I try to double-click a 2nd file in file explorer and that's when the crash report page shows up each time.

Originally, I had a well endowed Windows 10 64 system, so I thought that just perhaps some strange interaction occurred with SF12 and the mountain for creative labs sound, and video editing software might have created some preculiar interaction with SF12.

Since I frequently backup the entire system, I decided to take one disk and rebuild the OS with nothing else on the system. I insured the OS will fully up to date before loading only the SF12. Talk about a clean system, it's a raw as you can get out of the box.

So, from my point of view, the newly installed and registered SF12 fails on a new Windows 64-bit OS . Pretty basic stuff at this point. I've been with SF (Sony) products for over 20 years. Never had this kind on thing happen before SF12. So, I'm back to SF 11 and threw SF12 into the viritual garbage at this point, unless someone out there has seen this type of thing and discovered a solution.

If MAGIX ever monitors this blog, they can always contact me to run a test or upgrade fix to the software. I'll keep the "test disk with new OS around for a few months, but I'm not going to waste more time with nothing new to try.

Oh... one last thing. If I open wav files I can double-click the file explorer, and open wav1 wav2 wav3 with never a crash. It is only related to mp3 files and I've tried all different ones, not just the same two files. Those are the two formats that I always use, so I have no idea if other file types might also generate a crash. Mp3 is the most popular for my work.


rraud wrote on 1/9/2020, 9:57 AM

Try to contact Magix tech support on-line. I assumed you tried to re-install Pro 12. I can only suggest trying the 32 bit version of Pro 12. I have both 64 & 32 bit Pro 13 on my PC, since some of my go-to DX plug-ins do not work on a 64 bit host. The two versions share many of the settings and authorization. I can not detect a noticeable speed difference. btw, I still use Pro 10 a lot, since I do not like the plug-in chainer rebuild, which was implemented in SCS Pro 11.

robert-p wrote on 1/9/2020, 3:04 PM

Hello again RRaud,

I've reinstalled SF12 more times that I would care to list. The latest and last attempt was on a clean new Windows 64 OS with nothing else other then the OS and SF12.

Still fails if opening more than one mp3 using the file explorer double-click to open.

I tried to use MAGIX tech support. It won't let me go past the warranty page; saying that my product is too old. WHAT?????? I just purchased this new. and then when I try to go to the "buy a voucher" page. It goes nowhere. I've tried this multiple times over multiple days so it's not like the website was down for a week.

I'm back using SF11 and happy with it for what I need it to do in my world of mp3s and some CD wav creations.

In any event, thanks for the communication. I've wasted more than then the software cost me. What a waste from the Sony days when you could actually get tech support, and the product worked.

bizvoice9 wrote on 1/9/2020, 4:04 PM

I'm have the same 'Fail Issue' with SF12 occurring in the past week! It's like something just went missing in the software- or Microsoft updates are blocking it. Been using it faithfully since SF5 - But Magix's tech support really sucks! SF is Magix's step-child since they bought it from Sony! Cant' get anyone at Magic by phone to talk- just rings; and, the last tech-request took 10 days to get an answer. I'm not seeing any answers here... probably because so many users have already moved to greener pastures! I've Wasted 11 hours between yesterday and today uninstalling and reinstalling the software- with no success!! I'm feeling very FRUSTRATED and it's making me crazy! 😜. I bought SF3 for Mac- But now it doesn't work either. Not going to waste money on SF 13-PC.

robert-p wrote on 1/9/2020, 6:58 PM

I agree, MAGIX is not wasting any human power on this because there is no profit left in buggy software. I'll stay with SF11 for the duration. What a shame the industry workhorse seems to have died while we're still trying to ride it.