No more recording after update Windows 10

luc-brusselmans wrote on 2/9/2020, 5:56 AM

Using Soundforge 13, I did a (rather large) update of windows 10 this morning.
After and during the update, there were numerous restarts and after the last one, I tried to record an album through the Optical in of my soundblaster ZXR. That worked today before the update but after the update all my settings in Soundforge were gone (or they dindn't work anymore). Playing the album, using the optical in does work (both through my headphones and the speakers)
Is there anybody who can point me in the right direction to find a solution.
I already reinstalled Soundforge but that didn't solve my problem.

In the preference-tab, I can chosse between different device-types. (Windows sound - Direct sound - Windows Classic wave driver - Creative SBZ series asio device - Magix low latency 2016). There is only one that actually let me start a recording and that is the creative asio device but it doesn't record my source. It is just a blanc file....
So I guess I am doing something completely wrong.

all help appreciated here.

Personal email address removed by Moderator

 

kind regards

Luc

 

 

Comments

emmrecs wrote on 2/9/2020, 7:40 AM

@luc-brusselmans

Welcome to the Magix forums.

Unfortunately, I cannot directly answer your question but you will see I have a) moved your question to the correct area of the forum, and b) deleted your email address from your post. This is a public user to user forum and there is a very real danger that spambots may harvest your email address and you will find yourself deluged with Spam! Any personal data, like email addresses or serial numbers should never be posted to the forum.

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

luc-brusselmans wrote on 2/9/2020, 7:43 AM

Thanks Jeff,

much appreciated.

rraud wrote on 2/9/2020, 9:50 AM

In your Windows' OS sound settings, under the 'Recording' tab, enable "Stereo mix" or "Record what you hear" . Then In SF, go to "Options> Preferences> Audio> Recording" and select 'Classic Wave Driver" confirm that the (above) "Stereo mix" or "RWYH" are enabled.

On some PCs, recording directly off the sound card is permanently disabled. I had a Toshiba Satellite the could not record from the card and encountered other Toshiba's with the affliction. All of the Dell PCs I've owned (many) allow recording directly.

luc-brusselmans wrote on 2/9/2020, 11:52 AM

Thank you Rraud,

I have followed your directions but with no succes sofar. Since my source is a digital (optical connected Bluesound iNode, I guess there are some other factors in play.
I am going to try some other settings tonight.

Luc

CubeAce wrote on 2/9/2020, 3:22 PM

@luc-brusselmans

Try downloading the free Asio4all plugin as it has digital input and output modes. I have to use it for my old copy of Cubase.

Windows 10 Enterprise. version 1909.OS Build 18363.720. Latest Bios update as well as latest hardware updates for Western digital hard drives.

Asus ROG STRIX Z390-F Gaming motherboard with Supreme FX inboard audio using the S1220A code. Intel i9900K Coffee Lake 3.6 to 5.1GHz CPU with 32GB of 2133MHz Corsair DDR4 ram. 1000 watt EVGA modular power supply. 2 x 320GB SSD drives striped for faster R/W times are my C: drive. 1 320gig Toshiba M2.1 drive. + x2 WD BLACK 2TB internal SATA 7,200rpm hard drives. Total 4TB. Three external WD drives for backup. NVIDIA G Force GT 1030 Graphics clock 1252Mhz Memory data rate 6008Mhz. 384 CUDA cores. Memory interface 64bit Memory bandwidth 48.06 GB/s 2GB of dedicated video memory, shared system memory 9967MB PCi Express x4 Gen3. Running MEP Premium 19.0.2.58

luc-brusselmans wrote on 2/16/2020, 9:35 AM

Hello everybody,

 

this morning, again, an update of Windows 10. and, also again, my setup was disrupted.
Both SF_13 and 14 are affected.

I have a Bluesound iNode 2, optical connected to my soundcard in my PC. I know that the iNode works when I connect it directly to my active speakers, I also know that the optical input of my soundcard is ok because the soundsettings give a signal.... However, there is no way I get any sound out of my speakers. When playing music through a program installed on my pc, there is sound but never when I play music from the iNode. And that worked flawless until yesterday....

I can’t seem to figure out what I am doing wrong.
On top of the no sound issue, I can’t record anything through SF_13 or 14. Not one of the input in the preferences of SF records anything. And I wonder if it is normal that both play and record use the same device? I should think that both can be a different but whatever I chokes for one, it is always duplicated to the other.
I don’t think it is an issue of SF. Also Audacity gives me the same problem. Until last week, record through the optical input of my soundcard went without problems.

all help or sugestions are welcome.

 

kind regards

Luc Brusselmans

 

 

 

rraud wrote on 2/16/2020, 10:14 AM

I had a Win 10 update change the soundcard operation, it disabled the mic which subsequently blocked all audio going to SF, VP and other recording apps It was some kind of privacy issue setting as I recall.

luc-brusselmans wrote on 2/17/2020, 11:42 AM

Hello Rraud,

 

thanks for your tip.
I did a clean install of my Windows 10 yesterday. Did the updates but didn’t install the software that came with the soundcard. I also skipped the drivers and let it all be handled by the Windows installation.
And now everything works again as before. I did upgrade to SF14 but I am not very happy with the way that the layout of the program is handled. Something that I will have to get used to, I guess

 

kind regards and thanks for the assistance

 

Luc Brusselmans

ste_c wrote on 2/22/2020, 5:43 PM

I had a Win 10 update change the soundcard operation, it disabled the mic which subsequently blocked all audio going to SF, VP and other recording apps It was some kind of privacy issue setting as I recall.

Had same issue with a Realtek 'Stereo Mix' input after a Win10 major update, seems to be a mic privacy settings thing ...this fixed it (see newest answers) :

https://answers.microsoft.com/en-us/windows/forum/all/no-sound-input-devices-working/dec39adc-3a68-47b7-ba61-f6f4628c7655