No picture or sound

henry-s wrote on 9/20/2019, 10:42 AM

I have been working with Video Easy for two weeks now. I'm trying to digitalize old video cassettes, using a Terratec G3 to capture. After a few difficulties getting started, which forum members were able to help me resolve (thank you again!) I now have a new problem.

I tried to begin a new project. I set everything up and cued the cassette in the VCR. I could see a picture in the preview window of Video Easy, but heard no sound. To make sure there was sound on the cassette, I unplugged the video capture device and connected my VCR to audio inputs to capture the audio with another program (Adobe Audition).

After ascertaining that there was sound, I reconnected the video capture device, now I get no picture. When I use device manager, it shows the Terratec device, although I don't see it show up in File Explorer attached to the USB port.

I uninstalled and reinstalled both the device and the Video Easy software twice, but have made no progress. I noticed that the DVD that came with my device listed Win 8 as the newest version, so I downloaded a Windows 10 64-driver and the Video Easy software directly from the Terratec website.

I checked the manual for troubleshooting tips but didn't find anything relevant, nor did a search of threads here on the forum turn up anything (perhaps I overlooked something).

Any suggestions what I should do? Thanks in advance!


HP Pavilion Desktop, Intel Core i7, CPU@ 3.60 GHz, running Windows 10 Home 64-bit 18362.356
NVIDIA GeForce GTX 1060 3 GB graphics card; Realtek HD Audio
C drive is a 500 MB SD, D is 2 GB
Video Easy Terra Tec edition, V (USAA)


Mikael-Lojdkvist wrote on 10/1/2019, 6:27 AM


I have picture and sound in the preview screen when recording and edit but when I click "Finish movie" and I choose "Save on compupter" it saves it in mp4 and when I open it in either "Windows media player classic", "Windows media player(Windows 10) or in "VLC player" I only get sound, no picture. It worked on my first video, now I am trying a second tape but does not work. I will try a 3rd tape but is there a setting somewhere I missed?

henry-s wrote on 10/1/2019, 10:43 AM

Hello Mikael, that is really strange. Have you tried to burn a DVD instead of saving it to the computer?