Normalizing file deletes major portions of track

Lori-Titus wrote on 1/7/2021, 2:16 PM

I have been using Sound Forge for years for VO work. Switched last year to Sound Forge Pro when I picked up a new computer, the software says it is currently on version 14 build 130.

Previously, when I was done editing a file, I would double click on the waveforms to select all and normalize it to -3.0dB. Done this for years, never a problem.

Yesterday, did the exact same thing, and instead of normalizing the file, a large portion of it disappeared. It was like it created a really bad soundgate instead of normalizing it all. (There was no sound gate on this file, never touched that option.) Did a ctrl-Z to remove the normalization, and the screen displayed pre-normalization peaks. Tried a few more times, with the same result. Ended up trying to save as a separate file without normalization so I wouldn't overwrite the original. It saved to the new file, AND overwrote the original! Worse yet, it was showing the effects of the "bad" normalization on both files. I lost the audition I had been editing. Very frustrating.

This has happened with two files now, and I don't know why. I think there was a recent update to the software? Is this a bug, or is it me?


rraud wrote on 1/7/2021, 5:43 PM

Is this a bug, or is it me?

I have not read of this behavior prior. Where did the files originate from? Are they PCM or lossy file type?? Was 'snap to' markers, regions or something else enabled??? Was part of the file deleted, or was the part processed to silence (same length but no sound?????

Always back-up the original files prior to any editing (which I am sure you will do now), You may try editing in the non-destructive mode (Save as SF Pro Project file <.frg>) which creates a project file and companion media folder. Then "Render as" when you are done editing.

btw, welcome to the Magix Sound Forge users forum @Lori-Titus.

Lori-Titus wrote on 1/7/2021, 6:40 PM

This was recorded directly into Sound Forge with a SM7B microphone with focusrite and a cloudlifter. 44,100Hz sample rate, 16 bit depth, stereo. I saved the original file, then started editing. I did not resave back into the original file - I saved the edited files into a separate file, but when I went back to the original file, saw that it had also been overwritten at the same time.

I guess you could say part of the file was silenced, a large part. I did check to see if it had been muted somehow, but no such luck.

I've been doing VO of and on for several years, but my knowledge of soundforge is limited to the specific functions I use. That is, I'm not making large complex musical files or weird sound effects. I moved from a much older version of sound forge, there is a much different look to the software now. But I can't imagine what would have caused this.

rraud wrote on 1/8/2021, 11:36 AM

I saved the edited files into a separate file, but when I went back to the original file, saw that it had also been overwritten at the same time

Sorry, I have no idea what caused this, nor have I heard of that particular behavior before. Pilot error maybe, I have inadvertently done things I did not notice and wondered, "WTF" !?

As I stated, try the Sound Forge Pro project file mode which will leave everything intact with the ability to change things back or re-edit, after rendering w/o doing the entire project from the start. The only drawback is it takes a little longer to open and save the project.

Which version of SF did you have? The basic SF Pro UI has not changed much since version 4.5. If you had AS (Audio Studio) that is significantly different. The only big UI change in SF Pro occurred with SCS (Sony) SF Pro 11. The plug-in chainer went to a modal design and the record UI was complicated as well, including dropping of the useful remote record feature. Neither was a good idea in IMO. FWIW, Magix stated the remote record will be resurrected, but do not hold yo' breath.