NoTurning wrote on 9/26/2008, 8:38 AM
Are you using a sound interface or the built-in sound card? Certain recording interfaces were showing this behaviour and needed a firmware update. This can be found on the manufacture's website.

Try also to update your sound card drivers if you're using a built in sound card.

If this does not help let us know what Magix product you use and what your set-up is. We can go from there.

NoTurning wrote on 10/2/2008, 8:27 AM
Next I would try switching from the Magix ASIO driver (in the software settings) to WAV or DirectX. Also try the sound card manufacturer's ASIO driver if they are available in the settings window. These can be changed in the playback parameter area and will affect recording as well. 

A little experimenting might be needed here to find the best setting which does not introduce noise but has no latency.

I also recommend setting Windows to give priority to background tasks. This will prioritize any audio functions and software using them. You can do this in the Windows System Settings.

Let me know how it turns out,
NoTurning wrote on 10/6/2008, 9:21 AM

Wow... strange behaviour. Do you have plenty or RAM? Does this happen on a specific arrangement/track or does it seem to be random. What type of audio interface do you have? Is it the internal sound card?