Pro X7 Suite either no sound, or LOUD hiss while other sounds play

Philip-Thompson wrote on 3/21/2023, 7:33 AM

Pretty disappointed in this. JUST bought it, went through all the install, accepting all defaults. Wanted to make sure everything was okay so I opened a Demo song, and the title says the rest. Numerous attempts. Referred to a bunch of posts here, tried several different configs via the standard ctrl+y, to adjust Audio and Import/Export settings, all to no avail. I've had three previous versions of Samplitude, going back 20 years (last purchase ProX3), and have never experienced this kind of frustration. Please tell me there's an easy way to fix this.

System specs:

Windows 11 Home
12th Gen i7 Intel Core 2.10 GHz
64-bit OS and processor
SSD with 805 GB available

Last platform purchased ProX3 with SoundForge 11 (2017 or 18)

Thank you.



SP. wrote on 3/21/2023, 7:41 AM

@Philip-Thompson Can you upload screenshots of your audio and performance settings? Click on the blue arrow icon above the response text box to upload an image to this forum.

Philip-Thompson wrote on 3/21/2023, 7:58 AM


Thank you for the prompt reply. Here are some screen shots -

On the Import/Export settings I tried all options on the drop down then clicked "reload," some resulting in the loud hiss, some resulting in no sound. None resulted in a working configuration.

SP. wrote on 3/21/2023, 8:05 AM

@Philip-Thompson Try enabling "Allow Pull Mode (WaveRT)" and "Always Resample" in the ASIO driver.

Philip-Thompson wrote on 3/21/2023, 8:26 AM


This did the trick! Thank you for your help.

- Phil