Problem with XARA Premium

gary-tayman wrote on 3/15/2019, 9:28 PM

I recently downloaded Xara Premium, It doesn't work properly and I'm getting extremely frustrated with my inability to get basic support, even after trying for several days. The ONLY support response I've received, a few days after asking, is a suggestion to uninstall and reinstall the program, which I did. It also suggested removing all files from c:\programdata\XARA\Webdesigner_premuim\16\. There is no such folder, even if I look at hidden files. I see on this forum that there's ANOTHER forum for XARA called talk graphics or something -- I tried THAT but it refused to let me log in. That's why I'm here -- stuck, frustrated, and having second thoughts about having purchased it.

Anyway, here's my problem, and hopefully you can help. I go into the program. I start reading the basic tutorial, and one of the first things it suggests is to browse through the content catalog. I do this and get error messages on everything I click. I saved a screenshot and sent it to so-called "support", three times, but no reply at all. If I try to get past the errors, and click on any thumbnail, the entire program locks up and I have to do a three-finger salute to get my desktop back.

Now, the simple question: could the problem be my internet browser? This computer is using Windows 7, with Internet Explorer. I also have Google Chrome (which I use the most) and Firefox. Might this work if I open it with Chrome? Is it worth a try? OKAY, so how do I select the browser in XARA so it utilizes Chrome? I've been through all the tools and options and have found nothing. Any ideas? I feel as though I've been left out to dry, with no support on a product I just paid good money for. I greatly appreciate any help you can give me.

Thanks!

 

Comments

johnebaker wrote on 3/16/2019, 12:43 PM

@gary-tayman

Hi

The error message you are getting suggests that the content server cannot interpret the data it is being sent ie your installation may be corrupt, hence the un-install/re-install.

. . . . c:\programdata\XARA\Webdesigner_premuim\16\. There is no such folder, even if I look at hidden files. I see on this forum that there's ANOTHER forum for XARA called t . . . .

If there is no C:\ProgramData\Xara\Xara Web Designer Premium\ folder then that also would also suggest the installation did not complete correctly or is corrupt.

Possible causes are Antivirus program blocking part of the installation, corrupted download other program interfering with the installation. If you are on Windows 10 1809 then there may be an issue with your user account security permissions.

. . . . . XARA called talk graphics or something -- I tried THAT but it refused to let me log in . . . .

The Xara Talkgraphics website is a separate entity from the Magix forum and main website and requires you create a separate account.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

gary-tayman wrote on 3/16/2019, 6:31 PM

John,

 

Thanks for getting back to me.  I looked again, and found no ProgramData folder on the C drive, I DID find Xara under the program FILES folder, and everything looks intact.  Again, I'm not using Windows 10; I'm using 7 with Internet Explorer 11.

I might add that the program seems to work fine as long as I don't do anything that accesses the internet.  The online catalog gives me errors, and I've also tried looking at Google Fonts -- which also gives me an error.  Aside from that I've done more poking around, and this program looks like it will be nice to use -- if only I could get past first base.

My nest step at this point will be to try this on my laptop -- which DOES use Windows 10.

 

 

gary-tayman wrote on 3/16/2019, 7:53 PM

Update:  I just installed it on my laptop, Wow!  Different as night and day!  I'm going to try and reconfigure Xara on my desktop, but for now I'm going to put this to use with my laptop.

Now for a dumb, unrelated question:  I currently have a website, and would like to make changes to it, one page at a time.  I currently keep all the files in a folder called "Website."  I have an Index page, and a folder titled "Index" that contains all the photos and graphics associated with it.  Plus a bunch of other pages arranged the same way.  Does Xara store pages in the same manner?  I prefer to upgrade the pages methodically if I can.

 

 

johnebaker wrote on 3/17/2019, 12:00 PM

@gary-tayman

Hi

Windows 7 should have the ProgramData folder present this version of Windows was the first time it appeared, previous versions of Windows used the Programs and Settings, All users folder.

. . . . I have an Index page, and a folder titled "Index" that contains all the photos and graphics associated with it. Plus a bunch of other pages arranged the same way.  Does Xara store pages in the same manner?  I prefer to upgrade the pages methodically if I can . . . .

This would suggest you have been using a different Web design program eg DreamWeaver or the like. With Xara Web Designer (XWD) it does not care where the pictures etc are stored.

If the web site was created with a different program, then you are going to have to import it XWD - see this article for the limitations.

XWD is not an HTML editor, it stores all the data of the text, design, images etc in a the project file. It is only when you publish the website that the HTML pages are created and the images etc added, and put into a folder structure which may be very differently organized to the one you have now.

HTH

John EB

 

 

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

gary-tayman wrote on 3/17/2019, 2:50 PM

@gary-tayman

Hi

Windows 7 should have the ProgramData folder present this version of Windows was the first time it appeared, previous versions of Windows used the Programs and Settings, All users folder.

Not there, but the Xara files ARE in the Program files folder.

I suppose next step is to make Chrome my default browser -- don't want to do this for unrelated reasons, but I'll see what it does.  I upgraded to 10 back in the "free" days, but it interfered with my business programs and I had to go back.  Now it's all changed, but the day may come when I replace the entire computer.

Back to the web page itself.  So I gather that XARA stores this in a proprietary format, and I need to use Publish to upload it?  (Instead of CoreFTP)  You also said it makes additional folders at that time.  Do these folders have names (that I can watch for)?  Is that "Index" folder no longer relevant after the new, replacement page is made?

Here's why I'm asking these questions:  I have an existing website that contains several pages, is working fine, and already seems to have the right keywords to put me on the front page of search engines.  It just looks old, and XARA can help.  I want to make the improvements one page at a time.  Rather than update existing pages, I want to start each page fresh.  I also want to keep my metadata, which could be an upcoming issue with Hello Engines.  I have to buy the Pro version to insert keywords?  Did I read this right?  I don't want a better-looking web page that destroys the SEO.

So these are my concerns.  Aside from this I'm really impressed with what I see so far.

 

johnebaker wrote on 3/17/2019, 3:37 PM

@gary-tayman

Hi

. . . . I suppose next step is to make Chrome my default browser . . . .

Only if you want to use Chrome as the default, AFAICS there is no requirement for Chrome to be the default.

However you do need to have several browsers installed for checking that the site performs correctly - I use Firefox, Chrome, Edge, Internet Explorer and Opera.

If you are creating a mobile friendly version of the website as well, XWD has templates for these, then you need to test on several different mobile browsers as well.

. . . . It just looks old, and XARA can help. . . . .I want to make the improvements one page at a time . . .

I would advise you to start from scratch and rebuild the entire site. Changing one part, while feasible, is not practical, the web site is going to be in a mix of old vs new, lacking consistency in appearance and branding and is likely to confuse visitors.

Importing the old site should at least get you a good head start from which you can apply a suitable template and re-arrange the items as you desire.

. . . . an upcoming issue with Hello Engines. . . .

These will not work until you have actually exported the web site to your PC from Web Designer.

. . . . XARA stores this in a proprietary format . . . .I need to use Publish to upload it?  (Instead of CoreFTP) . . . .

Yes - publishing/exporting and uploading can be done in 2 separate steps:

Export website - to save the entire website on your PC in a separate folder. The SEO tools can then be run on it.

Upload - you can upload with any FTP program, or use the XWD internal FTP uploader.

Publishing exports and uploads in sequence - this I do not recommend if you want to use the SEO tools.

. . . . You also said it makes additional folders at that time . . . .

The basic structure is all HTML files in the root, and all resources used, ie images, icons, logos, etc are in a folder called index_htm_files.

. . . . I have to buy the Pro version to insert keywords? . . . .

As you have Web Designer Premium you can do this manually adding the appropriate HTML in the Web properties, HTML code header dialog.

In your case as you have these already in your old website you can copy the lines of HTML that refer to the keywords and paste them directly in the above dialog.

HTH

John EB

 

Last changed by johnebaker on 3/17/2019, 3:42 PM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

gary-tayman wrote on 3/17/2019, 6:09 PM

Thanks.  You've given me a lot of information.  I printed it out for reference.  Rewriting the entire website could take months or years, so I'll do a page at a time, when I have time.  The new pages, especially the Index page, will have the same general look as before, but with improved graphics.  I'm sure the Publish feature is great, but I prefer the idea of the two steps -- so I can stay organized.  Thanks again for your assistance!

 

 

shgrude wrote on 3/18/2019, 6:39 AM

@gary-tayman

ProgramData is a default hidden and systems folder. So it will not show in Explorer.
However, the folder i accessible when accessing it directly, and this can be done by typing the folder in the address line (or in "Search Program and files" from Windows Start button menu, or in the Run command line).
If you have some special with your installation (not on C:, other language etc) you can type %ProgramData% (including the percentage signs) followed by <ENTER> in one of the 3 before mentioned locations to get there.

There will be files in both "C:\Program Files" (%ProgramFiles%) and "C:\ProgramData" (%ProgramData%).

Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Operating system: Microsoft Windows 10 Home 10.0.17763 Build 17763 64-biters (1809)
Memory: 16GB
Sound Card: NVIDIA High Definition Audio
Realtek High Definition Audio
NVIDIA Virtual Audio Device (Wave Extensible) (WDM)
Graphics Card: NVIDIA GeForce GTX 1060 1920x1080

gary-tayman wrote on 3/20/2019, 8:45 PM

Thanks for all the help given me so far.  I have a lot of information printed here for the original problem, and will follow these steps to reload XARA on my desktop..  Meanwhile I've been using this on my laptop and am actually enjoying this new program.

However I've run into one more bug, that I hope you can explain/fix.  Like I said, I want to replace my site one page at a time.  I've added my descriptions and keyworks -- easy.  I used the two-step procedure described above for uploading.  Again, easy.  Sure enough, I opened my browser and went to my website, and the Index page looks fantastic.  BUT -- I got a nasty little surprise.  The OTHER pages don't work!  They're there, but all the images are missing!

Here's what I have:  the website is related to car stereos.  The main page is Index, and I also have pages titled Stereos, Speakers, Power, History, and a few others.  All of these pages are untouched, except I have buttons on my Index page with links to them.  Why are the images missing?  All the folders full of images are still there, I see no reason why this would happen.

Now here's a clincher:  I have online shopping, using OSCOMMERCE.  This portion of the site is built online, and hopefully I won't have to rewrite this.  I'm hoping my XARA pages won't corrupt any of this.  The Stereos, and Speakers pages, etc., will eventually be rewritten in XARA, but for now I need to retain the old ones.  I don't know what changed them.  Meanwhile I had to erase my new Index page and put the old one back!  Please help!

 

 

 

gary-tayman wrote on 3/20/2019, 9:19 PM

UPDATE:  I think I've figured it out!  Gee, I'm so smart . . .

For each button I had, under Web Properties, link to file -- Stereo.htm.  This is similar to the way things were done in the past.  Instead I linked it to Web Address, and put the whole address in -- it works!

I'll probably have more questions before long, but I'm making a great amount of progress and I should be in the swing of it before long.  Again, thanks for the help you've given.  The thread is most likely closed -- that is unless I continue having trouble with loading it on my desktop.

 

gary-tayman wrote on 3/23/2019, 4:14 PM

Good news!  The original problem was XARA not working on my desktop.  Error messages and screen freezes.  I finally WAS able to find the Program Data folder; I uninstalled XARA, removed the data as requested, and reinstalled.  It now appears to be working.

 

Thanks again for all your help!  It was a rough start, but I'm falling in love with this software!

 

gary-tayman wrote on 3/23/2019, 4:21 PM

AAAAKKK!  Not so fast!

After typing this, I went back into XARA to get started.  What happened?  It said there's an update.  I installed the update and guess what?  Back to the errors!

 

I give up.  i'll simply use my laptop for this.