Problems with Trial of SLP 4, "Device Error 1"

d_anne wrote on 12/21/2016, 1:16 AM

I changed the folder locations in my preferences, and then SLP 4 would no longer work. I get "Device Error #1" Open Error: no samplerate or channels available (48000,0,0). When I try to play audio, I get "Device Error #2" "API not initialized".

Problem seems to be related to my WASAPI device. It is selected, and the correct output device is selected (analog), but there are no channel mappings available for it. (tried the digital outputs too - no channel mappings available).

Tried SLP 3, and no problem at all. Changed device from WASAPI to ASIO and then back to WASAPI and the channel number mappings are fine.

Of course there is no way to file a technical support request against SLP 4, even if it weren't the trial version. (they apparently don't think SLP is their product on the support page).

Don't think I'll upgrade to SLP 4. Not ready for primetime yet.


DivideFrame wrote on 12/21/2016, 2:28 AM


I could repro this issue by disabling either the record or playback device on the PC.

Can you check you have at least one record and one playback device available before running SLP4 ?

The bug will be fixed in the next update.



DivideFrame wrote on 12/21/2016, 8:54 AM

I fixed the bug, you can download here unofficial installers for SLP 4.0.63 (the dmg is for Mac, the exe for Windows).

Please install the 4.0.63, go to Preferences, "Reset All" and restart the software.

Robin Lobel (SpectraLayers developer)



d_anne wrote on 12/21/2016, 3:12 PM

Robin, thanks, that did do it. I do not have input devices, only output devices - but this fixed the problem. So nice that you follow the forum.

Good things about SLP 4, - the GROUP feature is very nice. Bad thing - the time cursor and zoom does not match the other SCS/Magix programs. Really want the zoom and cursor/pointer to operate the same as Vegas, DVD Architect, ACID, Sound Forge, etc. I get frustrated switching from one of them to SLP4 and try to deal with zooming and cursor motion.

shmuel wrote on 1/22/2017, 12:24 PM

I have a similar issue as d_anne. I had it recently in SPL3 and I also have it in SPL4 trial. When I try to load or playback an audio file I get "Device error #1 not enough channels available for requested mapping (2,2,0,2)". I have a Scarlett 6i6 interface. I tried the fix you mentioned it didn`t work.

DivideFrame wrote on 1/23/2017, 4:18 AM


First, please try the new SpectraLayers Pro 4.0.69. Then, the error message you're having means the device you selected has no stereo output activated. Are you using in ASIO or WASAPI mode ?

shmuel wrote on 1/23/2017, 12:51 PM

I clicked on the link for SpectraLayers Pro 4.0.69 and downloaded SPL4 it was same version as before 4.0.63 not 4.0.69

DivideFrame wrote on 1/23/2017, 1:15 PM

On PC: Right-click/Property on the file you downloaded today from Magix, it should show "4.0.69":

On Mac: Double click on the file you downloaded today from Magix, Agree, the title of the installer window should show "SpectraLayers Pro 4.0.69".

If it does, then install it, it should replace the 4.0.63 installed on your computer.
If it does not, then it's not the latest file from Magix.

shmuel wrote on 1/23/2017, 1:28 PM

Youre right it's just that after downloading I ended up installing previous version. Now I tried the newest version, I still have problem. Tried the wasapi mode, had problem with channel mapping. Then tried Asio mode the program just shut down.

DivideFrame wrote on 1/23/2017, 2:46 PM

shmel: Please email me at: contact at divideframe dot com , and send me the log files localed in Documents/SpectraLayers Pro logs.

DivideFrame wrote on 1/25/2017, 3:34 PM

Bug fixed in 4.0.70: Windows installer / Mac Installer

dave_clark wrote on 2/24/2017, 9:50 PM

I am having a similar problem as shmuel but with 4.0.70 showing (0,2,0,2) for ASIO, SBZ Series, after crashing in trying to set up ASIO. Last night ASIO was fine and has been for months with dozens of audio programs including Pro X3 Suite and Sound Forge Pro. After installation of SPL4, ASIO no longer works.

This is either the most unfortunate coincidence I've suffered in quite some time, or SPL4 (when it crashed) somehow left my ASIO as "in use," or some critical dll has been corrupted or replaced. I have rebooted both warm and cold, uninstalled the entire SBZ driver package and reinstalled, etc. Are you (DivideFrame) doing something strange to lock out other ASIO programs that may cause ASIO to malfunction after a crash? There are programmers out there that have done things like this, but usually a reboot causes the offending process to halt and everything is fine after that. In this case, I'm suspicious that you have something weird going on which is causing problems after reboot. Any ideas about what might have caused this? Tests I could run?

Checking the error log, the first crash caused by attempting to change preference to Creative SBZ ASIO was:

Offending app: E:\Program Files\MAGIX\SpectraLayers Pro 4.0\Win64\SpectraLayers.exe

Offending module: E:\Program Files\MAGIX\SpectraLayers Pro 4.0\Plugins\Devices\rtaudio.dll


Another crash was similar, then a bunch of the following as I tried different things:

Offending app: E:\Program Files\MAGIX\SpectraLayers Pro 4.0\Win64\SpectraLayers.exe

Offending module: E:\Program Files\MAGIX\SpectraLayers Pro 4.0\Win64\MSVCR120.dll


Any thoughts on how these could cause ASIO to become corrupt or just stop working?

Checking the logs: No MS updates except for Malicious Software Removal Tool for Feb 2017 the night before this happened, but nothing was found by MRT, nothing removed, etc.

DivideFrame wrote on 2/27/2017, 5:09 AM

Hi Dave, could you give SLP 4.0.80 a try: SpectraLayers Pro 4.0.80 (unofficial)
(this version should go live this week I guess)

With 4.0.80, in the Devices Preferences, set the ASIO sample rate at 0, it should default to the preferred ASIO sample rate.
If it doesn't work for you, try forcing to the sample rate that matches your device sample rate.
If it still doesn't work, try using WASAPI instead of ASIO.

That said, SLP4 is not doing anything silly with ASIO, it has no way to interfere with how the driver is set up. It's just standard ASIO API calls as a client application, not messing with any internal ASIO settings or files. You could try deinstalling/reinstalling the ASIO driver ?

Hope that helps.

dave_clark wrote on 2/28/2017, 6:41 PM

Hi DivideFrame,

Thanks for your reply.

First, I should say that I contacted Creative Labs about the SBZ Series ASIO not working, and they suggested that I install Foobar 2000 with the ASIO output option, a nonstandard thing to do for a media player of course. When I tried all my DAW and WAV editor programs, they all started working again --- very odd and very unexpected.

Then I installed 4.0.80 per your suggestion and left the ASIO sample rate at 0. It worked for the first session, but when I closed the project, exited the app, then restarted SpectraLayers Pro 4, it stopped working. I get

"Device Error #1: Open Error #9: RtApiAsio::probeDeviceOpen: unable to load driver (Creative SBZ Series ASIO)."

When I next try to change Options -> Preferences... and Open ASIO Panel, SpectraLayers Pro 4 crashes with unhandled exception. Anything I now try to do to modify ASIO settings causes a crash.

All my other DAW and WAV editing programs still work fine now as far as I verified, even though SpectraLayers Pro 4 does not work (again).

In summary, 4.0.80 works only slightly better than 4.0.70 --- it allowed me to use it once with my preferred driver. I should say, however, that there were a lot of popping sounds in mixing three layers. It could be "overs," but I did not hear them with WASAPI, and when I merged all down, I did not hear the popping noises. So it worked not so well and only one time.

I'll follow up here if there is any more news.




DivideFrame wrote on 3/1/2017, 1:54 AM

Thanks for the feedback. Well, if WASAPI works for you, why not use it meanwhile ?

You can also send me (to contact at divideframe dot com) the log files located in "Documents/SpectraLayers Pro logs", it may give additional details.

MrSoundman wrote on 3/1/2017, 4:49 PM

Once I have set both the device and SLP preferences to the desired (same) samplerate, ASIO works flawlessly. ASIO is important because, even though latency is not an issue in an editor application, it guarantees that there is no "on-the-fly" sample rate conversion going on in the OS. That was certainly the case with previous incarnations of Microsoft multimedia drivers, and although I don't know enough about WASAPI yet to be sure, I hesitate to trust Windows and therefore prefer to use ASIO if that's an option.

The other issue is that ASIO drivers are the responsibility of hardware manufacturer, and in my experience, quality varies wildly. I have previously used (many) Creative cards over the years, which collectively cost more than the RME card I currently use. RME have rock-solid drivers that have never, ever given me trouble. That makes it worth it to me.

dave_clark wrote on 3/1/2017, 5:35 PM

Hi DivideFrame,

I have sent some example log files with descriptive filenames so you can see one example where it worked and several where SPL 4 crashed.

Like MrSoundman, I also prefer ASIO for everything if it's available, but don't have much choice with SPL at this point because it doesn't work properly, so WASAPI it is.

This is the first instance I've had of trouble with the Creative SBZ ASIO driver which I've been using for several years with dozens and dozens of audio programs (including my own plugin development), and through about three updates now.

I will experiment a bit with specification of the audio sample rate, but I would swear that I already tried that. (But thanks for the recommendation, MrSoundman.) On Edit: Didn't help...


Dave Clark

DivideFrame wrote on 3/2/2017, 1:58 AM

For what it's worth, WASAPI implementation in SLP always use the preferred device sample rate, and WASAPI is the official low-latency audio API since Windows Vista; in theory, you can get the same low-latency (or close) as ASIO. The way I see it, WASAPI is a modern replacement to the old ASIO API.

Regarding your ASIO problem, looking at the logs it seems the problem is with multiple ASIO driver loading/unloading - it's loaded once during SLP initialization so SLP is aware of every API/every device, then unloaded (at this point everything's fine), and loaded again when you open a project. At this point, it fails loading the driver. I'll keep investigate.

dave_clark wrote on 3/4/2017, 10:40 AM

Hi DivideFrame,

Also for what it's worth: The original WASAPI is not the same animal as is in Windows 10. When WASAPI came out for Vista, it sucked. Poor documentation, lack of support, etc. Also worth pointing out Official != Microsoft; Official != Best; and Official != MostPopular. Another little tidbit: Magix's flagship DAW Samplitude Pro X3 Suite does not support WASAPI, so you may want to talk with your own colleagues (sort of anyway) about this subject and let them know the "Good News."

If we could all get on the same page, I'm all for it!

Thanks for continuing to look at the ASIO problem.


Dave Clark


DivideFrame wrote on 3/4/2017, 11:57 AM

Not sure about Vista, but on Windows 7/8/10 it's the lowest-level native API, all other APIs (DirectSound, WaveOut/MME, AudioGraph, XAudio2...) go through it (except ASIO, but it's hardware dependent). So it's always my preferred choice whenever an audio app provides it.
I'd love Samplitude to support WASAPI instead of MME but it might be hard to change the core implementation at this point :)

Still working on the ASIO thing... Hard to repro without the Creative hardware though.
I wonder how ASIO4ALL would react on your hardware (though it might seem counter-productive since your hardware already support ASIO, it could give some clues).

MrSoundman wrote on 3/4/2017, 1:46 PM

FWIW, none of the other professional audio applications I use (WaveLab, Melodyne, Cubase) offer WASAPI as an option. I have never trusted Microsoft's audio stack and I still don't .... but I'd be happy to be convinced otherwise.

DivideFrame wrote on 3/4/2017, 2:17 PM

I guess it's because most started their development when WASAPI wasn't available, and ASIO was the best choice. Then other developers join the teams, and as time goes by, nobody wants to rewrite the audio path from scratch again. Proof of that, most keep their obsolete Windows API (Samplitude: MME and WDM, Ableton: MME/DirectX, WaveLab: MME) when the newer and more efficient WASAPI replacement is as close as it can be to the audio hardware. A couple exceptions though, the Adobe Audition team rewrote the audio path to include WASAPI. The same for Cakewalk when they decided to rewrite Sonar (Since version X). More recent DAWs such as PreSonus Studio One or Bitwig have built-in WASAPI support.
WASAPI is basically the equivalent of Core Audio on Mac.

Bob_Olhsson wrote on 3/4/2017, 2:57 PM

Pro Tools also has WASAPI support but only for motherboard audio. I agree its a shame more don't update.