Program will not open unless it is Run as Administrator

Redwagon wrote on 6/15/2018, 7:17 PM

I have a registered copy of SoundForge Pro 10 installed in my computer:

 

This past March I had to have my hard drive wiped due to a corrupt Windows file. I reloaded the SoundForge program from the Magix website and used it successfully until two months later, when the following problem occurred:

 

Clicking on the SoundForge icon results in the following message:

 

“Registration of Sound Forge Pro 10.0 requires elevated privileges.

If your user account does not have sufficent privleges, you will be prompted to provide administrator credentials.

After this step is completed, Sound Forge Pro 10.0 will be registered for all users.”

 

Clicking <Next> results in

 

“Do you want to allow this app to make changes to your PC?”

 

Clicking <Yes> results in no action.

 

Right-clicking on the SoundForge icon and selecting  <Run as administrator> opens the program.

 

I am already logged into the computer as administrator. I had the same problem in December of 2015, again after the hard drive had been wiped and the SoundForge program reloaded.

 

At that time I submitted the problem to Sony; and was was instructed to change a setting to administrator, which corrected the problem. Unfortunately, I failed to make a note of the setting in question or how to access it.

 

 

Comments

Redwagon wrote on 6/17/2018, 10:20 AM

Many thanks for your help. I'll wait for an opportunity to have someone more knowledgeable than me to work with the registry.

rraud wrote on 6/17/2018, 10:34 AM

The well known 'Elevated Privileges' issue is normally the result of Win 10 updates, and requires a registry tweak. Unfortunately. I have needed to do this a few times. This occasionally happens on Sound Forge Pro 11 as well... but  not on SF Pro 12.

 - WARNING: using Registry Editor incorrectly can cause serious, system-wide problems that may require you to re-install Windows to correct them. Use the tool at your own risk, Take the appropriate precausins like copying the entire registry and/or creating system restore point (or better yet a drive image), before doing anything. If you are not comfortable editing the registry, enlist someone with experience.

- Uncheck 'Run as Administrator' in the the Sound Forge Pro shortcut or the "100.exe" file in the 'x86 Program files' folder (right-click and select "Properties> Compatibility")

- Open the Registry Editor; Windows key + R, type regedit in the run dialog and press Enter key. Once in the Registry Editor, navigate to the following directory:
HKEY_USERS > [user SID]_Classes > VirtualStore > MACHINE > SOFTWARE > Wow6432Node > Sony Creative Software > Sound Forge [Pro or Audio Studio] > [Version Number]

NOTE: The [user SID] listed above is a variable and will usually be different for each account on a computer. It will most often begin with S-1-5-21-.
For instance, on my Win 10 laptop, it is:
"HKEY_USERS\S-1-5-21-1127706934-2234140011-1683470176-1001_Classes\VirtualStore\MACHINE\SOFTWARE\WOW6432Node\Sony Creative Software\Sound Forge Pro\10.0"

- Right click the "10.0" folder and select 'Delete'. Confirm you wish to delete the folder if prompted.

- Close the registry editor. SF should now start and run normally without the annoying Elevated Privileges issue.

Redwagon wrote on 1/1/2019, 8:10 PM

Being very reluctant to mess with the registry, I lived with the problem. However, after installing version 1809 of Windows 10, the problem went away and I can now open SoundForge 10 without administrator privilege.

Michael-Mele wrote on 8/24/2020, 12:18 PM

I am running S.F. 11 and not able to find a work around. I am an administrator on my account and have permission access. Yet still am met with elevated privileges required- I click next and asks to make changes to computer I say yes and nothing happens. Any insight would be appreciated. Thank you.

rraud wrote on 8/24/2020, 1:34 PM

I would try the above registry tweak., I have read reports of the same issue with early builds of Pro 11. If you do not want to delve into the registry, download the latest Pro 11 build from the Magix Download Center and reinstall Pro 11. You should not need administrator privileges when SF is working ok and not have to click on the annoying 'run as administrator' every time your launch or import a file.