SF 14 Opening sample rate

Peter-Bailey wrote on 11/26/2020, 12:40 PM

My computer win 10 latest edition and Focusrite Claret interface are set to 48khz. When I open soundforge 14 suite (latest update) it forces the sound interface to 44100. Only when i create a new sound file and set it to 48khz does it then change back. Soundforge has been doing this for a long time. How do I get soundforge 14 to open at 48khz? Vegas Pro if i recall can have a sample rate set so the problem does not occur. Wave lab 10 pro doesn’t have this errant behavior. How can I set SF 14 to 48khz on opening. I don’t want to faff about and have sf 14 interfering with the sample rate to 44100 on startup. Whatever windows setting I state ie dont allow apps to change setting makes no difference. Magix blame Focusrite, so wont help. I cant be the only person with this issue. I cant find settings to make sf 14 open at 48khz and saving files at 48khz does not make sf 14 stay at the last sample rate. I have cúbase pro 11, Ableton 11 suite on its way, Reason, wavelab 10 pro and all these products work and do not have this behavior. I know it’s happening as windows notify shows me that the sound card sample rate changed and of course the annoying click. You might say well use wavelab but I love the SF 14 interface and use it for quick narration but this startup issue I hate. Help would be appreciated as maybe I missed a setting somewhere but I dont think so.

Comments

rraud wrote on 11/26/2020, 2:16 PM

Are you saying, when opening a 48kHz file it plays back at 44.1kHz? (slow and pitched down)

SF should open an existing file at whatever file's the sample rate is. When selecting a "New File" (window) to record. the sample rate is set at the last recorded one, or can be re-set in the drop-down context menu. Also, confirm that "Open default workspace on startup" is check-marked in "Options> Preferences> General"

You may try re-setting SF to the default settings and clearing the cache, in the 'File' menu. Then open the "Internal" menu tab in "Options> Preferences> and manually change the new file sample rate value to 48,000 .. about fifty or so entries down the list

Sorry, but Focusrite interfaces are known to cause flaky behavior in many applications. I had an Echo interface that locked SF to 44.1, The Echo had a setting to unlock it though.

 

Peter-Bailey wrote on 11/27/2020, 7:36 AM

No, no, I am just talking about when Soundforge 14 opens with no file in the workspace. Let me try your suggestions. This was ok Also, confirm that "Open default workspace on startup" is check-marked in "Options> Preferences> General" I can't find the tab "internal" ... Then open the "Internal" menu tab in "Options> Preferences> and manually change the new file sample rate value to 48,000. Should I create a new file before that point?

Peter-Bailey wrote on 11/27/2020, 7:58 AM

When I opened this time it has resolved the problem. I think the resetting did it. Thank you very much.