SF Audio Cleaning Lab - Spectral Editing Problem

toddbooster wrote on 2/20/2019, 8:00 AM

Hi all,

I'm demoing the new Sound Forge Audio Cleaning Lab, and it does not seem to be possible to apply spectral edits to a 96 khz wav file. It works fine at lower sample rates, but at 96 khz, applying the edit calculates the audio effect, but makes no changes. I assume this isn't just a demo limitation, and I can't find any documented limitation as far as supported sample rates, so I'm hoping someone can tell me if this is a bug, or if I'm doing something wrong. Thanks.

Comments

toddbooster wrote on 2/20/2019, 11:24 AM

In fact, I've just noticed that while you can import and play 96 khz files in AF Audio Cleaning Lab, saving the VIP converts the audio file to 44.1 khz, which is a bit obnoxious.

emmrecs wrote on 2/20/2019, 2:01 PM

Hi, welcome to the Magix forums.

I think you are entirely correct!

I never use 96kHz files so this was something of an experiment for me. I imported a 96kHz file to ACL and the Info tab told me it was resampling the file, to 48kHz. I discovered that it was locking my external audio interface to this frequency (i.e. I could not reset it to 96kHz whilst ACL was open). So I closed ACL, reset the sample frequency of my interface and reopened ACL and the file now could not be played, presumably because ACL could not communicate with the MOTU audio interface.

I checked the Options>Playback parameters and saw the screen below; clicking on the ? opened the second screen, where apparently ALL the available Sample Rates are listed, nothing above 48kHz.

Even with my audio interface set to 96k any exported file became 48k! Not good!

I think the problem MAY be caused by the fact that, as shown on the lower screen in the screenshot, ACL does not/cannot use an ASIO driver (I have a fully-installed and operational MOTU ASIO driver, as well as ASIO4All; neither are shown as driver options.)

@toddbooster I think you should report both these as bugs. I cannot believe that it was intentional that ACL should not be able to, either, operate at higher SR frequencies than 48kHz, or, that it should not be possible to use an ASIO driver. As I said before, personally I have no need of the 96kHz option but for those who do, like yourself, it certainly ought to work.  Please use the Contact button in the footer of every forum page to raise a Support Ticket.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

toddbooster wrote on 2/20/2019, 5:14 PM

Hi, welcome to the Magix forums.

I think you are entirely correct!

I never use 96kHz files so this was something of an experiment for me. I imported a 96kHz file to ACL and the Info tab told me it was resampling the file, to 48kHz. I discovered that it was locking my external audio interface to this frequency (i.e. I could not reset it to 96kHz whilst ACL was open). So I closed ACL, reset the sample frequency of my interface and reopened ACL and the file now could not be played, presumably because ACL could not communicate with the MOTU audio interface.

I checked the Options>Playback parameters and saw the screen below; clicking on the ? opened the second screen, where apparently ALL the available Sample Rates are listed, nothing above 48kHz.

Even with my audio interface set to 96k any exported file became 48k! Not good!

I think the problem MAY be caused by the fact that, as shown on the lower screen in the screenshot, ACL does not/cannot use an ASIO driver (I have a fully-installed and operational MOTU ASIO driver, as well as ASIO4All; neither are shown as driver options.)

@toddbooster I think you should report both these as bugs. I cannot believe that it was intentional that ACL should not be able to, either, operate at higher SR frequencies than 48kHz, or, that it should not be possible to use an ASIO driver. As I said before, personally I have no need of the 96kHz option but for those who do, like yourself, it certainly ought to work.  Please use the Contact button in the footer of every forum page to raise a Support Ticket.

Jeff

Thanks Jeff. I'm still not sure if this behaviour is intended or not, but I did eventually figure something out after reading your post. It seems that if I open Options>Playback Parameters, and set that to 96 khz (it allowed me that option, despite having a MOTU interface as well - Ultralite AVB if it makes a difference) before importing the audio file, it works normally and the VIP saves the file without re-sampling. However, if I forget, and import the file with the wrong sample rate set, it will be re-sampled and can't be changed.

I think you're right about ASIO, as that's obviously why it's not changing sample rates based on the detected audio files. I have WASAPI as an option, and I'll try that next to see if it makes a difference.