SF Pro 15 latest update 5/5/21 will not allow my custom keyboard cmds

BScott-Fischer wrote on 5/6/2021, 11:45 AM

SF Pro 15 latest update 5/5/21 will not allow my custom keyboard commands. I've always used Alt N for insert silence, as it's just easier when editing...now it is listed but the latest build does not allow it. I tried changing it to Alt B...it just won't save or recognize either.



rraud wrote on 5/6/2021, 12:57 PM


Thanks for the heads up @BScott-Fischer.

The Alt + N keyboard shortcut does not seem to work for any global command.
In the new build 57, Alt + N is now 'Envelope Tool' by default in the data window view, but that does nothing globally. I will check it out further ASAP.
Alternate key commands for "Insert silence" worked though.

FWIW, the Build 57 release notes state:
>>   Export
o    Fixed menu not appearing in some situations:
o    Added "Export with Previous" feature that allows to apply the last used export preset·

>> Instant Action
o    Fixed scroll-bar that intermittently wouldn't show up on program start-up
o    Fixed User Entries group that appeared empty on program start-up

>>   Batch Converter / Export Dialog
o    Added "Same as Source" render option and set as default for new/empty presets
o    Improve focus of text fields when saving presets and creating folders
o    Set maximal length from preset name
o    Small User Interface fixes

>  Fixed length calculation issue for short MP3 files with ID3v1 tag
>  Updated some help file

>>   New Shortcuts for the Data Window
o    Alt + D - Edit Tool (Strg + D is still available too)
o    Alt + E - Event Tool
o    Alt + M - Magnify Tool
o    Alt + N - Envelope Tool
o    Alt + P - Pencil Tool



xman_charl wrote on 5/9/2021, 1:50 PM

Use insert silence quite a bit...

Why I use insert silence...

Record radio shows, edit out commercials, add about 05 silence where commercial was

then mix a leadin music... silence area, so I know this is start of another segment

so its about 5 or 7 silence inserts into audio file...

Use Xkeys Programmable keypad, software is MacroWorks 5.1...

Just press a designated key for insert silence, bam....insert silence

My macro for insert silence..... ALT + SHIFT + S

NOTE: Macros will not work, unless sound forge is ran with Administrative Privileges ! ! !




rraud wrote on 5/10/2021, 4:01 PM

btw, @BScott-Fischer, if you really want to use Alt+N for insert silence (or other process) append the key command with a second N. Alt+N+N

btw, the other new default shortcuts do not work either and cannot be used w/o appending the key command. The deep-thinkers (developers) are being notified.

BScott-Fischer wrote on 5/10/2021, 4:19 PM

Thanks very much rraud!!! I really appreciate your help every time I seem to have an issue...you are there for me and others...very grateful. I solved it on my own by changing Alt+N to Alt+B. It seems to be working fine now.