SF Pro 17 - Cannot save changes when using Tools repair option

rbh69 wrote on 5/26/2024, 4:04 PM

Any help much appreciated. One of my favourite tools will not work properly. Using SF Pro v17 to record some of my old vinyl, saving in flac format, 24 bit. Then using repair option to manually remove random clicks in the recording, using Interpolated option under Tools - repair. After removing clicks and confirming clicks are no longer audible, I save the existing file and all clicks have returned to the waveform, and are visible and audible. No different if I do a new Save As, or use the Export option, or project/ rendering option. Other methods for removing clicks & noise, such as audio restoration (under Tools), RX de-click, save normally with changes intact. Any advice on why this is happening? I have previously used this tool without these problems.with earlier versions of SF such as SF11 pro. Happy to provide more info of course.


SP. wrote on 5/26/2024, 4:49 PM

@rbh69 Flac is a compressed file format. I often read in this forum, that users have problems with audible or graphical glitches and it often looks like this is caused by compressed file formats which are maybe handled differently in current versions of Sound Forge.

I would recommend you convert and edit uncompressed WAV files instead.

There is a option in the Sound Forge preferences to always proxy compressed audio files which will do this automatically.

Only the final export should use a compressed file format.

rbh69 wrote on 5/26/2024, 7:19 PM

SP. Thanks very much for the feedback and suggestions. Have tried converting an existing file to .wav and a new recording as well. Also changed the proxy compressed setting as suggested. Still not saving the changes when using interpolated repair tool. Will keep exploring ...

rraud wrote on 5/27/2024, 10:42 AM

The 'Replace' and 'Interpolate' tools which I use extensively, have always functioned normally in my experience.
Is Sound Forge re-opening the rewritten 'Save-as' file? "Automatically reopen file after Save-as" may be disabled in the "Options> Preferences> General" menu. You may be listening to the re-opened original file after Save-as.

btw, welcome to the Magix Sound Forge users community @rbh69.

rbh69 wrote on 5/27/2024, 7:27 PM

Thanks rraud. Still trying to resolve this issue, have tried changing the settings as you suggest, along with the other ideas already suggested. When I re-open the saved files it saves changes by '3rd party' options such as Noise Reduction and RX for example, saves changes such as volume from the core programme but does not save the Tools - repair work that I am doing. This applies whether I use flac, wav, save, save as, render, export or project to work with the file. They are files I have recorded myself through SF. Wondering if there is some clash with previous configuration/ drivers from having SF11 on this computer in the past (it was deleted before installing SF17). I am clearly missing something? Anyway still working on this issue and other ideas very welcome.

rbh69 wrote on 5/28/2024, 4:57 PM

Resolved. I needed to take a slightly bigger sample of the waveform before replacing. Then it saves the changes. Was confusing because the 'spike' of the click was being removed from the waveform with a smaller sample but would not save until I increased the sample size. Subtle but important distinction as it turns out.