Comments

DivideFrame wrote on 2/12/2017, 4:21 AM

Hi MrSoundman, let's try with SpectraLayers Pro 4.0.76 : once installed, go to the audio settings/ASIO, force the sample rate to a sample rate matching your ASIO hardware, then click "Show ASIO Panel" and let me know.

MrSoundman wrote on 2/12/2017, 7:10 AM

That's working now, thanks, but you have to click OK and go back into preferences before the value is applied. For example, if the forced value is 44100 and you change it to 48000, then click "Show ASIO Panel", the hardware is still set to 44100. If you change the forced value to 48000 and click OK, then go back into Preferences and "Show ASIO Panel", the hardware has now changed to 48000. I would not regard that as a major problem though.

DivideFrame wrote on 2/12/2017, 7:55 AM

Thanks for the feedback. Not sure why this happens (it may be hardware-specific, I can't repro that here) but let's call it fair enough :)

MrSoundman wrote on 2/12/2017, 9:16 AM

Presumably the change is only sent to the driver when OK is clicked, not on leaving the "Force sample rate" textbox. One other suggestion would be to query the driver for a list of valid sample rates and only allow those from a drop-down list.

The hardware I'm using has a minimum sample rate of 32kHz which is probably why it defaulted to that initially. Now that I've set it specifically in SLP Preferences I can pretty much leave it like that.

johnebaker wrote on 2/14/2017, 4:22 AM

Hi

. . . . Presumably the change is only sent to the driver when OK is clicked, not on leaving the "Force sample rate" textbox. . . . .

Where ever you get a dialog with either an OK or Apply button, or both, standard practice is that clicking the X button or pressing Esc on the keyboard is the same as Cancel - no changes will be applied.

John EB

Last changed by johnebaker on 2/14/2017, 4:22 AM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

MrSoundman wrote on 2/14/2017, 12:52 PM

Yes, basic usage, but that is not the issue. When you open Preferences for the very first time e.g. after installation, the "Force sample rate" textbox is pre-populated with 0, an non-valid value for sample rate, and this is sent to the driver when you click OK. With my specific hardware, this resulted in the lowest allowable sample rate being selected, namely 32kHz.

This is fine once you know that you have to type in a valid sample rate first, provided you also know what the valid sample rates are for you hardware.

No other audio software I've used does it this way though .... with other applications, the ASIO driver is queried, only valid sample rates are allowed, and the default is whatever the driver (hardware) is currently set to. A change is made only if a file or project is subsequently opened which has a sample rate different from the current hardware setting.

DivideFrame wrote on 2/15/2017, 10:32 AM

Here's SpectraLayers Pro 4.0.78 : when the sample rate field is at 0 (default), then the preferred ASIO sample rate is used (usually 48Khz but depends on the device/device settings).

MrSoundman wrote on 2/15/2017, 4:24 PM

Confirmed, 4.0.78 will default to 48kHz if set to 0, and will not allow invalid sample rates to be set!