Silence when applying plug in chain

Edward-Ulloa wrote on 7/29/2020, 3:19 AM

Hello - does anyone know how to prevent getting silence when applying a plugin chain to a file? I keep getting a few seconds of silence at the beginning and then the file cuts in abruptly where the silence ends. The rest of the file has the plugin chain applied successfully. I'm using a mix of plugins (IK Multimedia, Izotope, Eventide) and I've tried both the VST2 and VST3 versions. Thanks for your help!

Comments

rraud wrote on 7/29/2020, 9:26 AM

- What version of Sound Forge (Pro-14)?
- Is this present after rendering or just in preview?
- Which chainer mode (Fx Favorites> Apply plug-in chain)?
 - An improperly set 'Noise Gate' initially comes to mind.

Try bypassing or removing one plug-in at a time to ID the offender. Then look at the settings or eliminate, substitute or apply outside the chainer.

 

 

Edward-Ulloa wrote on 7/29/2020, 2:50 PM

Hi

- Sound Forge Pro-14
- Is this present after rendering or just in preview? Present after rendering but when in preview it's not there, however while previewing, there are always artifacts like a small cut in the start of the file or a snippet of the file playing.
- Chainer mode - yes: Fx Favorites> Apply plug-in chain (is there a way to apply the plugin chain from View - Plug-in Chain? I can set up the chain but no way to apply - only from the FX Favorites menu. There seems to be less artifacts from the view menu. When I close the View - Plug-in chain it seems to do something to the file although I didn't apply anything because there's an indicator (*) to save)

No noise gates in use that I could see. I'll try the "one at a time" approach to see what I could find. If I use FX Favorites and just use one plugin, there are no artifacts or silence so must be something in the chain. Are there any settings to adjust for latency (like in Pro Tools)?

Thanks for quick response! -Ed

rraud wrote on 7/29/2020, 6:08 PM

Are the media files something other than PCM. If so, go "Options> Preferences> General" and check mark, 'Always proxy compressed formats'

In the Fx timeline mode, effects are embedded when the file is rendered ('Save as' .. or 'Render as' when using SF project files.<.frg>. btw, most plug-in automation is not available in the Fx Favorites, 'Apply to chain' mode. So try the chain directly on the timeline

Latency adj are not needed in SF.

Edward-Ulloa wrote on 7/30/2020, 2:52 AM

No all files are 44.1k 16bit WAV PCM. After trying several different scenarios, and the plugins one at a time, I noticed that I get more success with the timeline mode versus apply to chain. If I do any little bit of tweaking the presets, I get silence - whether it's one or several plugins. The workaround I found was that I tweak until I like the results (also using Tonal Balance Control 2), save the preset, close and re-open the file, open View > Plugin Chain starting with an empty chain, add the plugins (except tonal balance control), load the presets I saved earlier and render. This worked most of the time but not always. I also noticed that processing heavy presets (EQs) were more likely to cause silence.

rraud wrote on 7/30/2020, 10:35 AM

ISIO audio device drivers are known to cause problems with some plug-ins.

I do not have any IK Multimedia or Eventide plugs. My iZotope, Plug-in Alliance, Waves and most others, preview and render w/o issue with Classic Wave or Sound Mapper drivers. Some folks experience issues with Wave plug-ins and ISIO-4-ALL

Edward-Ulloa wrote on 7/31/2020, 6:05 AM

Hi - ah I see - I do use the ASIO driver when I'm really mobile on my laptop with headphones. But haven't been using that driver lately. Here are the choices I have:

Micrsoft Sound Mapper

Direct Sound Mapper

Windows Classic Wave Driver

ASIO4ALL v2

Focusrite USB ASIO

I've been using the Focusrite USB ASIO since I'm working at home on my speakers and use this audio device.

I'll try each of these audio drivers to see if any will not silence the beginning. Thanks!

TOM-HAMILTON wrote on 1/12/2021, 9:26 PM

Has this been solved? I have the same issue. I had this issue with SF 10 and now 14. I saw a thread complaining about the same thing on MAC (I'm on PC), and they talked about Sandboxing ..

 

johnebaker wrote on 1/13/2021, 10:14 AM

@Edward-Ulloa

Hi

. . . . I've been using the Focusrite USB ASIO since I'm working at home on my speakers and use this audio device. . . .

Assuming you are using a Focusrite Scarlett and have you speakers/headphones plugged into it, the device could be the cause of your issues - this is a known issue with the device - try unplugging it and use the same drivers as your laptop and the computers audio card - if you hear the audio, try reinstalling the Focusrite drivers and use a different USB port.

HTH

John EB

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021.

Running Windows 10 Professional 20H2 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 3 x 2Tb internal HDD + 60GB internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Edward-Ulloa wrote on 1/13/2021, 10:11 PM

Hi All - sadly never really found a solution to be consistent. (I've tried John B suggestion too.) I just changed my workflow depending on what I'm doing. For straight mastering, I use Sound Forge with any of my various plugins (IK Multimedia, izotope, etc.) and save my IK presets for each device. Then I finish my mastering projects and render in IK TRacks. Otherwise I use sound forge normally for editing and any DDP or red book CDs. It's inefficient but I've gotten used to it and forces me to save presets for each song im working on.