SOLVED - Error 0x80131700. Failed to Bind to MS Common Language Runtime Scripting Host failed to start up.

bengalstripes wrote on 10/7/2016, 10:16 PM

After updating to the latest Windows 10 (I think it was 1607), opening Sound Forge Pro 11 produced the following error:

Error 0x80131700. Failed to Bind to MS Common Language Runtime Scripting Host failed to start up.

Looking on the Internet, I stumbled across a couple of posts, discovered this forum but no solutions.

Well, I had a gut feeling that I knew what this was about and I was right. Basically, the last Windows 10 update seems to have disabled some .Net framework components. That's the bad news.

The good news is that it's really quite easy to restart them...

1. Go to the search point next to the Start menu and type 'Windows Features'.

2. 'Turn Windows Features on or off' will appear.

3. Click on this. You may be asked for your Administrator password, so enter it.

4. At the top of the list, you will see '.NET framework 3.5 (includes .Net 2.0 and 3.0)'. Expand this item and check the check boxes next to the two items that drop down and ensure that the main item is also checked. Press OK.

5. You will be asked to confirm the download of some additional components. Do so and let the system do its stuff.

6. You'll be prompted when the process has completed.

7. Close the panel. You do not have to restart your computer. Fire up Sound Forge and it should open without the annoying error.

On a side note, I have Sound Forge Pro 11 installed on a couple of machines in my studio and this error has only appeared on two of them. All computers have been updated to Windows 10 release 1607. Weird or what?!?!?!

I hope this helps some people.

Comments

Cielspacing wrote on 10/19/2016, 9:54 PM

Thank you bengalstripes your post is one of the best examples of a good "users for users" forum post.
I have a long story of dealing with Windows configuration but is my first time that I see you may actually tinker with the .NET Framework; well done. 
///I am saving this in my Soundforge Installation folder for future reference, and will also remember it for similar cases with other software.
 

fprstudio wrote on 1/3/2017, 6:49 PM

Thanks a million!!! bengalstripes

It works and by doing this I also could install DVD Architect Pro 6  😁

bengalstripes wrote on 1/5/2017, 5:21 PM

Thank you for the kind comments, guys.

So many people put up good stuff that really helps others and on this occasion... well, it was my turn for a change. Glad I could put in a little.🙂

kenneth-berrier wrote on 1/29/2017, 12:38 AM

Worked like a charm! Thanks!

bengalstripes wrote on 1/31/2017, 10:39 AM

Happy to have helped, Kenneth.

My SoundForge is still working just fine, nine months later.

I actually have SoundForge installed on two machines. Both machines are identical in terms of hardware and software. In fact other than the obvious licenses, the boot drives are clones of each other.

This problem only happened on one machine. Why? I never bothered to get to the bottom of it. Just so glad that the .net hack worked.

mp4music wrote on 9/10/2017, 12:49 PM

Just what the doctor ordered; Thanks Bengalstripes; You de man; The Disco Daddies!! :D

Studiochap wrote on 9/12/2017, 5:58 AM

Thanks Bengalstripes! I had this on one machine a couple of weeks ago...didn't chase it then. Had it agin installing on a second machine now., googled, and 2 minutes later problem solved - thanks to your post!

rachelsound wrote on 10/2/2017, 5:32 AM

Thanks a million for this! Not only did it fix the error but it also fixed my problem with the Batch Converter. If anyone else finds their batch converter is greyed out they should give this fix a try. Thanks again :)

bill-byers wrote on 3/12/2018, 11:31 PM

Thank you this answered my question.

Khaled-Selim wrote on 8/18/2018, 2:29 PM

Thank you for saving me from hours of frustration!

depascla wrote on 10/16/2018, 6:06 PM

Grazie Mille, ho risolto il problema dell'errore, ora suono forgiamo perfettamente senza quel fastidioso meggio all'apertura del programma, era molto frustrante. Grazie ancora

igniz-krizalid wrote on 3/11/2019, 10:21 PM

Thank you!

eduardo-nolazco wrote on 5/2/2020, 8:34 PM

Thanks a lot! I have Windows 10 Pro. Version: 10.0.18363 (Build 18363).

This message appeared with Sound Forge Pro 11. I did what you shared and it works! No more annoying messages

sentier34 wrote on 8/12/2020, 3:21 PM

Many thanks. Works OK