Sound Forge 11.345 still damages sound files

ReverendLove wrote on 12/31/2016, 11:57 AM

Dear forum members

The bug which is alive since SF 9 still exists and destroyed files recently. Last one was a 24bit flac at 44.1k.
You can read about it in the folowing links:

So, if you have a workaround for the issue mentioned above I would be very pleased.

Audacity's recent version like all my other applications have no problems like this with the same file.
So it seems encoded correctly.

Best regards


rraud wrote on 3/13/2017, 3:47 PM

I have never read of or encountered that problem. I've been a SF user since ver 3 and active in the defunct SCS Sound Forge forum since around 2001.

ReverendLove wrote on 3/13/2017, 4:04 PM

That doesn't really help.
I just had it yesterday again.
And those messages above I applied are from the old scs-forum which is mirrored on magix site.
Im with SF since 4 iirc.

noisywan wrote on 3/30/2017, 9:12 AM

Do you get the same result if you open one of those files manually and save as FLAC, without using the batch converter?

ReverendLove wrote on 4/1/2017, 5:43 AM

I didn't use the batch converter at all. It happens if I apply any process or effect to an imported flac file. Even resaving it mutes a part at the beginning or the end.

noisywan wrote on 4/1/2017, 6:13 AM

I didn't use the batch converter at all.

I thought you did because you said it in your message;

" This is the first time I've actually needed to use the batch processing function and..."

Well looks like I'm confused. All I can suggest is to remove any 3rd party codec pack or any other apps that might have installed or modified codecs that Sound Forge uses. Good luck.

ReverendLove wrote on 4/1/2017, 8:52 AM

Yes, I wanted to use the batch processer but encountered the misbehaviour before using the BP at all when I tried to compile some tracks into a CD project. If you read my linked posting in my third post you can see that there has been done a lot by me. I can only state that there is obviously a decent lack of interest from magix fixing this issue. That leaves me somewhat worried.

noisywan wrote on 4/1/2017, 9:20 AM

I have read the board messages and I'm still not sure what to do exactly to recreate the bug you wanted to report.

I think the key to report an issue is being brief and clear in explanation. I suggest posting a step-by-step instruction that recreates the bug so people can easily test it. If you get enough bug-positive test feedbacks then you can open a ticket.

BTW I have tested converting a WAV to FLAC with SF10 and SF11 on my 2 different Win 7 SP1 systems. No issues here.


ReverendLove wrote on 4/1/2017, 3:25 PM

Well. If you had read the linked posts carefully you cannot deny that this issue is well documented, reported repeatedly and I reported exactly step by step like the other people what I did too. This issue is reproducable if you use the same files. You cannot reproduce it intentionally. It does not really help me if you cannot reproduce it. And it does not mean that it does not exist. It mutes decoded flac files at the beginning or the end. Randomly. There is nothing remarkably different to another flac files which didn't get damaged. They stem actually from the same batch of encoding I did once with flac.exe. If you'd read my mentioned post you must have recognized the last answer by magix which is at best purpose a helpless face saver. But for me it's still a petty excuse.

And at last I will not open a ticket anymore due to this bad experience with the German help desk. I can waste my time and dupe myself better. I just hope that other folks here with more experience here in these forums can help me. I am with SF since v4 or 5.

ReverendLove wrote on 4/1/2017, 3:29 PM

BTW: I am not the guy of the first linked post who wants to use the BC. I just encountered the same issue.

noisywan wrote on 4/1/2017, 4:13 PM

To be honest, I did not read all of it.

This issue looks like a `standarts war`. 
There used to be a bug like this in Vegas and SF, not saving the markers dropped in Trimmer when you edit a file rendered with Protools. You needed to open the file in SF, do a little modification like trimming a few milisecs and save over it to make sure the SF creates a section in file for saving marker data properly. What I'm trying to say is, it might be an app that creates non-standart headers and tags in the audio file, that makes SF think the audio data ends sooner than it actually is. 
Such issues are not considered as bugs so they ignore it. Both companies think their app is the one that defines the standards (Protools, SF, Vegas, Adobe, Winamp etc) so they keep on doing what they think is the`standart`.

You need to help them pinpoint the issue by providing files and instructions to recreate and isolate the bug.

I'd be glad to confirm if you showed me a simple way to reproduce it like this;
1) open the file I uploaded
2) convert to FLAC
3) reopen and modify


so we can see the truncated file.

I'm a SF user since v4.0 too, the times when Vegas used to be 2 separated applications ,Vegas Audio and Vegas Video. I've also reported many bugs to S.Foundry and Sony. What they always expected is to reproduce the bug. They can't help you about a `random issue` because there is no such thing as a `random issue`. 
There is always a reason for it. You call it `random` because you can't pinpoint the exact cause. 

There are many people out there trying to have a solution for issues caused by their cheap HDD controller, motherboard chipset, a 3rd party plugin, a pirate copy, poorly coded apps that destroy common files that other apps use, etc. from unrelated developers and support.


ReverendLove wrote on 4/1/2017, 6:19 PM

Sorry noisywan, - and thanks for your effort.
I don't and did not want to sound harsh but I don't need your confirmation of this issue because it is confirmed not only in the answers of support and in the linked entries several times. Read the archived forum and you get some more. I want solutions, no confirmations.
I don't want to go throught this again like in a Franz Kafka novel too.
If you'd read the post regarding my support ticket you would have to realize that there weren't any (de-)codecs involved but original FLAC.EXE and SF's own. Files which were encoded in SF had the same issues. SF USES HIS OWN ENCODER! FULL STOP. (Sorry for getting loud.) Obviously the staff does not know this elementary matter. I needn't any bulk packages of this kind before. Only magix suggested to install them in the first reply in lack of basic knowing of their own products. I got rid of this crap packages right after this unpleasent and unkind affair with support.
Read the four mails linked in my first post. This thing is no fantasy of a SF-Hater (what I am obviously not) but a proof for magix' an sony's blaming customers, competitors and probably any each other but themselves.
And I already have a workaround. If I decode the concerned files with flac and import them to SF as WAV or any other RIFF. Then SFs handles them correctly. But this is tedious because all my recordings before 2016 are encoded to FLAC44.1/24. Correct behaviour would ease my work substantially.
I cannot understand that SF is incapable to do this elementary task of importing FLAC or MP3 files. And chance is 1 to 20 that something gets destroyed. Any other application can do this without issues with the absolute same files.
But really worse were the replies of magix which took my trust from SF.

noisywan wrote on 4/1/2017, 9:01 PM

Sorry dude but you need to calm down. 

You said you already have a workaround for the issue but your 1st post on this thread asks for a workaround from the forum members. What do you want people to do? Boycott Magix and use Audacity? Demand a refund for you from Magix? 

One member said "I have never read of or encountered that problem" and you replied "That doesn't really help."
What kind of help are you looking for from the forum members?
If I were you and I needed help, instead of posting links of messages from 2009 that contains no material to reproduce the issue, I'd post the WAV and the FLAC file here, and a clear instructions to reproduce the truncation. Your claim is about SF v9 from 2009 till today and this sounds a bit `unbelievable` for me.

Looks like you don't need help from the forum members who haven't encountered this problem, so good luck with your quest.