Sound Forge 11 after Windows 10 upgrade

MusicFan007 wrote on 11/18/2017, 6:35 PM

SF 11 has been working without problem since instillation 3 months ago. Yesterday I endured the 90 plus minute upgrade of Windows 10. Today, SF 11 does not recognize my desktop where I keep music files I've recorded. Pulling down and clicking on "open" does nothing, when it previously would show all file names on the desk top allowing me to import what I wanted. I made no adjustments to SF 11 since it was installed 3 months ago. I see Magix does not provide tech support for SF 11. Ideas what is happening? Places to go for tech support? All input appreciated. Thank you. I've got a DELL xps system, with the tower.

Comments

rraud wrote on 11/18/2017, 7:34 PM

Very likely the (common) 'elevated privileges' issue.. Try right-clicking the "Forge110.exe" or shortcut and select "Run as administrator" which should open SF, however it will not be a permanent fix. For that, a registry tweak is necessary. See the below link which states what to change...and it would be nice if our friends at Magix could at least offer a patch.

https://www.magix.info/us/forum/sound-forge-requires-elevated-privileges-fixed-in-the-magix-version--1177664/

johnebaker wrote on 11/19/2017, 4:18 AM

Hi

. . . . my desktop where I keep music files I've recorded . . . .

It is not good practice to keep your recordings and any other user files, on the Desktop.

The correct location for storing them is the Documents folder which is a protected folder from the effects of a system restore and Windows upgrades/patches.

The Desktop is not a protected folder, if you do a system restore any changes you made to the desktop, ie saved further recordings or other files to it, can be lost, the same applies to a Windows upgrade or update if it makes changes to the desktop.

Does SF recognise the Documents folder without running as Administrator or applying the fix recommend by rraud?

HTH

John EB

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021.

Running Windows 10 Professional 20H2 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 3 x 2Tb internal HDD + 60GB internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

MusicFan007 wrote on 11/19/2017, 8:00 AM

Thanks to rraud and johnebaker. John: Your information about desktop versus folder is something I did not know and will consider. The nagging factor is that having the files on the desktop keeps me actively removing them asap, versus the old out of sight out of mind.

rraud: I followed your link to the Nick Hope piece. Not surprisingly (for me) I'm stuck at the beginning, being unable to find the Registry Editor. Directions? I'm a long time computer user who knows little how they really work. So, can you point me toward the items you mention: "Try right-clicking the "Forge110.exe" or shortcut and select "Run as administrator".

Thanks in advance.

rraud wrote on 11/19/2017, 9:41 AM

SF Pro 11 is typically located in "C:\Program Files (x86)\Magix\Sound Forge Pro 11.0\Forge110.exe" (however, an older SF11 build would be under 'Sony'). A shortcut (link) can be placed just about anywhere, most put it on the desktop. Same goes for 'in progress' audio files. (right-click your audio file and select "Send to> Desktop (create shortcut)".

A few different ways to access the Registry, I usually just type in the decades old Windows run command (windows key + R) "regedit". However if you don't know what your doing, stay out of there and enlist someone with experience, as serious damage is possible, rendering your entire PC unusable. Again Magix should develop a fix for this common 'elevated privileges' issue.

I did not know the 'Desktop' (user folder) is "unprotected" either but have never had any problems (I rarely put any files there anyway, just shortcuts to the actual file or application).

MusicFan007 wrote on 11/19/2017, 11:27 AM

Thanks again to rraud. Good news was that following your notes I was able to locate the "run as administrator" button, click on it, click yes and the world appears not to have ended. The bad news is that the problem remains, clicking on "open" does nothing. Your first note indicated that this would not be a permanent change. I'm guessing I'm better running it as an administrator than not, but how long does the condition last, one session, more? I noticed when I went back into the application and went to run as administrator it acted as if I hadn't done it already. I didn't repeat the step. Anything thing you can pass along is much appreciated. And any other thoughts on this particular problem. Thanks

MusicFan007 wrote on 11/19/2017, 11:41 AM

Some more grist for the mill. Hitting the "new" button brings up an empty but visible panel. At the bottom of the tab are recently accessed files with this address - C:\users\myname\Desktop\file name. Selecting the most recent (still on the desktop), it appears in a normal panel and plays as normal. So it appears there is some functionality, but for some reason the open button is not giving me any fresh selections. I'll say too that at the same time, my recording application (Total Recorder) ingests the audio (meters move, time elapses) but it refuses to save the file (default is to the desktop). I have an email off to the TR folks on the matter, but the common point seems to be the desktop. I'm sure at some point this will all make sense.

johnebaker wrote on 11/19/2017, 11:55 AM

Hi

To make a program run permanently as Administrator locate the program executable file do the following:

  1. Locate the file Forge110.exe - follow the path rraud has given above.
     
  2. Right click Forge110.exe
     
  3. Select the Compatibility tab
     
  4. Check the Run this program as an Administrator check box
     
  5. Click Apply and then close the dialog.

HTH

John EB

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021.

Running Windows 10 Professional 20H2 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 3 x 2Tb internal HDD + 60GB internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

MusicFan007 wrote on 11/19/2017, 1:30 PM

Hey, John EB:

Well, I've learned to right click on the SF 11 icon, aka Forge 110.exe. The only option that comes close to the one you indicated is called "Troubleshoot Compatibility." Clicking on it brings me to choosing between two automated troubleshoot scans. There is a separate option for "Run as Administrator" but that allows only for a yes or no response. To possibly anticipate your next question, here are the options I see when I right click (// means a new text line): Open//Shred//Open File Location//Run as Administrator//Troubleshoot Compatibility//Pin to Start//Scan//Pin to taskbar//Restore Previous Version//Send to://Cut//Copy//Delete//Rename//Properties.

All suggestions present and future much appreciated. It is possible that issues outside the application are driving the problem. There are some applications that, when I try to open some elements (like older word files), causes the screen to black out requiring a reboot before I'm back to the applications that don't seem to trigger such a response. More talking to those nice Indian techs at Dell I guess.

Best and again thanks.

 

johnebaker wrote on 11/19/2017, 1:58 PM

Hi

My apologies- I missed part of instruction in step 2 out

Should read: Right click Forge110.exe file and select Properties

then follow on from step 3 above.

HTH

John EB

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021.

Running Windows 10 Professional 20H2 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 3 x 2Tb internal HDD + 60GB internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

MusicFan007 wrote on 11/19/2017, 6:24 PM

Hello yet again, John E.B.

Instructions followed, I am now the administrator which I know will be helpful down the line. Issue remains, but I suspect what's going on with SF is a symptom of a broader issue. I just wish I had a clue. Thanks again for all you wise help.

rraud wrote on 11/20/2017, 9:33 AM

When this issue happened on my machine, selecting Run as Administrator (in Forge110.exe properties/compatibility) partially remedied the issue, e.g. SF would always open, but drag and drop and opening files directly did not work. The registry tweak brought it back to 'normal' (permanent .. or at least until the next Win 10 update).

BYW, I did not try an uninstall/reinstall since the reg tweak worked, if that's the route one takes, I would use a third-party uninstaller like Revo's uninstall which can remove the old registry entries.