Sound Forge 14 audio recording failure

Stan-T wrote on 1/10/2021, 11:43 PM

Current system : Windows 10 PC. Sound Forge 14 running. Previous functionality - Windows 7 where Sound Forge recorded and played back internal audio and heard through system speakers. Windows 10 plays back audio sources. Stereo Mix (recording) is enabled in Sound tab displaying a bar meter. When Sound Forge is running and set to record ( Preferences are set for the audio recording from Stereo Mix ) no signal is detected or recorded. After Realtek drivers are updated the Audio Manager with the drivers does not run. After system restart with new drivers : when audio signal is present, the Stereo Mix recording tab meter shows the signal levels moving. Sound Forge can detect and record the audio signal and a file is created with a wave pattern. HOWEVER - no audio can be heard from the speakers for any sound file including system sounds. Preferences for audio record set up in sound forge appear correct , and system recording tab : stereo mix enabled and set to default device. When drivers uninstalled, and PC restarted, any audio source can be heard through speakers BUT Sound Forge does not record any audio. I understand that the issue is NOT an issue with Sound Forge but with configuration settings for audio in Sound Forge and Windows 10


rraud wrote on 1/11/2021, 1:52 PM

Which audio device types (playback and record) are you using in SF? Widows Classic Wave Driver and Ms Sound Mapper are usually trouble free. In SF, the 'record' device should be the same as in the Windows sound settings 'record' input. Usually 'stereo mix' or 'speakers' if you wish to 'record what you hear'.

btw, Initial posts should state which version of SF you have (for instance Audio Studio-14 or Pro-14) and welcome to the Magix Sound Forge users forum @Stan-T .

Stan-T wrote on 1/11/2021, 4:41 PM

Sound Forge Pro-14. SF is used in record mode to record direct internal audio. Windows Classic Wave Driver , and Mapper were effective and trouble free in the past. SF has been configured to the Windows settings, ie Stereo Mix. Whilst audio is generally heard - ie, internet, audio files being played, system sounds, it appears none of these sources is being routed to SF. When SF is armed and record commenced, no audio signal is present or recorded. In Preferences / Audio/ Record is set to Stereo Mix as default device. In Windows : Sound / Record - Stereo Mix is the default device. Despite these settings and variations in Realtek drivers -no signal is recorded in SF. As mentioned the current ( Oct 2020) Realtek Drivers are problematic. After installation and following the above settings, Stereo Mix in Windows shows an incoming record signal and SF can record this to produce a file. However no audio is heard from the PC from any source.

rraud wrote on 1/11/2021, 5:11 PM

I am not sure, but in 'View> Record options', try setting 'Monitor' to 'ON' or 'AUTO. This can create a feedback loop though in some systems, but you will hear immediately if it does.

Below are the record instructions for SF Pro-11 and later. Pro 10 and earlier versions were different.
- Go to "Options> Preferences> Audio" and select the 'Record' tab
- Confirm or select audio record device type settings
- Go to "View> Record options" and make any parameter changes if so desired,
- Leave the "Record options" window open and select "Arm" (shortcut: Ctrl+ Shift+ A)
- Viewing the record level meters in the 'Record options' window, make any necessary record level adjustments at the source or soundcard/interface
- Commence recording by selecting "Record" in the transport (shortcut: Ctrl+ R) .

btw, Prior to recording the sample rate and bit depth can be changed by selecting "File> New". Typically, 44.1kHz for music and other audio only material, 48kHz is the standard audio sample rate for video. I recommend saving and editing in a PCM <.wav> file format. An MP3, AAC or other lossy formats can be encoded from the PCM master for distribution to end users.

Stan-T wrote on 1/11/2021, 9:50 PM

Yes, i'm familar with these setting with in SF. I have adjusted them previously as you have suggested with out any effect on receiving an audio signal into SF. NOTE: Whilst Stereo Mix is enabled as the default device I have observed that if the microphone device within the Sound options in Windows is not disabled so that the microphone can receive audio, sound is now heard within Windows and esclates into a feedback loop even at low levels. Most advice recommended disabling the microphone but giving it security permissions within Windows and the Sound settings in the Control panel. Despite even this advice, no audio is recorded in SF.

Stan-T wrote on 1/11/2021, 10:02 PM

In SF : View / Record Options- with record being Armed- whilst playing any audio, the level meters in this showed a signal. After clicking record and allowing about 5 seconds of audio recording and stopping recording, SF stopped and the new file created for the recording showed no wave form being recorded

rraud wrote on 1/12/2021, 12:00 PM

I cannot think of much else at this point. You should be seeing the waveform being built whilst recording. Make sure the other settings in 'Record options' are disabled or set to normal. You may want to set the soundcard and SF 'new file' sample rate the same. You can also try resetting SF to the factory default settings which also clears the cache. That option is in the 'File' menu. A repair install or uninstall>reinstall (w/ a third-party uninstaller) are other options to try,. Then there is Magix Sound Forge Tech Support.