Sound Forge Audio Studio 12 does not remember audio driver selection

-TG- wrote on 12/21/2018, 1:41 PM

Dear community,

I recently installed SFAS 12.

At startup, the audio driver selected is always MME; I want to use it with ASIO drivers (for my Focusrite Scarlet USB Interface), and make the appropriate selection.

But, after closing and reopening the program, again MME is selected. The software doesn't remember my setting.

Anyone ever encountered that? any known solutions? Is there some kind of .ini file where this could be manually tweaked?

SF Audio Studio (DP3) on Windows 10 Pro 1803. 64bit.


Thanks in advance!


t-scott wrote on 11/8/2019, 9:59 AM

I have the same problem. Each time I start the SFAS 12 I have to re-assign the Driver System which reverts to MME.

I'm amazed that after nearly a year no one else has commented on this?

Apparenty I need to contact Magix directly, which I'll do now.

RB43 wrote on 11/9/2019, 2:09 PM

I've just recently started having the same issue with my Scarlett 2i2 interface as well. SF Pro 12 on Windows 10. Not sure why either. When I tried to submit a ticket I got a response something to the effect of "Your software is too old, click here to "buy" a ticket for support on it." Seriously? I bought it last December. If anyone finds out why I would like to know. I wish Sony still had and supported this.

browj2 wrote on 11/9/2019, 3:24 PM

I have SFAS and no updates are showing.

I just tested several times with 3 different configuration and SFAS keeps the last config after exiting and restarting. I tried WASAPI and M-Audio Asio, line-in, speakers out, M-Audio out. All changes were kept.

No idea why you are having problems with this, unless it has something to do with the version and not the version.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

RB43 wrote on 11/11/2019, 2:03 PM

Thanks for the info. I don't have SF Audio Studio, I have SF Pro 12 and it says Build 25. So I'm not sure I will see what you are seeing on the build versions you have listed. But after a few exits it will switch at some point. Not every time but I have to keep going in to see if it has kept the Focusrite ASIO device driver. Sometimes it goes back to Microsoft sound mapper. Another issue is that no matter how many times I click "do not show this again" box on the ads for new versions and software when the program loads, it keep coming back. And sometimes that pop up makes the program crash. I've even opted out for notifications and removed that piece of the install. Also sometimes when I open the program it will have reverted back to things I had worked on over a week earlier instead of what I'm working on at the present. Go figure. I miss Sony support. At times it may not have been the greatest, but at least I didn't have to "buy" it if needed.