Sound Forge Audio Studio 12 does not remember audio driver selection

-TG- wrote on 12/21/2018, 1:41 PM

Dear community,

I recently installed SFAS 12.

At startup, the audio driver selected is always MME; I want to use it with ASIO drivers (for my Focusrite Scarlet USB Interface), and make the appropriate selection.

But, after closing and reopening the program, again MME is selected. The software doesn't remember my setting.

Anyone ever encountered that? any known solutions? Is there some kind of .ini file where this could be manually tweaked?

SF Audio Studio 12.6.0.361 (DP3) on Windows 10 Pro 1803. 64bit.

 

Thanks in advance!

Comments

t-scott wrote on 11/8/2019, 9:59 AM

I have the same problem. Each time I start the SFAS 12 I have to re-assign the Driver System which reverts to MME.

I'm amazed that after nearly a year no one else has commented on this?

Apparenty I need to contact Magix directly, which I'll do now.

RB43 wrote on 11/9/2019, 2:09 PM

I've just recently started having the same issue with my Scarlett 2i2 interface as well. SF Pro 12 on Windows 10. Not sure why either. When I tried to submit a ticket I got a response something to the effect of "Your software is too old, click here to "buy" a ticket for support on it." Seriously? I bought it last December. If anyone finds out why I would like to know. I wish Sony still had and supported this.

browj2 wrote on 11/9/2019, 3:24 PM

I have SFAS 12.6.0.356 and no updates are showing.

I just tested several times with 3 different configuration and SFAS keeps the last config after exiting and restarting. I tried WASAPI and M-Audio Asio, line-in, speakers out, M-Audio out. All changes were kept.

No idea why you are having problems with this, unless it has something to do with the 12.6.0.361 version and not the 12.6.0.356 version.

John CB

John C.B.

VideoPro X(12); MEP2021 Plus; MM2021 Premium; see About me for more.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

RB43 wrote on 11/11/2019, 2:03 PM

Thanks for the info. I don't have SF Audio Studio, I have SF Pro 12 and it says Build 25. So I'm not sure I will see what you are seeing on the build versions you have listed. But after a few exits it will switch at some point. Not every time but I have to keep going in to see if it has kept the Focusrite ASIO device driver. Sometimes it goes back to Microsoft sound mapper. Another issue is that no matter how many times I click "do not show this again" box on the ads for new versions and software when the program loads, it keep coming back. And sometimes that pop up makes the program crash. I've even opted out for notifications and removed that piece of the install. Also sometimes when I open the program it will have reverted back to things I had worked on over a week earlier instead of what I'm working on at the present. Go figure. I miss Sony support. At times it may not have been the greatest, but at least I didn't have to "buy" it if needed.

noou wrote on 5/23/2020, 5:15 PM

I have SFAS 12.6.0.356 and no updates are showing.

I just tested several times with 3 different configuration and SFAS keeps the last config after exiting and restarting. I tried WASAPI and M-Audio Asio, line-in, speakers out, M-Audio out. All changes were kept.

No idea why you are having problems with this, unless it has something to do with the 12.6.0.361 version and not the 12.6.0.356 version.

John CB

Same problem here with 12.6.0.360 (no updates showing).

@browj2 do you have the installer of build 356? If yes, could you please share it? I can only find this download, which installs the build I already have: https://www.sony.com/electronics/support/downloads/00015797

emmrecs wrote on 5/24/2020, 4:53 AM

@noou

Did you not notice this thread was started in 2018, with the most recent prior reply in 2019?

I also doubt very much whether John (@browj2) would be able or willing to share any Magix installer files since such sharing would be in contravention of the End-User Licence, I believe.

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

rraud wrote on 5/24/2020, 11:56 AM

Not sure about 365, but if you have a valid serial number, the installer can be downloaded at the Magix Download Center. You will also need your log-in info. A demo version can be downloaded and installed as well, activating that with a valid serial number will remove the demo limitations.. again, I'm not sure about the 365 version.

-TG- wrote on 8/31/2020, 3:33 PM

Hi all, I just realized that there were answers to my OP. I am still having the problem I described above, never solved it, which is annoying and a reason for not using the software much. I also have SF Pro 12 (there everything works fine) but like the UI of SFAS 12 a little more (it is a little different).

Anyway, I think I'll get SFAS 13 via Humble Bundle in the hopes that the problem doesn't occur with that version as well (maybe it is my sound card / driver's fault after all? But works with all other software I have...).

Anyone experiencing this with SFAS 13?

Thanks in advance!

 

 

rraud wrote on 8/31/2020, 4:22 PM

If you already have SF Pro 12, why would you want or need SF Audio Studio 13? Not exactly an upgrade

Former user wrote on 8/31/2020, 4:41 PM

I didn't experience the driver problem with AS13. But I didn't get the program from Humble Bumble. I'll add that AS14 is far and away a better program than AS13. If you have money burning a hole in your pocket, shop for a deal on AS14.

-TG- wrote on 9/1/2020, 1:59 AM

If you already have SF Pro 12, why would you want or need SF Audio Studio 13? Not exactly an upgrade


As I said above, I like the UI better (newer versions of SF Pro have also introduced these changes) and SFAS 12 seems to do most of what I need from it. I got the SF Pro bundled with another software I bought, iirc.

 

-TG- wrote on 9/1/2020, 2:01 AM

I didn't experience the driver problem with AS13. But I didn't get the program from Humble Bumble. I'll add that AS14 is far and away a better program than AS13. If you have money burning a hole in your pocket, shop for a deal on AS14.


Thanks, I'll see which version makes most sense. SFAS is not terribly expensive, true.