Sound Forge issues

Jeff-Miller wrote on 1/7/2023, 10:26 PM

Sound Forge Pro 15 is screwing up. Too often when I open a file it tells me there's an error, but there is not I can open the same file in other audio apps. I can open it in the old Sound Forge Pro 14. What I have to do is open it in Pro 14, make a small change, save it and then it will open in Pro 15. So there was no error, Pro 15 just thought there was. It's now starting to do it when I save files also.

That's not all, it makes these annoying .sfk files when I save and I don't want it to. It didn't used to, older versions didn't. also sometimes .sfapO files along with the .sfk. I would like that to stop.

Also since I've had Pro 15 it won't let me delete or change custom presets in on the Volume process tab.

And yes, I have reinstalled, it changed nothing.

I am using Win 11 on a new computer but it did the same things on my previous Win 10 computer.


rraud wrote on 1/8/2023, 11:09 AM

Welcome to the Magix Sound Forge users community @Jeff-Miller.

when I open a file it tells me there's an error,

What format files are displaying the error message? (MP3, PCM, AAC, other) You might try resetting SFP and clearing the cache, "File> Reset all preferences and clear cached data" This will restore all the SFP settings to factory defaults, Confirm you have the latest updated version SFP-15, build 161.

it makes these annoying .sfk files

The <.sfk> waveform files can be deleted or hidden manually or in SFP settings. Choose the action in "Options> Preferences> General", enable "Hide new temporary files" and/or "Delete new temporary files on close. The <.sfapO> files are for the lossy file type proxys, which can be switched as well: Disable "Always proxy compressed formats" in the same 'General' settings menu,
There are caveats however, if the waveform file is missing, the next time the file is opened, it will take longer to load because waveform will need to be rebuilt. There may be performance issues with lossy file types if proxys are not built.. try it.

won't let me delete or change custom presets in the Volume process

Have you updated SFP-15 to the latest build (161), I recall a preset bug in earlier builds.
Otherwise, I cannot duplicate the behavior on my Win 10 PC.

Jeff-Miller wrote on 1/10/2023, 9:14 PM

Thanks for your reply rraud. SP15 has the latest updates. I generally use wav and flac. I don't mind if the waveform has to be rebuilt when I open, it doesn't take very long and I don't want those little file cluttering up fielders. I already had "Always proxy compressed formats" disabled. I have used Sound Forge since 1999 and as much as I live it every version has always done some crazy thing. SP14crashed like crazy, SP15 doesn't, it just does other crazy stuff. Not bad enough to prevent me from my tasks, just enough to always be a bit annoying.

rraud wrote on 1/11/2023, 10:52 AM

when I open a file it tells me there's an error,

What software created the file? Are you opening the file from within SF or clicking the file itself. The file association may not be set right. Confirm or change the associations in "Options> Preferences> File types" . I also use "Default Program Editor" the change file associations globally, or add 'Open in SF-15' (or whatever) to the file type's context menu. You can also change the Win file type descriptions and other useful Windows customization.
Does the error display if the file is opened from another folder.

Otherwise, you could change the extension to <.raw> and open it in SF-15.. but I do not know that would be faster/easier than re-saving it in SF-14 first.

CJ-Brown wrote on 1/11/2023, 11:59 AM

I am unable to record audio using my current Sound Forge 11 Pro with my new Dell laptop. Same issues with a newly installed trial version of Sound Forge 16. My laptop is a Dell Inspiron 16 5620. It has a Cirrus Logic High Definition Audio sound card. None of the recording options using preferences allow sound to be recorded. These include Windows Classic Wave Driver for USB PnP speakers, Direct sound Surround Mapper for Left F and Right F and Microsoft Sound Mapper for the same Left F and Right F. Dell has recently told me Realtek drivers are not useable on the laptop. All I can figure at this point is the new Windows 11 install was corrupted or this laptop will not support Sound Forge 16 as set up. If I do reinstall Windows 11, can I resume my trial to check if it works? Please help.

Jeff-Miller wrote on 1/11/2023, 12:32 PM

The issue is always when opening within SF. and I don't think it's a file extension thing because it is completely random. It won't do it for a while and then it does. And as previously mentioned to get it to open I go to SF Pro 14, make a slight change, save , then go back to SF Pro 15 and it opens. I tried the "Hide new temporary files" and/or "Delete new temporary files on suggested and now the .sfk files don't appear in the open dialog box in SF but when I go the the file location they are still there. The thing is I don't want it to create those files at all. It didn't used to and SF14 doesn't.

rraud wrote on 1/11/2023, 4:23 PM

.sfk files don't appear in the open dialog box in SF but when I go the the file location they are still there.

They are probably leftovers. delete them manually. They should not reappear the next time the file is opened. When making changes, Sound Forge usually must be restarted before changes take affect.

Jeff-Miller wrote on 1/12/2023, 10:50 AM

Oh I do delete them manually. And next time I open the file it will generate a new one. Well not always. Every now and then it doesn't do it. Sometimes just the .sfk file, often also the .sfapO file, but not always. None of this is a major malfunction, just an ongoing, irritating, nipping at my heels annoyance. But that's just computer life. Thanks for your help but I guess I'll just have to put up with it if I'm going to use the program, It's just buggy.

rraud wrote on 1/12/2023, 11:18 AM

I have not experienced the issues you describe and do not recall reports of such that cannot be resolved in the user settings.

Have you actually tried resetting and clearing the cache (File menu) which will restore all user settings to the defaults. Another option is to fully uninstall using a third-party uninstaller like 'Revo Uninstall' that can remove the left-over registry entries and other pertinent data the OS uninstall leaves behind, which can cause issues to reoccur.. Revo Uninstall has a pro and freeware versions. The free version is adequate in most cases.

Jeff-Miller wrote on 1/13/2023, 2:15 PM

Yes I did reset and clear the cache. But I never heard of Revo. Reinstalling before didn't have any effect so I guess I would need something like that. Of course I would have to redo all my custom presets and toolbars so I'll have to give it some thought about which is preferable.Thanks for the tip.