Sound Forge opening multiple instances instead of multiple windows!

Phil-Hadaway wrote on 8/29/2020, 7:03 AM

This just started! Been using SF for YEARS! When tracking in Reaper OR Vegas, you can click on a file have it open in SF. IF you need to open multiple files and cut and paste, they would all open in different windows within one INSTANCE of SF. Now, when you do that, it opens a new instance of SF for every file! Needless to say, this is a giant PITA! I can point Reaper to SF 12 and it works perfectly. This just started happening with the latest release. What did they do? I need help!


rraud wrote on 8/29/2020, 11:48 AM

Hi @Phil-Hadaway and welcome to the Magix Sound Forge users forum, Thank-you for pointing out the abnormality.

I can confirm this behavior in both 32 and 64 bit Sound Forge Pro 14 (build 111). I am not aware of any setting but will look.


This a result of the new "Multi-instancing default", and stated in the release notes. The option to change it back to the legacy builds, was not mentioned though. It is also in the normally hidden "Internal" menu.
- go to the 'Options' menu
- hold 'Shift' key and select 'Preferences'
- select the 'Internal' tab
- find "Force Single Instance behavior" (bottom of list or use search)
- change value from 'FALSE' to "TRUE"
- click 'Apply' and 'OK'
- Exit or restart SF

Phil-Hadaway wrote on 8/31/2020, 12:57 PM

Worked perfectly! Thank you for your help!

sean-mccoy wrote on 9/30/2020, 3:30 PM

Excellent, thanks.

ddawson wrote on 12/1/2020, 9:32 AM

This fix doesn't appear to be available any longer in Vegas 18 - any other suggestions to make the multiple instances of loading Soundforge stop? It's really difficult when I'm doing multiple edits/processes. "Force Single Instance behavior" is no longer on the internal preferences list

rraud wrote on 12/1/2020, 1:09 PM

It is not a VP setting.
It remains in the SF pro build 112 menu, same as build 111.