Sound not playing on MP4 file

Gord-Boisvert wrote on 5/22/2022, 11:57 AM

I've added an MP4 file within my website. The widget used an HTML file - "<video class="" src="index_htm_files/Chronology.mp4" controls autoplay width = "100%" height="100%"/> The file has sound and plays on all media apps locally. When I preview the page within Web Designer, the sound plays as it should. When I post the page to my hosting platform and access the site through the internet, the video plays, but not the sound. I've used multiple browsers including Chrome, Firefox and Vivaldi with the same result. I'm using Xara Web Designer Premium 19.0.0.64291  DL x64 on Windows10. Any help would be greatly appreciated.

Comments

johnebaker wrote on 5/22/2022, 3:58 PM

@Gord-Boisvert

Hi and welcome to the forum.

This is probably a audio encoding format issue within the MP4 video file, download and install MediaInfo, analyse the video file and post all the data results, see this tutorial on how to setup MediaInfo and analyse a video clip for all the data required.

Which program was the video file created with?

John EB
Forum Moderator

 

Last changed by johnebaker on 5/23/2022, 11:37 AM, changed a total of 3 times.

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/23/2022, 11:14 AM

Thanks John... your links didn't work. This link worked for the download... https://mediaarea.net/en/MediaInfo/Download/Windows

The program I used to create the MP4 is Mixcraft 9 Pro Studio - 64 bit build 469

IsStreamable :No.

Video

Format :AVC

Format_Profile :Main@L3

Format_Settings :CABAC / 2 Ref Frames

Format_Settings_GOP :M=3, N=25

InternetMediaType :video/H264

CodecID :avc1

BitRate :269498

BitRate/String :269 kb/s

Width :640

Width/String :640 pixels

Height :480

Height/String :480 pixels

Sampled_Width :640

Sampled_Height :480

PixelAspectRatio :1.000

DisplayAspectRatio :1.333

DisplayAspectRatio/String :4:3

Rotation :0.000

FrameRate_Mode :CFR

FrameRate_Mode_Original :VFR

FrameRate :25.000

ColorSpace :YUV

ChromaSubsampling :4:2:0

BitDepth :8

ScanType :Progressive

Bits-(Pixel*Frame) :0.035

StreamSize :7898984

Audio

Format :AAC

CodecID :mp4a-40-2

Duration :234517

BitRate_Mode :CBR

BitRate :192000

Channel(s) :2

ChannelLayout :L R

SamplesPerFrame :1024

SamplingRate :48000

johnebaker wrote on 5/23/2022, 12:38 PM

@Gord-Boisvert

Hi

. . . . Mixcraft 9 Pro Studio . . . .

I have removed the excessive and duplicated information this program has put in the file header in your post above.

There is one issue with the video - IsStreamable :No.

For Internet use the video must be streamable, the program may have this option - if not then it needs to be made streamable using a program such as MP4 FastStart on the exported file.

Without being streamable the whole file must be downloaded before playing starts, this can be OK on fast Internet connections, however on slower connections there will be a delay before the video plays.

The video is standard h.264 video encoded and AAC encoded audio and I can see no reason why the audio is not playing from your website - the Bitrate and Sampling rate are correct for video.

Note: the video above plays OK in the forum because it has been converted after upload.

John EB

Last changed by johnebaker on 5/23/2022, 12:42 PM, changed a total of 2 times.

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/23/2022, 3:26 PM

Thanks John. I ran the video through Handbrake 1.5 selecting Web Optimized. Below is the info of the converted file. Unfortunately, I have the same situation as before. The video and sound play in page preview but once uploaded to the hosting platform and accessed via the internet, the video plays with no sound. :-(

General
Complete name                            : C:\Points2ponder files\04082022\index_htm_files\Chronology.mp4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42 (mp42/iso2/avc1/mp41)
File size                                : 8.31 MiB
Duration                                 : 3 min 54 s
Overall bit rate                         : 297 kb/s
Encoded date                             : UTC 2022-05-23 19:55:17
Tagged date                              : UTC 2022-05-23 19:55:17
Writing application                      : HandBrake 1.5.1 2022011000

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : Main@L4
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 4 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 3 min 54 s
Bit rate                                 : 131 kb/s
Width                                    : 640 pixels
Height                                   : 480 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.017
Stream size                              : 3.66 MiB (44%)
Writing library                          : x264 core 164 r3065 ae03d92
Encoding settings                        : cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x1:0x111 / me=hex / subme=6 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=0 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=30 / rc=crf / mbtree=1 / crf=22.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=20000 / vbv_bufsize=25000 / crf_max=0.0 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=1:1.00
Encoded date                             : UTC 2022-05-23 19:55:17
Tagged date                              : UTC 2022-05-23 19:55:17
Color range                              : Limited
Color primaries                          : BT.601 PAL
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.601
Codec configuration box                  : avcC

Audio
ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 3 min 54 s
Source duration                          : 3 min 54 s
Bit rate mode                            : Constant
Bit rate                                 : 160 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 4.48 MiB (54%)
Source stream size                       : 4.48 MiB (54%)
Title                                    : Stereo
Default                                  : Yes
Alternate group                          : 1
Encoded date                             : UTC 2022-05-23 19:55:17
Tagged date                              : UTC 2022-05-23 19:55:17
mdhd_Duration                            : 234517

johnebaker wrote on 5/24/2022, 4:13 AM

@Gord-Boisvert

Hi

If the website is publicly available can you give us a link to it.

John EB

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/24/2022, 11:05 AM

https://www.points2ponder.com/ click on the book description which will take you to the page with the MP4 file.

johnebaker wrote on 5/24/2022, 12:18 PM

@Gord-Boisvert

Hi

Thanks for the link.

The video is not playing any sound because it has none - this is the MediaInfo data for the file on your website:

General
Complete name                            : W:\Downloads\Chronology.mp4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom (isom/iso2/avc1/mp41)
File size                                : 3.41 MiB
Duration                                 : 3 min 48 s
Overall bit rate                         : 125 kb/s
Writing application                      : Lavf55.48.101

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L3
Format settings                          : CABAC / 4 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 4 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 3 min 48 s
Bit rate                                 : 123 kb/s
Width                                    : 640 pixels
Height                                   : 480 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.016
Stream size                              : 3.35 MiB (98%)
Writing library                          : x264 core 142 r2431 ac76440
Encoding settings                        : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=6 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=25 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=23.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Codec configuration box                  : avcC
 

 

Note there is no audio section as shown in your MediaInfo data. The General and Video highlights are mine.

I suspect you may have had 2 copies of the Chronology.mp4 file, the silent one is now on the server and the linked file is not replacing the one without audio with the one that has audio when Web Designer publishes, or you export and FTP upload the site.

HTH

John EB

 

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/24/2022, 12:47 PM

It must be something else. I deleted the sever copy and uploaded the file with sound, but still no sound over the internet. So I downloaded the server copy and played it locally and voila ...it has sound.

johnebaker wrote on 5/25/2022, 7:07 AM

@Gord-Boisvert

Hi

. . . . It must be something else. I deleted the sever copy and uploaded the file with sound, but still no sound over the internet. So I downloaded the server copy and played it locally and voila ...it has sound. . . .

Something odd is going on with the video file - testing in Opera, Firefox, Chrome and Edge, and downloading the file from each and playing on my PC, the video clip still does not have any audio track - it looks like it is being stripped out.

I have also checked one of my test sites containing mp4 video, built using Web Designer and it plays the audio correctly both on line and my PC.

. . . . So I downloaded the server copy  . . .

Did you right click the video on the overview web page and select Save video as (or similar option)

John EB

Last changed by johnebaker on 5/25/2022, 7:07 AM, changed a total of 1 times.

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/25/2022, 9:40 AM

no, I used filezilla to download the server copy.

johnebaker wrote on 5/25/2022, 2:11 PM

@Gord-Boisvert

Hi

This is very puzzling.

Are there other copies of the video file on the server? The video file that has no sound and I am downloading is in the index_htm_files folder, this is the correct location.

I have a simple test site here with video on it - can you hear the home page header audio or the videos in the video gallery? 

John EB

Last changed by johnebaker on 5/25/2022, 2:12 PM, changed a total of 1 times.

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/25/2022, 9:43 PM

no other copies on the server... but this is very strange. The video plays on my tablet with sound but not on the PC. The web page is part of a responsive template so I'm wondering if there is something that is messing that up.

Gord-Boisvert wrote on 5/25/2022, 9:46 PM

also...I went to your test site and the video and sound played fine on the PC... didn't bother to check on the tablet as I'm sure it would also play there.

johnebaker wrote on 5/26/2022, 4:34 PM

@Gord-Boisvert

Hi

I have retested your site and the video now plays correctly on my PC and the downloaded file MediaInfo data shows the audio is present.

I suspect that there may be a caching issue either on the PC, with your ISP provider or another intermediate provider.

Who is the site hosted with?

. . . . The video plays on my tablet with sound but not on the PC.  . . . .

Try forcing your web browser to reload the page - press Ctrl + F5 several times to see if this helps.

John EB

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.

Gord-Boisvert wrote on 5/26/2022, 7:56 PM

the site is hosted with Whois . I just checked and the sound is playing on the PC as well.... 😁😁 That was very odd. Anyway, I very much appreciate your help with this and all the time you put into assisting.

johnebaker wrote on 5/27/2022, 6:15 AM

@Gord-Boisvert

Hi

Thanks for the feedback and pleased to hear the audio problem is sorted.

John EB

VPX 15, Movie Studio 2024, 2023, and earlier versions 2015 and 2016, Music Maker Premium 2024.

PC - running Windows 11 23H2 Professional 64bit on Intel i7-8700K 3.2 GHz, 16GB RAM, RTX 2060 6GB 192-bit GDDR6, 1 x 1Tb Sabrent NVME SSD (OS and programs), 2 x 4TB HDD (Data) internal HDD + 1TB internal SSD (Work disc), + 6 ext backup HDDs.

Laptop - Lenovo Legion 5i Phantom - running Windows 11 23H2 on Intel Core i7-10750H, 16GB DDR4-SDRAM, 512GB SSD, 43.9 cm screen Full HD 1920 x 1080, Intel UHD 630 iGPU and NVIDIA GeForce RTX 2060 (6GB GDDR6)

Sony FDR-AX53e Video camera, DJI Osmo Action 3 and Sony HDR-AS30V Sports cams.