Sound Pools Will Not Install

Patrick-McNerney wrote on 7/17/2019, 5:47 AM

I bought Music Maker Premium in 2016. I have switched to a new computer. I re-installed Music Maker Permium (no problems there), but when I went to re-install my sound pools it asks me for my email, I input, then it comes up and says

"Connection Failed, the Server Responded With The Error Code: 404"

Any ideas? I have 10 paid for sound pools, I'd hate to think about how much money will be lost if these will not install.


ralftaro wrote on 7/19/2019, 7:06 AM

Hi Patrick,

If this is about version 2016 of Music Maker, can you possibly provide a little more context here as to what source those soundpools would have come from? Exactly how are you going about re-installing them when you're being asked for your e-mail and receive the quoted error message? I can't really make sense of that off the top of my head. Since this is about an older Music Maker version, I assume the new in-app store system is not involved, correct? In version 2016, if you were using a disc version, the soundpools would have been installed from the disc during the program installation. If you were using a download version, you would have triggered the soundpool installation via the download manager in the "Help" menu upon program installation and activation. Neither really seems to match the workflow you're describing above. So, please shed some light on that, and I'm positive we'll be able to help you. Thanks!


Patrick-McNerney wrote on 7/19/2019, 7:23 AM

Thank you for the response!

The sound pools were purchased via the in-app store (it existed in 2016 version). When you purchase the sound pool in 2016, it allows you to download an EXE file. I saved these EXE files for backups knowing I'd eventually get a new computer and not want to lose my investments. They installed / worked perfectly on the old computer. When I got a new computer and installed the software there, the sound pools will no longer install. I go to open the EXE and it asks for my email and then gives the server 404 error.

Yesterday I paid to upgrade to Music Maker 2020 thinking maybe that would fix the problem. But alas, it did not. None of my sound pools will install.

I have tried to "add sound pools" through Music Maker and navigate to the folder where my sound pools were saved, but it does not add them.

I have attached images of the sound pools in my folder, as well as the error message when I go to install them. (I install as "administrator" and input my email address as asked. Then get the error message. Back in 2016, they would simple extract and install into the software).

Larry98 wrote on 7/20/2019, 7:15 AM

Those soundpools were purchased on the magix website and not in the in-app-store.
The in-app-store downloaded in a zip file in the background and then automatic extracted it to the correct folder.

MAGIX Fan seit 2014.

Aktuelle Programme (jeweils neueste Version)
Video deluxe Premium, Video Pro X, VEGAS Pro Edit 15, Music Maker und Xara Designer Pro X.
Eine komplette Programmliste findest du in meinem Profil.

ralftaro wrote on 7/22/2019, 8:12 AM

Hi Patrick,

Thanks for the additional details.

This seems to be a problem connecting to our servers from these older executable soundpool installers. I'll have this looked into. One way or another, may I ask you to raise a formal support ticket about this issue?

If this cannot be fixed quickly, or if you simply want to migrate over to the new Music Maker version and prefer to use these soundpools as in-app store content, I could then more easily sort you out with suitable replacement items that will work under the new system. Thanks!


Patrick-McNerney wrote on 7/22/2019, 9:08 AM

ralfataro - thank you!

I upgraded to Music Maker 2020 last week. I not have the most recent version of Music Maker on this computer. How can I use these sound pools as in-app store content? I'm fine with this solution as long as I don't have to pay a second time. If I need to make a formal support ticket let me know.

Here are the pools I had purchased previously:
80s Too Hot;
Chillout Summerbreeze;
Glitchhob_Chips Sounds & Glitches;
Metal Tears of Salvation;
Rock Pop New World;
Rock Pop Replay;
Scores - No Fear;
Techno Darkstar;
Trap Bounce;
Trap Future Bass;

Patrick-McNerney wrote on 7/22/2019, 9:09 AM

I NOW* have the most recent version of Music Maker on this computer.

ralftaro wrote on 7/25/2019, 7:35 AM

Hi Patrick,

So, the primary problem you were experiencing with the online authentication of the soundpool installation process was due to some recent migration work on our servers, and was fixed. You might want to try this again, and see whether you're coming up against further problems.

As discussed, if you need me to switch you over to having these soundpools as in-app store based content, please send in an official support ticket under the user account under which you purchased your products.


Patrick-McNerney wrote on 7/25/2019, 9:44 AM

Thank you! IT got past that, but now it's saying my email address is not associated with any purchases. I will open a support ticket.

browj2 wrote on 7/25/2019, 11:08 AM


I'm not following you. If you have purchased stuff in the past, then you must have registered with Magix. Did you register again with a different email address?

Did you activate your previous MusicMaker activation codes in the new MusicMaker2020? You can check by going to Help, Activated Content. There, you'll see the various previous versions that you have purchased and Activated in MusicMaker. If you have nothing, then you have to activate the previous versions before continuing.

What do you see?

Did you Activate with the new Premium code that you received by email?

Once you've activated, click on the Download button that should appear at the top right of the Media Pool. What do you see?

Download and Install everything.

Do you now have your Soundpools that you mentioned in the first post?

If not, go to Program Settings and press on the Clean up Store button. Restart the program. Log in to the Store (you will have been logged out).

Do you see your Soundpools?

Does anything show up under the Download button? If so, download and install.

Do your Soundpools show up under Loops?

If not, Program Settings, Rescan Soundpools.

Now do you see them?

If not, open Windows Explorer and navigate to the Soundpools Folder. Unless you changed it, it should be:


Go through everything, including the Shop folder. Do you see your Soundpools anywhere there?

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

Patrick-McNerney wrote on 7/25/2019, 12:43 PM

You nailed it! The program was not activated via the serial - once I did that, I also had to go to the help > activate previous maker code and the sound pools showed up in downloads.

It appears I'm only missing 1 or 2 sound pools now, I think because I purchased them under a different user login.

browj2 wrote on 7/25/2019, 12:45 PM


Great to hear that!

Did you get the missing Soundpools through the Store or before the existence of the Store? If before, then they can be simply copied into folders under the Soundpools folder.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

Patrick-McNerney wrote on 7/25/2019, 1:01 PM

Looks like I'm good to go - I copied some into the folder prior to the store. The rest that I had previously purchased came back after activation........and I spent pretty decent chunk just now buying several new bundles, always happens LOL will be fun to start making some tunes again.

ralftaro wrote on 7/26/2019, 4:20 AM

Well, glad to hear you somehow seem to be up and running again, albeit I have no idea how you did it. 😬

Seems like you may have still had those soundpools on your hard drive in unpacked/installed form, because I have to confirm that the problem with the executable soundpool installers you were having is real (i.e. a general problem). After the fix for the first problem with the moved server, it currently doesn't correctly detect the purchase status, even when entering the correct e-mail address under which you purchased those add-on soundpools. I got the very same problem here in my test, and am still in touch with our back-end development team and server admins about this.

So, yeah, the bottom line is: Check closely whether you really got all of those soundpools you should have. If you find that anything is still missing, the installation of that pool via the executable installer should be working again soon. We also received your ticket at support and will respond. So, if everything else fails, we'll work out some other solution for you to complete your soundpool collection again.


Patrick-McNerney wrote on 7/26/2019, 5:50 AM

Thank you Ralf! I will respond through the support ticket on it.

ralftaro wrote on 7/26/2019, 7:36 AM

UPDATE: Fixed! Those old soundpool EXE installers would now be working and correctly connecting with the back-end server again! I just successfully tested it here as well.