Soundforge 12.1 plug in chain is unusable

Bearlee wrote on 2/11/2019, 3:17 PM

I have been having problems with plugins failing to load on boot up among other things. The biggest problem is trying to create a plug in chain. If I create a chain and then open a plugin to view its parameters, play back stutters, and runs slow and often crashes requiring a reboot. It appears the implementation of VST 3 and 64 bit processing has rendered this software almost unusable to me. I have reinstalled Sound forge 11 and the same plugins, in 32 bit form, work perfectly. I feel as if I have wasted the upgrade money I spent. This is not a random event. It happens every time I use the program and is easily duplicated. I would be happy to co-operate with Magix so they can fix this but it should happen sooner rather than later. Its one thing when users requests take time to get implemented but, IMHO, Sound forge 12 should never have been released running the way it does. For what its worth, this is not a hardware issue. I get exactly the same response on 2 different machines running Windows 10 Pro and Windows 10 home respectfully. Please tell me there is a fix on the NEAR horizon.


rraud wrote on 2/12/2019, 2:12 PM

Exactly what VST-3 plug-ins are causing problems? Can you use VST-2 versions if available. SF does not support VST instruments.

This forum is basically a peer-to-peer discussion group so correspondence with MAGIX should be done through technical support or customer service.

Bearlee wrote on 2/13/2019, 1:19 PM

Waves L1 and Renaissance compressors plugins are definitely culprits as I use these a lot. Other plugs have caused issues as well and if doesn't matter if its VST-2 or VST-3. The problem appears related to the plugin managers handling of multiple plugins running with the parameters window open. These same plugins work perfectly in SF 11 32 bit. I have been in contact with Magix support. They indicated they are aware of the issue and have passed it on to the development group but so far, no updates, no action, just a very disappointing program. I have been using SF as a mastering tool for as long as I can remember. I have been forced to go back to SF 11 . Sorry for the rant, I,m just very disappointed.


rraud wrote on 2/14/2019, 11:24 AM

As support stated, it is a known issue with some of the Waves plug-ins. Same issues with Waves in Vegas Pro, though VP does not currently support VST-3..

"Sorry for the rant, I'm just very disappointed".
> You are not alone!

drumee wrote on 4/7/2019, 1:58 PM

i'm having the same problem with sound Forge 12 which I just bought. Izotope Ozone 7 is a crackling mess in Plug in chain. this is pretty much the only reason I have Sound forge.and SF Pro 10 ...32 bit worked fine.

rraud wrote on 4/7/2019, 5:11 PM

Try using the ''Classic Wave Driver or 'MS Sound Mapper' audio device setting. (Options> Preferences> Audio> Audio device type),

Otherwise you could see if the 32 bit version of SF Pro 12 helps . You can download the installer (soundforgepro12_dlm.exe) from Magix 'My Products' page in the Service Center. Of course it will not run 64 bit version plug-ins, so you may have to install them if they are not there already.

drumee wrote on 4/7/2019, 8:41 PM

Thanks for your thoughts, but I’ve invested in the Focusrite 6i6 and it’s running with the Asio driver, as it should. Surely sophisticated editing software like SF12 should be able to work with that, as a base expectation? If push came to shove I can revert back to SF10 , 32 bit. But why did I spend $100 for an upgrade. Do you think Magix are dealing with this?

Grump wrote on 4/8/2019, 2:13 PM

Hi, your issue sounds very similar to mine - I get severe stuttering in SF Pro 12.1 when using the plugin chainer with any plugin I try. Using the FX favourites menu with the same plugins does not cause any stutter. I am using an RME HDSP9632 with the ASIO driver; if I switch to the Microsoft Mapper driver the stuttering does not appear. I have reported this to Magix, and they said are looking in to the issue - however, they told me nobody has reported anything similar. Does switching the driver to anything other than ASIO reduce/stop the stuttering for you?

Bearlee wrote on 4/8/2019, 3:01 PM

If they told you you one has reported a similar issue they are blowing smoke .......I opened a support ticket on the same issue with waves plugins and Izotope plugins many months ago. I was told they were aware of the issue and stated they were in contact with waves and said waves was unable to duplicate the problem. I don't believe that for a second all. It can be duplicated EVERY TIME using multiple plugins in the plugin chain and opening the plug in to view the graphics. I offered to help in any way I could to demonstrate the issue, no response except to say they passed the issue on to the development team. There are other issues as well including intermittent crashes on startup when loading plugins, intermittent lock up problems when rescanning plugins from the VST menu in preferences , but the useless plugin manager issue is a deal breaker. I am also using Focusrite,a Scarlet 18i20 2nd gen. on one system and a Projectmix I/O on the other system...Same problem on both systems. I have reverted to SF 11 until they figure this out. I had hoped Magix development team would be an improvement over Sony but so far, I,m not impressed.

drumee wrote on 4/8/2019, 8:18 PM

It’s only bad with the asio driver, which I have pushed to the largest buffer that’s possible. It doesn’t glitch if I don’t use the plug in chainer and just input the plug in. I tried to go back to SF10, but it won’t load now. What a mess.

Bearlee wrote on 4/8/2019, 10:11 PM

Same here. Used individually its okay, just not in the plugin chainer

rraud wrote on 4/11/2019, 10:34 AM

I tried to go back to SF10, but it won’t load now. What a mess.

If Pro 10 will not open, that could be the known 'Elevated Privileges' issue and is typically the result of a Win 10 update, This requires a registry tweak. Search this forum for "Elevated Privileges". I have needed to do the reg tweak every other time there is a win 10 update... or so it seems.

Grump wrote on 4/11/2019, 2:01 PM

Magix do seem to be keen to try and fix the stuttering issue from the contact I've had with them. They said they would keep me updated, and that the developers would be looking at in very soon.

With regards to the Sound Forge Pro 10 not opening properly have you tried running the registration with admin privileges and then running the program itself with admin privileges on first launch? As rraud mentions, there is a known issue that intermittently seems to appear. I just set my executable to always run as admin which seems keep everything working fine for me.

Bearlee wrote on 4/11/2019, 4:56 PM

They told me they they would pass it on to the developers months ago. No updates, no bug fixes, no feedback. I,m not holding my breath.

rraud wrote on 4/12/2019, 9:21 AM

With regards to the Sound Forge Pro 10 not opening properly.... I just set my executable to always run as admin which seems keep everything working fine for me.

That will work, and keep some folks from delving into the potentially dangerous registry. 'Run as administrator' may require an extra click when opening a file though.

Grump wrote on 4/12/2019, 7:16 PM

For sure - it's horse for courses. You can just find the executable, and set to always run as admin which should always trigger asking for elevated privileges. You can also set an option to stop windows asking for confirmation of that program using the MS Management Console - but it's not really any easier than going through regedit. However, for me, I have only had to set the option once now via this route and forget it - all other options required met to fiddle around with some settings every so often.