SPACE vs ENTER during playback

Brian-Sepolen wrote on 9/12/2018, 12:36 PM

I've been using SF10 for 18+ months before upgrading to SF12. So my workflow has been honed around rapid key presses while editing recorded audio.

It used to be that hitting the ENTER key would play the audio in the current selection. Now, hitting ENTER makes the selection go away and plays the audio *after* the selection. (I use this in conjunction with Ctrl-K while cleaning up spoken word.)

Any way to get this back, because I keep finding myself stumbling over this (little) change in functionality.


rraud wrote on 9/12/2018, 2:20 PM

in the 'Options menu, try selecting "Seek Cursor on Playback" (keyboard shortcut: F)

When zoomed in to the millisecond or sample level, disabling "Quantize to Frames" would be make placement more precise. Maybe check your snapping parameters as well,

Brian-Sepolen wrote on 9/13/2018, 9:42 AM

Yeah, I discovered "Seek Cursor on Playback" early on in SF10, back when I shared a login with multiple users. During Playback, clicking with this setting off sets the cursor. Clicking with this setting on causes playback to jump immediately to the cursor position and continue.

I have confirmed this setting has no impact on the functionality I have described.

rraud wrote on 9/13/2018, 11:46 AM

Are you stating there is a delay when you commence playback, for instance, a second or two gap before sound plays? If that's the case, the playback buffering may need to be adjusted. "Options> Preferences> Audio" I believe the default is 0.20.

I can't duplicate that behavior, try the 12.1 update, assuming of course we are referring to Pro 12, I do not recall that issue on 12.0 though.

Brian-Sepolen wrote on 9/13/2018, 12:00 PM

See. As I'm editing this voice track, I'm pulling out extra obstruents, sonorants, and other mis-articulants. My right hand is on the mouse, my left hand is resting across the keyboard with thumb on the right-most Ctrl and pinky on "L". The index finger rests naturally on Enter, so I have grown accustomed to pressing Enter to preview the selected region prior to deleting it.

This functionality was changed between SF10 and SF12. I have looked in the settings and options. I have Googled and Binged. But I am not finding satisfaction.

rraud wrote on 9/14/2018, 11:51 AM

Still not exactly sure, but I use the J,K,L scrub and Ctrl+K keys frequently as well. If your "Options> Preferences> General> Spacebar and F12 Play/Pause instead of Play/Stop" box is check-marked, this reverses the Enter and Spacebar 'Play/Pause - Play/Stop' behavior as well. Either way, when 'Pause' is enabled, the TL selection is undone. This option/behavior functions the same in Pro 10 & 11. I'll re-check Pro 12 on my Win 10 laptop ASAP. The factory default setting is Spacebar=Play/Stop, Enter=Play/Pause.

Addendum: The same applies to Pro 12