sudden buzz flat line appears when recording in Sounds Forge 10

Alex-Lancaster wrote on 5/10/2020, 2:17 PM

I am using Sound Forge Audio Studio 10, with a Dell XPS 15 7590 laptop running Windows 10 Pro, 1TB nVmE hard drive with 32 GB of memory. My audio interface is a Focusrite Scarlett 2i4 which is connected to the laptop via USB cable. I am using 1/4" TRS balanced inputs to the Focusrite box, all the levels are set right. Laptop uses a Thunderbolt3 cable to plug into the Dell Thunderbolt docking brick. In Sound Forge Audio Studio 10, it is recording fine for the first few minutes, and then suddenly it will flat line with a buzzing sound, see attached screen shot below. What could be causing this sudden appearance of a flat line buzz within the Sound Forge software??


rraud wrote on 5/10/2020, 3:08 PM

Hi @Alex-Lancaster and welcome to the Magix forums.

Hums and buzzes are usually analog based and not something generated by software or anything else post A/D in the digital domain.
Hums (50-60Hz and their harmonics) are normally an electrical ground loop. Buzzing is usually electro-magnetic interference, radiated from a close-by power source (power amp for instance) through a broken or poorly shielded audio cable. Single-coil guitar pickups are notorious for electro-magnetic buzz as well. Try different mics and input cables feeding the interface. If that doe not fix it, try testing using the PCs internal soundcard or another interface and connection. Intermittent buzzing suggests an electrical device that cycles on and off.. HVAC (heating and cooling) refrigerators, freezers and such.

Alex-Lancaster wrote on 5/10/2020, 3:42 PM

What about Thunderbolt3 docking bricks? Is there a known problem with recording through a Thunderbolt3 docking brick, where the Focusrite audio interface USB cable is plugged into the Thunderbolt3 docking brick, and the docking brick is plugged into the Thunderbolt3 port on the laptop? Also, are there any known issues with recording to external hard drives via USB 3.0 or Thunderbolt cables? Are there any known issues with disk read/write buffering settings in Sound Forge? Is it possible that there is some kind of read/write buffering problem between the laptop memory and the laptop disk drive?

Alex-Lancaster wrote on 5/10/2020, 3:44 PM

I tried plugging in the Focusrite audio interface directly into my Laptop USB 3.0 port, and it was able to record fine for 21 minutes before the flat line event showed up in Sound Forge. In the example I showed above, that flat line event came just after 3 minutes. Does this mean anything to you?

Alex-Lancaster wrote on 5/10/2020, 5:34 PM

I tried recording using Sound Forge Pro 13, and after 21 minutes I get a similar scenario, the flat line buzz sound just appears out of nowhere after recording music just fine for 21 minutes. Same Dell laptop, same Focusrite audio interface plugged directly into the laptop, recording directly to the laptop nVME hard drive. This looks like some sort of software buffer overrun, or disk read/write error to me.

Alex-Lancaster wrote on 5/10/2020, 6:56 PM

I thought of some other possibilities. What I am trying to do here is basically use Sound Forge, the Scarlett audio interface, and Sound Forge like a DAT machine so I can record long DJ sets. What about other software processes running in the OS background, like virus scan, or iCloud sync, or One Drive sync, or Adobe Creative Cloud, or some other OS processes etc., could these interfere with Sound Forge's processing to record real-time audio to the hard drive? Is there a check list of software that should be turned off or disabled while recording real-time audio through Sound Forge to record directly to the computer's hard drive?

James-Lo wrote on 5/10/2020, 8:22 PM

Is your audio interface's driver up to date?

Alex-Lancaster wrote on 5/13/2020, 11:53 AM

Yes, all hardware, firmware and software drivers are up to date. I am using the latest Focusrite drivers they have. The only thing I can think of right now is going through "a process of elimination", try another laptop, try another Focusrite Scarlett device, try direct cable connects to laptop instead of through Thunderbolt3 docking brick, etc. It will take a while to test out all these possibilities. I would just appreciate some kind of article that talks about the recommended laptop setup, including use of docking bricks, use of external hard drives, possible software conflicts running in the background like virus scan, iCloud sync, One Drive sync, etc. I have not seen anything about what the recommended setup should be for recording long real-time music sets. All these recording problems make me miss my old fashioned DAT machine which was a workhorse and never screwed up.

rraud wrote on 5/13/2020, 6:06 PM

I had a HHB PortaDAT.. Can't say I miss it very much. If was heavy, ate batteries and occasionally a tape would not playback in other machines.

James-Lo wrote on 5/14/2020, 9:39 AM

And then there were rotating heads, head cleaning tapes, formatting gaps on tapes that confused some machines, and digital transfers that had to be done in real-time. Pure joy. 😉

Alex-Lancaster wrote on 5/17/2020, 2:52 PM

I think I found the problem, so I will post it here to help others that may encounter this. The Focusrite Scarlett series audio interfaces use the Microsoft Visual Studio C++ 2017 redistributable package for their driver on Windows 10 machines. When I was having the problem described above, I had Visual Studio C++ 2017 redstributable package x86 version 14.23.27820. I downloaded and installed Visual Studio C++ 2017 redistributable package x64 version 14.25.28508.3, and then everything started working fine, no more weird audio cut off like what is shown above. I even tested plugging in the Focusrite Scarlett (USB) audio interface directly into the Dell Thunderbolt3 docking brick, and using an external hard drive also plugged into the Thunderbolt3 docking brick, and everything seems to be working and recording fine so far. Also worth noting, Sound Forge Audio Studio 10 uses the Microsoft .NET Framework 2.0 redistributable package, so you need to download and install the .NET Framework 3.5 redistributable package on your Windows 10 machine if you don't already have it.

Alex-Lancaster wrote on 5/17/2020, 5:48 PM

I am 90% sure this is a driver memory leak situation, especially if they are using C++. Memory garbage collection in C++ can be tricky, and my software experience gives me a hunch these symptoms point to a memory leak scenario.

rraud wrote on 5/18/2020, 9:28 AM

Thank-you for posting your findings @Alex-Lancaster.