UMC404HD Audio interface

Trevor-Allport wrote on 4/10/2019, 10:04 AM

Got this new unit up and running but there are still issues in which I have to change between audio settings in order to change from recording audio to midi and vice versa. I'm running audio playback through a soundblaster Z into Logitech speaker setup. I'm aware of the bug in which to hear playback you have to turn off AUDIO REC tab but I'm no longer having that issue using this new interface unit.

None of the ASIO drivers ( ASIO4ALL, CREATIVE, UMC, MAGIX LOW LATENCY) allow me to record audio, some of them causing my audio to completely disappear OR crash to desktop. To get my audio back I have to come out of MM.

I can record and playback audio using Speakers SoundblasterZ and Wave driver 24bit.

The only way I can record midi is using the ASIO4ALL drivers although the midi signal is clearly being received using the other settings.

And in order to get the mic (on channel 3) to work properly, I have to switch the default audio device playback in Windows from Speakers SBZ to SPDIF. I'm willing to suffer this for now but would like to know if anyone can shed any light on this?

Comments

emmrecs wrote on 4/12/2019, 4:16 AM

Hi again.

I think you should be able to avoid this problem by changing some settings within the ASIO4All control panel. (BTW, I would strongly recommend NOT using the Creative ASIO drivers, they do not have a very good reputation for reliability at all!)

In MM>Program Settings>Audio/Midi tab, with ASIO4All selected as your ASIO driver, at the top of that screen you should see a button marked "Advanced". Click on it> This control panel will then appear. (The listing of MOTU Audio is for my system; your screen will look different, in terms of details.)

Click on the highlighted "spanner". This screen will then appear, showing ALL the possible inputs and outputs that ASIO4All can see/use.

Click alongside the ones you want to have available, the little "blue" symbol becomes illuminated. Do not, at this stage change any of the other settings on that screen, but do post back and tell us whether, or not, this works!

HTH

Jeff

Last changed by emmrecs on 4/12/2019, 4:17 AM, changed a total of 1 times.

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

Trevor-Allport wrote on 4/12/2019, 4:38 AM

Hi Jeff. I've already tried all the advanced settings in the tabs associated with each driver to ensure the relevant inputs and outputs are selected. Nothing seems to sort it. I WILL have another look specifically at the ASIO4ALL driver. Thanks for the reply!

Trevor-Allport wrote on 4/12/2019, 7:13 AM

Revisited the ASIO4ALL settings. Just can't get it to work. It seems my only way to record and playback midi is the Wasapi drivers (hit and miss whether it works on SPDIF or SoundBlaster Speakers I just have to change between the two in Windows settings) And Wave driver with Speakers SoundblasterZ for audio.

Basically if I want to change from one to the other it doesn't always work first time. I have to piss about coming out of MM and changing windows settings around until it works. It's a ballache but at least I can work it.

Edit: Ok, I'm getting some weird shit. If I use the ASIO4ALL and Wasapi Driver SpDIF OUT I can record and playback midi. I can ALSO record audio and then I can only playback if I uncheck the AUDIO REC tab, a known bug, HOWEVER, the audio playback is at a higher pitch. Baffling!

Graham-Hawker wrote on 4/12/2019, 1:12 PM

What are you using for playing through midi?

In the end it looks over complex still. Using one device for audio input and one for audio out sounds like a recipe for problems. The Soundblaster z manual does not recommend mixing audio devices. Mixing in SPDIf output may also be problematic. Apparently this can be set as 44.1khz, 48khz or 96khz and I guess should match the specs of the audio input.

Trevor-Allport wrote on 4/12/2019, 2:25 PM

Hi Graham. I need to be able to play games in 5:1 sound so I keep the SoundBlaster for playback. As I understand it, if I use the UMC404HD for audio output I not only will not be able to get 5:1 sound in games but I will create a feedback loop when using the mic plugged into Channel 3 of the UMC404HD even if I use headphones from the UMC404HD. I use my DeepMind synth for midi. A 5 pin midi cable into the UMC404HD and the USB connection transmits the midi from UMC404HD to computer.

I can live with it unless anyone has an obvious solution. It's a minor problem compared with my musical incompetence which I am battling with considerable success.

Graham-Hawker wrote on 4/12/2019, 3:27 PM

Personally I'd disable the Soundblaster when doing audio and unplug the Behringer and enable the Soundblaster for gaming and general use. I guess you would need new speakers for audio stuff.

johnebaker wrote on 4/12/2019, 3:34 PM

@Trevor-Allport

Hi

From your previous topic:-

. . . . the SPDIF output from the soundcard to the speakers on another channel to switch to for playing games . . . .

As I understand the SoundBlaster connections you are using the SPDIF to feed the audio from the computer to the Logitech speakers and you also have standard copper cables between the PC and the Logitech speakers for playing games audio in 5.1 Surround Sound - is this correct?

The SPDIF output, which is basically fibre optic, is an alternative to using copper cables, there should be no necessity to use both, therefore no switching 'channels'.

In Windows try setting the default audio output to 'speakers' not SPDIF, and disconnect the copper cables from the sound card. and test audio playback from the games, Music Maker and Media Player - they should all work.

If not disconnect the SPDIF and reconnect the cables and test again.

If both work as they should, then use either the SPDIF or cables whichever you prefer.

HTH

John EB

 

 

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Trevor-Allport wrote on 4/13/2019, 5:19 AM

Hi John. Yes I connected the copper cables before I aquired the audio interface to see if it cured the settings problem (having to change settings when changing from recording audio to recording midi and vice versa). It didn't work. I'm not confident that it will help with this and but I'll give it a go when I can get back to it in a couple of days. Thanks.

Trevor-Allport wrote on 4/14/2019, 2:17 PM

Nope. Removing copper cables or SPDIF just creates more problems as it's hit and miss. When changing from audio to midi and vice versa, sometimes I use Speakers SBZ and sometimes SPDIF. If it won't work on one, it will on the other. Removing one just renders it a problematic mess. Thanks for the help guys but it looks like I'll just have to live with it. Maybe I'll have better luck with different software.

johnebaker wrote on 4/14/2019, 3:34 PM

@Trevor-Allport

Hi

Check that the SoundBlaster drivers are up to date - I found out that there have been issues with them, cannot find the page now, IIRC it was in the Creative forum.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Trevor-Allport wrote on 4/15/2019, 12:36 PM

Hi John. That was one of the first things I did. As long as I know how to get it working with minimal fuss, I can manage. Thanks for your help. I've uploaded some tunes to the media section if you want to take a look at what I've created so far. Cheers.