Unwanted timeshift on playback

James-Wolff wrote on 1/1/2019, 4:52 PM

I've had Sony Sound Forge 10 for quite a while and it's served me well. Recently, however, on playback the speed of the track increases without me doing anything. Not changing pitch, not changing time stretch. If I import a track and play it and it sounds fine, then I switch to another program without closing down Sound Forge; OR, for example, if I switch over to YouTube to listen to the same track without closing down Sound Forge, when I come back to Sound Forge the track plays back faster, and the pitch increases by a half or full tone. I'm still on Windows 7 Professional and have been forever. Anyone have any idea what I may have done to make this happen? Sure appreciate the help.


rraud wrote on 1/2/2019, 10:47 AM

Sounds like.. (no pun) a sample rate issue, (playback of a 44.1k file @ 48k) but that would change the pitch slightly as well. Does this happen on both 44.1 and 48k files? Is YT (or whatever) still open when this occurs? Does the 'Rate' indicator (bottom-mid-left on timeline) read 1.00 on playback?

You may try changing the OS 'Default playback quality' setting from 44.1 to 48k (or visa-versa). In Win 10: "Control Panel> Sound> Playback> Right-click 'Speakers' to get to the 'Properties' setting, then select the 'Advanced' tab and change the 'Default format'"

However, you may first try this first changing the 'Exclusive mode' settings in the same 'Default playback quality' window (On my WIn 10 PC, both boxes are check-marked).

James-Wolff wrote on 1/3/2019, 3:36 PM

Thank you rraud. Based on your suggestions, I looked first at the Windows Control Panel>Sound>Playback and found the default player quality was indeed set to 48K, but I couldn't change it. That took me to my Roland digital interface which was set at 48K, so I was able to change the default on that back to 44.1K. And that did the trick!

So, THANK YOU very much!!


rraud wrote on 1/4/2019, 9:26 AM

A few years ago, I had a similar occurrence with an Echo Mia soundcard, which had an option to 'lock' the sample rate. Glad you are back on track.