Using any VST Plugins in a Batch conversion always fails.

Vince-HA wrote on 7/30/2020, 4:37 PM

I use a batch conversion script with Magix "wave hammer" and "normalize" effects. I recently added a VST Plug-in to the batch list but it fails every time. The plug-in is a VST3, 64Bit plug from Neutron but I have tried to use other VST2 VST3 plug-ins and also tried using other developers and nothing works. I'm using Sound Forge Pro 14 now but this action was not a problem in SF Pro10.



rraud wrote on 7/30/2020, 6:04 PM

Try this @Vince-HA. I think all plug-ins must be in a chain for BC in SF Pro 11 and beyond

Go to FX Favorites, select "Apply plug-in chain" Set up your plug-ins in a chain as so desired and save as a new chain preset and exit the Fx favorites window ... This step is not necessary if you already have a specific plug-in chain preset.

Then... open Tools> Batch converter, and select your files as usual. In the 'Process' tab select 'Apply Plug-in Chain' and your desired (Chain) preset... "Run Job".

This method worked for me in SF Pro 13 and 14. SF Pro 11 (SCS) and subsequent builds handle multiple plug-ins (chains) 'differently'' (modal) .... different is not 'better' IMO. Everything else in the BC seem the same as the legacy SF Pro.

Vince-HA wrote on 8/3/2020, 6:04 PM

PERFECT!! I never knew you could "Apply a Plug-In Chain" to a Chain of commands in a batch converter!

But I do now and it works great!

Thank You Very Much!