VST Compatibility list

anthony-james wrote on 5/27/2018, 12:28 AM

I am compiling a compatibility list for VST plugins that have been tested in Acid Pro 8 in both 64 bit and 32 bit versions and will continue to update this list so we can assist the development team to resolve any  issues arising from plugin errors.

Please supply details of your system specifications including OS version, Software version, Computer Hardware etc. when posting details of any plugins you have tested...thanks.

Here are a few of the plugins I have tested so far using the 64 Bit version of AP8 with native 64 bit plugins...

*****************************************************
OS: Windows 7 Pro 64 Bit + Service Pack 1
Acid Version: Acid Pro8 64 Bit v8.0.1 Build 143
Hardware: Sabertooth X58 Motherboard + i7-950 Quadcore CPU + 12 Gig RAM + MSI NVidia GTX-460 GPU

Soundcards:
EMU 0404 USB (64 Bit Driver v1.3) - Working in ASIO mode
Sound Devices USB Pre 2 (64 Bit Driver v1.0) - Working in ASIO mode

VST Instruments:

Air Music Technology Xpand2 Software Synthesizer v2.2.7 (VST 2 64 bit)
Working

Reveal Sound Spire Software Synthesizer v1.1.13 (VST 2 64 bit)
Working

Xfer Records Serum v1.2.0 b7 Demo (VST 2 64 bit)
Working

Perfect Drums Player v1.5 (VST 2 64 bit)
Working

VST Effects:

REA Plugins v2.36 (VST 2 64 bit)
Working

*****************************************************

Input from Acid Pro 8 users will be vital in helping the development team update and maintain the stability and compatibility of AP8 with other third party software products so if you are having problems let us know about it so it can be resolved ASAP...

Comments

vani-bvani wrote on 5/28/2018, 5:20 AM

Windows 10

waves 9

antares auto-tune 5 / evo / 8.1

not working

any ideas ?

 

 

anthony-james wrote on 5/28/2018, 8:16 PM

Can you be more specific with the problem you are having?

Are the plug-ins loading or are they failing at startup... If they are loading what problems are you having with the plug-ins ie. crashing or GUI errors etc

What exact version of Windows 10 and these plug-ins are you using... Have you tried the latest updates to OS and VST...

To track down issues with specific plug-in errors you will need to give more details...Thanks.

 

 

Techman25 wrote on 2/18/2019, 9:49 PM

My OS is windows 10 home and I'm trying to add auto tune access and key but when I scan in acid pro they don't show up.

vokulsky1 wrote on 3/5/2019, 10:29 AM

Will the plugins that I purchased for the Magix Music Maker program work in Acid Pro?

ralftaro wrote on 3/12/2019, 5:17 AM

Will the plugins that I purchased for the Magix Music Maker program work in Acid Pro?

 

Unfortunately, at this point in time, the ACID product line doesn't feature any access to the MAGIX in-app store system and its back-end data yet. Consequently, ACID wouldn't have any knowledge of what plug-ins/instruments you did or didn't purchase through Music Maker. However, MAGIX is currently looking into a satisfactory solution for the not-so-distant future. So, even if ACID may not get the fully-featured in-app store system for now, it will get some sort of access to the store back-end, where you can punch in your MAGIX account details once, ACID will check online what instruments you have purchased through the store, and unlock them for use in ACID.

Cheers!

 

WatchWoods wrote on 3/17/2019, 8:46 AM

Windows 10 Home x64 Version 10.0.17134

16 gb ram

GEFORCE GTX 1070

Newest version of Acid 8.0 as of 03/17/19

 

VST Effect

Grossbeat - Not working

Opens up, but won't display in most cases. The 32 bit version has opened a few times, but then just started to freeze Acid. Prior to most recent update, Grossbeat barely worked, not enough to be in a useable state.

anthony-james wrote on 5/7/2019, 5:38 AM

OS: Windows 7 Pro 64 Bit + Service Pack 1
Acid Version: Acid Pro8 64 Bit v8.0.7 Build 223
Hardware: Sabertooth X58 Motherboard + i7-950 Quadcore CPU + 12 Gig RAM + MSI NVidia GTX-460 GPU

Fabfilter Pro-R v1. 04

Fabfilter Pro-C2 v2.06

Fabfilter Pro-Q2 v2.12

Fabfilter Pro-L v1.13

Fabfilter Pro-MB v1. 17

Fabfilter Saturn v1.13

All working well with Acid pro v8.0.7 which is very stable on my system...

 

 

anthony-james wrote on 5/19/2019, 3:59 AM

All previous plugins are working fine after updating Acid pro to version 8.0.8

Serato Sample v1.1 working after updating Direct X to version 9.0c. GUI wasn't showing up before running the updater.

Matt-Francis wrote on 5/23/2019, 3:32 AM

Windows 10, 64 bit

Acid Pro 8 64 bit, latest build.

IZotope ACIDEffectsRack bundled with Acid Pro 7

Not working. Not even showing up in AP8.

I was told by MAGIX to delete and reinstall everything, which I did, but it made no difference. Seriously bugging me because I used that effects rack on some tracks I want to transfer to AP8 but I will lose all the nice effects I spent ages getting right..

Djronrella wrote on 5/23/2019, 5:02 AM

All my Sony products we're transferred to my Magix website! I was able to re download it!

anthony-james wrote on 6/8/2019, 12:23 AM

Perfect Drums v1.6.0 not working properly with Acid pro v8.0.9.

If you add an instance of Perfect Drums to a MIDI track it seems to load OK but you can't preview the kit samples... Also

the project will fail to load the next time you open the saved project.... Acid failed to load the project... Unknown error... blah blah blah.

Martin_H_Emes wrote on 6/12/2019, 5:29 PM

Hi guys, I recently returned to music making and I was happy to see ACID has been revitalised, so I bought ACID pro 8. Running 64bit on Windows 10. Building up my setup, here's what I've found:

Plugins that work:

Fabfilter Q3 and C2

Guitar Rig 5

Plugins that don't appear to work:

EZdrummer 2

Brainworx Plugin Alliance bundle

Also I've just bought Gullfoss the intelligent EQ plugin (check it out if you haven't heard of it, it's still in "pre release" phase at the moment it seems, and it has a reduced price.) But unfortunately it's gone to the "failed" plugins folder in ACID. I've emailed Soundtheory, the studio behind Gullfoss, about that. As it's at an early stage perhaps compatibility will be improved over time.

I am a bit worried however, I like ACID and it's the only DAW I know well, so I want to keep using it. But obviously it needs to work with plugins.

EDIT: I've been running ACID 8 v119, the version that was on the DVD I bought. Looking to make sure I'm updated to the latest version.

EDIT 2: Good news! After I updated ACID, I found Gullfoss is working. So I suppose the lesson here is to make sure you've downloaded the newest update. Gullfoss is seriously amazing by the way, I strongly recommend anyone who hasn't heard of it to look it up.

anthony-james wrote on 6/14/2019, 4:41 AM

Mercuriall Spark v1.1.1, Ignite Amps Emissary v2.0 and Nadir v2.0 IR loader all working great in Acid Pro8 64

steven-cluthe wrote on 6/14/2019, 11:08 AM

I reluctantly purchased AP9 yesterday hoping that it would work seamlessly, nope not even close, I could have learned new DAW software with time Ive been spending trying to get these vst to load correctly . I really hope you guys are working hard to fix these bugs.

 

 

steven-cluthe wrote on 6/14/2019, 11:11 AM

Also AP9 tells me it's looking for waveshell-vst 5.0.dll while loading program. I have a feeling this is an imortant file. Can you give me some insight

mjn wrote on 6/17/2019, 1:28 PM

That would be your plug-ins made by the company "Waves" I believe... can't help you get past it, I'm on ACID Pro 7. Waiting for Nine to be deemed working well by most posters here before getting into it.

sheppo wrote on 6/17/2019, 2:23 PM

@Stephen-Evans - are you running the latest, or semi recent version of Waves?

Stephen-Evans wrote on 6/18/2019, 11:34 AM

@sheppo - not running Waves at all.

sheppo wrote on 6/19/2019, 2:35 PM

fair enough, I have wave shell DLLs in the Waves installation folder. But, I believe Waves also make third party audio devices, control surfaces, drivers, amongst many other things, which may explain the error. It's not one I've seen before sorry