Weird behaviour in MM 2023 vers : midi played back.. or not

Thierry-Antoine-Woirgard wrote on 12/1/2022, 8:43 AM

[bug report] 😕 (I don't know why I ordered the upgrade. I had MM 2019, then 2020 and never saw it working without troubles)

I recorded a (monophonic) midi track with my Yamaha WX5 midi sax using external sound (Aria with improvizer Audio trumpet sound) -- dunno if it is important to mention or not.

I then decided to split this recording and duplicate the first 16 measures using split, then copy/paste (having pushed the end of the recording 17 measures away, leaving a blank measure between the firstblock+its copy and the rest.

When playing back, the behaviour is strange : sometimes everything is ok, more often, instead of playing the 2nd copy of the 16 first measures, it plays what was previously there...

... and sometimes no midi is played, only the 3 audio tracks containing library stuff

I tried to see if there is something in the end of my first block by extending the object : nothing more, it has been cut properly after the 16th measure.

I tried to copy the second block (measure 17 to 32 ) to another track, same (weird) stuff

I tried to use internal instruments : identical random (often wrong) result.


Has anyone experienced any problem of this kind ?

I am going to record a fresh new project, even simpler to be able to give you more elements of information to clearly identify where is the bug

Best regards,



Thierry-Antoine-Woirgard wrote on 12/1/2022, 9:02 AM

Just made another try.

This time I split the midi track but instead of copy/paste, I copied the object and used "insert object" and it seems to be working...

Using paste may copy something in a hidden place or I don't understand anything.

This just means that I should not try to replicate the way I use other DAWs


Cloudglow wrote on 12/1/2022, 12:02 PM

Sometimes MMM refuses to play midi notes, especially when at the loops end. I corrected my problems by removing the MIDI notes which were silent and putting back them, then only they worked. convenient isn't it?

Sadly there are also other bugs in MIDI editor. This is just one of them.