rraud wrote on 11/5/2021, 9:51 AM

Has RX been installed?
Is the location of the <.dll> files designated in the default or alternate VST search folders? That setting is in "Options> Preferences> VST Effects". Assuming you have Sound Forge Pro and RX Elements has been installed, the RX (iZRX#... .dll) files should be in the"Steinberg" vst folder in the root "Program files" and/or "Program files (x86)" folders.

Once the search routing is set, you can add it to your "FX Favorites" menu using the 'Organize' tool. RX is not in the SF main menus by default.

btw, welcome to the Magix Sound Forge users community @bruce-miller.

bruce-miller wrote on 11/5/2021, 10:49 AM

thank you but it did not show up even after i installed it again. it doesn't even show up in the windows start menu, it does show up in add/remove programs, but it is not on my desktop or the start menu program list or in the list of available vst effects under preferences.

rraud wrote on 11/5/2021, 12:33 PM

@bruce-miller, RX Elements does not have the stand-alone option like RX Standard or RX Advanced, so It would not be in the Windows Program's 'Start' menu.
I think you are overlooking a Sound Forge setting, Re-read my previous comment and confirm the VST search folders settings, Then click 'Refresh '

Restart SF and go to 'FX Favorites> Organize> Choose VST' and drag the desired RX items to the Favorites folder. The RX items will then be available in 'FX Favorites'

bruce-miller wrote on 11/9/2021, 3:30 PM

unfortunately it [despite repeated re-installs, it goes through the motion of installing after "uninstalling previous versions" which is futile as there ARE no previous versions on my puter] still does not show up ANYWHERE on my puter in ANY folder nor in the VST folders that sound forge looks for. could it be because i already have standalone versions of Rx?

rraud wrote on 11/9/2021, 5:04 PM

If you have RX Standard or Advanced, why do you need RX Elements? I believe the aforementioned can be used as plug-ins and well as stand-a-lone. In any case, I do not think it would prevent RX Elements from installing and the RX <.dll> plug-in files may be in another folder somewhere.
As I have stated, the default folder is usually 'Steinberg> Vst' in 'Program Files' and/or 'Program Files (x86)' for the VST-2 format. If you installed the VST-3 format, they would be in 'Program Files> Common files> VST-3> iZotope', assuming you have a 64 bit Win 10 PC.

bruce-miller wrote on 11/9/2021, 5:09 PM

when i bought SF15 i was led to believe it had rx elements bundled inside of it that works within sound forge. that would save me and my old computer of limited resources the trouble of having to open another external audio program at the same time that sound forge was up and running, occupying memory. one of the reasons i have been using sound forge all these years [since the 90s] was that it had a relatively small footprint in system memory/resources and i could use it somewhat longer than other audio programs before i exhausted my system resources. so you can see why i'd like to be able to use elements within sound forge and not have to open another [external to sound forge] program. i hope i am making sense here.

craig-d wrote on 11/10/2021, 1:51 AM

hi! could you please share which version of sound forge you have...there is Audio Studio and Pro...the Pro version comes with iZotope RX 8 Elements, but Audio Studio does not...please check and make sure you have the Pro version. also, it should be noted that the RX 8 Elements is an iZotope plugin, not a Sound Forge plugin, so it has to be installed, and it will run like any other third party plugin. So, if you already have the advanced version, it will also run in won't make a difference in the program's performance--and just to clarify: you can use the Advanced version within SF just the same as Elements.

bruce-miller wrote on 11/10/2021, 8:10 AM

it is the SF15 pro version, the expensive one. elements does not show up anywhere, in any editor, after i install it, like it just goes through the motions of installing without a result and it always tries to uninstall a previous version.

rraud wrote on 11/10/2021, 9:33 AM

Are you uninstalling and reinstalling Sound Forge? That will no install RX Elements, which is an (check mark) option in the installation manager. Did the RX Elements installer unpack successfully? If so, the file iZotope_RX_8_Elements_8.1.0_201123_12-41_8_1_0_0.exe (or similar) should be in your "C:\Users\user name\Documents\MAGIX Downloads Installationsmanager" .

If you did install RX Elements, it also would be listed in the Windows default or third-party uninstallers. Open an uninstaller to confirm it is in fact (or is not) listed.

bruce-miller wrote on 11/10/2021, 10:02 AM

yes to all that except i did not uninstall and reinstall sound forge 15. i must have tried installing Rx Elements 10 times now but to no avail. windows defender gives no clue as to whether or not it is blocking it.

rraud wrote on 11/10/2021, 12:54 PM

@bruce-miller, so.. the windows uninstaller has RX Elements listed?

If so, that would indicate it is installed... and you looked in the Sound Forge 'FX Favorites> Organize> All, Third-Party and VST folders?
The VST-2 (32 & 64 bit) and VST-3 (64 bit) would be listed if installed and the search folder(s) are selected in "Options> Preferences> VST Effects"

Here is a link to download the unpacked RX Elements installer if you want to try it.
( )


bruce-miller wrote on 11/10/2021, 8:07 PM

actually it doesn't even show up in the uninstall section AND programs in general. but i will try the elements unpacked installer to be sure. thank you.

craig-d wrote on 11/11/2021, 1:37 AM

i have heard a few iZotope users here and there have issues with the installer...if this is the case, it would be a good idea to contact iZotope support and see if they have any suggestions for that.

bruce-miller wrote on 11/11/2021, 1:59 AM

already did that, they are stumped.

sathyme wrote on 12/2/2021, 11:54 AM

Hi Bruce:

I had a problem like that with an earlier version of SF - Now you MAY have tried this - and it STILL didn't work - but I remember having to search and search and I found THIS article and I have used it with EACH subsequent SF I have purchased. Take a look - It might help you (The first article - the others are for other programs):



bruce-miller wrote on 12/2/2021, 4:34 PM

thank you, i did do that. i guess it just won't work on my puter for some reason. i do have another installation of the standalone izotopeRx, was just hoping to be able to use it inside SF, as my old puter has limited memory and doesn't do multiple open programs that well.

rraud wrote on 12/2/2021, 4:51 PM

The iZotope RX VST-3 plug-in files <.dll> are in the "Program files> Common files> VST3> iZotope" so one of the SF's 'VST search folders' should be directed to that vicinity... though I am not certain that is the problem.

bruce-miller wrote on 12/3/2021, 2:31 AM

i went there, it wasn't there, so there must be something majorly wrong with my puter that prevents it from installing.

Shawn-Rogers wrote on 1/17/2024, 9:49 AM

Did anyone figure out how to fix this? None of my Izotope plugins work in Soundforge 15 on windows 10 with I9 processor. They all crash the program. How do you bundel non working software? Please help. Thanks so very much.

SP. wrote on 1/17/2024, 10:07 AM


1) click Options > Preferences > VST Effects and click Refresh (this may take a while, depending on how many plugins you have).

2) after the refresh, click File > Reset all preferences and cached data, check the box 'Delete all cached application data' and click Yes, then restart the program.