Comments

johnebaker wrote on 5/5/2016, 2:21 AM

Hi

If you were using the free Online Album - see this post.

If you have purchased one of the Online album packages check that you are using the correct URL in your online settings and if you also have a domain name pointing to the album, check that you have it correctly set up.

John EB

Last changed by johnebaker on 5/5/2016, 2:21 AM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

douggiefresh wrote on 1/30/2019, 6:43 PM

Hello John, you responded to a question I had a few years ago. I'm having the same problem again. I have a paid subscription to Magix Online World, however I'm unable to access my Magix Online Album Premium. The following error message is what I get every time. Can you help me?

The connection has timed out

The server at www.magix-photos.com is taking too long to respond.

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

browj2 wrote on 1/31/2019, 8:37 AM

@douggiefresh

Hi,

I just tested mine and it works fine.

Are you going through www.magix-photos.com or directly to your album, which should be something like:

http://yourusername.magix.net/album

The URL www.magix-photos.com redirects to https://www.magix-online.com/us/ which is the account for online, including the Control Centre.

Did you try with another program, like Edge or Chrome?

John CB

douggiefresh wrote on 2/8/2019, 2:18 PM

browj2 I've tried changing my browser from Microsoft Edge, to Google Chrome to Firefox. I've installed the latest version of Adobe flash and updated my Java. None of this has helped. Do you think it could be something in my PC settings?

browj2 wrote on 2/11/2019, 9:31 AM

Hi,

You didn't answer my question.

Are you going through www.magix-photos.com or directly to your album, which should be something like:

http://yourusername.magix.net/album

Are you trying to access your album or the online control center page?

Are you using the correct user name in the address?

Why are you using www.magix-photos.com? As I told you, it redirects to the online site.

What is the exact address that you are trying to access?

John CB