MAGIX Help Center

Error message: "DVDMaker.dll has detected a version conflict [..]"

This error message indicates that your burner can't be found because the burn routines are out of date.

To resolve this issue, download and install the latest burn routine update.

Win 8 burn routine update

Win 10 burn routine update