AVCHD & HEVC Encoder Export "atmen" führt zu unscharfem Video-Export

Kommentare

manfred-salzmann schrieb am 23.10.2017 um 10:57 Uhr

Einstellungen:

newpapa schrieb am 23.10.2017 um 11:03 Uhr

Hallo,

@manfred-salzmann Ich leide doch nicht an Einbildung? Oder doch?

Der Fehler ist schon zu sehen. Kann aber nochmals nur feststellen: Bei mir kann ich den Fehler mit Test-jpgs / bmps nicht reproduzieren. Ist der fehler auch in VDL zu sehen, wenn du die Datei dort Frame für Frame betrachtest?

manfred-salzmann schrieb am 23.10.2017 um 11:08 Uhr

Anbei ein AVCHD Video mit einem anderen Encoder/Software.....keine Effekte. Also keine Einbildung?!

Einstellungen (Bitrate usw. identisch).

manfred-salzmann schrieb am 23.10.2017 um 11:10 Uhr

Nein. In der Voransicht ist alles o. k. Und das ist ja nur ein Beispiel. In Video-Streams ist das auch gut zu erkennen. Allerdings natürlich viel schwieriger. Da ist es mir auch zum ersten Mal aufgefallen. Und das Video wird sichtbar unscharf (auf einem Beamer unerträglich, wie ich finde).

manfred-salzmann schrieb am 23.10.2017 um 11:18 Uhr

Hier mal das Bild zum testen.....weil das sehr geeignet ist.

Vielleicht ist das ja nur auf meinen PC'S & Magix so, denn mit anderen Encodern....alles Prima.

Grund für meine Hartnäckigkeit: Ich möchte zukünftig nicht so wie zu MPEG2-Zeiten vorgehen Die Filme mit MAGIX bearbeiten, unkomprimiert ausgeben und mit einem anderen MPEG2-Encoder fertigstellen (der MPEG2 war von MAGIX auch nicht so besonders). Bei FHD/50Hz Videos wird das aber langsam etwas umständlich. Deswegen bin ich hier so penetrant, weil ich mich eigentlich nicht von MAGIX trennen möchte (bin seit glaube ich schon seit 2004 dabei).

newpapa schrieb am 23.10.2017 um 11:24 Uhr

Hallo,

Du hast mich falsch verstanden. Das ecodierte (fehlerbehaftete) Video mal im Projekt auf Framelänge gezoomt ansehen. Da müsste der Fehler zu sehen sein - könnte theoretisch auch am Player liegen.

Und nur mal so eine Idee: Encodiere mal ohne Hardwarebeschleunigung.

Das mit dem Beamer kann ich nachvollziehen. Hatte vor Jahren beim Übergang auf HD solche "Pumpprobleme". War am Beamer dann wesentlich deutlicher zu sehen.

Nachtrag: Bin jetzt etwas verunsichert. Das Video von 10.56 Uhr sehe ich fehlerfrei.

Nachtrag 2: Also am Bild liegt es nicht. Auch dein jpg bleibt fehlerfrei.

manfred-salzmann schrieb am 23.10.2017 um 11:40 Uhr

NewPapa: Teste doch mal deinen Export mit meinem Bild. Und das der Fehler vorhanden ist, habe ich schon so oft reproduziert! Ich dachte natürlich auch zuerst: Ich bin schuld, das Material ist schuld usw. Das hat mich schon Stunden gekostet! Deshalb bin ich ja dann auch zu einem anderen Encoder übergegangen. Mit Erfolg! (Bin noch in der Testphase, habe also noch nicht kaufen müssen.)

P. S. Im gezoomten Vorschaubild von VDL ist alles o. k. Und ich habe schon allle möglichen Einstellungen verändert, um der Sache auf den Grund zu gehen. Wie gesagt ist habe mittlerweile Stunden experimentiert und alles mögliche ausprobiert.

Nachtrag: NewPapa: Na wenn bei Dir alles o. k. ist, dann liegt es dann doch an meinen PC's und MAGIX. Dann muss ich wohl doch langsam Abschied von MAGIX nehmen und ganz zu PEGASYS wechseln. Danke für deine Zeit!

newpapa schrieb am 23.10.2017 um 11:48 Uhr

Hallo,

habe ich gemacht = Nachtrag 2 in der vorhergehenden Antwort - kann den Fehler bei mir nach wie vor nicht reproduzieren.(Immer nur AVCHD)

manfred-salzmann schrieb am 23.10.2017 um 12:04 Uhr

Nur noch einmal zum Abschluss: Beim unkomprimierten, MPEG-2 und MJPEG Export ist alles o. k.!

Und ich habe das Fehlerverhalten mit 4 verschiedenen Playern getestet.....

BilderMacher schrieb am 23.10.2017 um 14:04 Uhr

Leider ist es mit dem von hier zur Verfügung gestellten Screenshot bei mir in VProX (9) auch so, wenn ich AVCHD, Intel-hardwarebeschleunigt exportiere.

Aber ein Export mit aktivierter Option "Videoeffekte auf GPU berechnen" bringt den Fehler nicht. Er tritt auch nicht auf, wenn, wie schon vorgeschlagen, ohne Hardwarebeschleunigung exportiert wird.

 

Ich habe nur dieses Einzelbild exportiert. Wie es sich in einem Projekt mit anderem Videomaterial davor oder dahinter verhält, kann ich nicht sagen. Einschränken muss ich auch, dass mir das bei einem "richtigen" Projekt mit Foto- und Videomaterial nicht aufgefallen ist.

juergendiener schrieb am 23.10.2017 um 16:31 Uhr

Leider erschließt sich mir nicht, welche Einstellungen zu welchem Video gehören.

Einmal ist die Bitrate 10000, einmal glaube ich 26000

Auf jeden Fall kenne ich das Fehlerbild und es liegt meiner Meinung nach an den Einstellungen.

Bitrate 10000 ist definitiv zu wenig, 26000 ist OK. Codierqualität auf höchste Stufe (dauert halt ewig) und die GOP - Rate extrem reduzieren (erhöht Speicherbedarf).

Letztlich muss man dann Kosten und Nutzen für sich selbst abwägen.

Aber das ist definitiv kein Defekt oder irgendetwas, dass man per Mausklick oder EINER Einstellung ändern kann.

Bessere Qualität gibt es nur mit mehr Speicherbedarf und/oder längerer Renderzeit.

Hauptplatine : ASRock H61M-DGS R2.0

Gesamtspeicher : 15.75GB DIMM DDR3

Prozessor(en)

Prozessor : Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz (4C 8T 3.89GHz, 3.9GHz IMC, 4x 256kB L2, 8MB L3)

Chipsatz

Speichercontroller : ASRock Core (Ivy Bridge) DRAM Controller 100MHz, 2x 8GB DIMM DDR3 1GHz 128-bit, Interne Grafikeinheit

Speichermodul(e)

Speichermodul : 99U5471-047.A00LF 8GB DIMM DDR3 PC3-8500U DDR3-1066

Speichermodul : 99U5471-047.A00LF 8GB DIMM DDR3 PC3-8500U DDR3-1066

Grafikkarte : Intel(R) HD Graphics 4000 (16CU 128SP SM5.0 350MHz/1.15GHz, 320kB L2, 256MB DDR3 1GHz 128-bit, Interne Grafikeinheit)

Grafikkarte : NVIDIA GeForce GTX 1050 Ti (6CU 768SP SM6.4 1.38GHz/1.5GHz, 1MB L2, 4GB 7GHz 128-bit, PCIe 3.0 x16)

Betriebssystem

Windowssystem : Microsoft Windows 10 Privat 10.0.18362

Kompatibel mit Plattform : x64

1903

 

manfred-salzmann schrieb am 23.10.2017 um 17:28 Uhr

Die Screenshots mit den Einstellungen haben eine Überschrift AVCHD, HEVC, MP4. Deswegen dachte ich ist klar, das sich die Screenshots auf das Video darüber beziehen. Sorry für die Unklarheit?!

Bei HEVC ist die Bitrate bei der Standardeinstellung so gering. Aber ich habe viele Stunden mit den verschiedensten Einstellungen auf zwei verschiedenen PC's zugebracht und es ist mir nicht gelungen den Effekt zu eliminieren. Nur die Intensität war manchmal kleiner.

Software/Hardware Encoding brachte keinen Unterschied. Mit oder ohne GPU auch nicht. Bei HEVC habe ich keine Hardwareunterstützung.

Ich arbeite seit 1978 mit Computern. Und ich gebe nicht so schnell auf, bevor ich andere frage. Und ich bin bei Qualitätsfragen bei Videos pingelig.

Leider ist es mit dem von hier zur Verfügung gestellten Screenshot bei mir in VProX (9) auch so, wenn ich AVCHD, Intel-hardwarebeschleunigt exportiere.

Aber ein Export mit aktivierter Option "Videoeffekte auf GPU berechnen" bringt den Fehler nicht. Er tritt auch nicht auf, wenn, wie schon vorgeschlagen, ohne Hardwarebeschleunigung exportiert wird.

 

Ich habe nur dieses Einzelbild exportiert. Wie es sich in einem Projekt mit anderem Videomaterial davor oder dahinter verhält, kann ich nicht sagen. Einschränken muss ich auch, dass mir das bei einem "richtigen" Projekt mit Foto- und Videomaterial nicht aufgefallen ist.

Gott sei Dank ist das zucken bei mir nicht so stark. Aber es ist der gleiche Effekt am Anfang/Ende eines GOP's.

manfred-salzmann schrieb am 23.10.2017 um 17:42 Uhr

Hallo,

habe versucht, den Fehler zu reproduzieren. Gelingt mir nicht. Mit welchen AVCHD-Einstellungen arbeitest Du? (Mit HEVC arbeite ich nicht).

Mein Grundeinstellung, auch mit Variation keinen Fehler erhalten.

Habe ich mit den gleichen Einstellungen auch schon exportiert. Keine Verbesserung.

Einstellungen:

 

Bei mir wird nicht die Hardware benutzt.

Vielleicht ist das Ergebnis etwas ruhiger?! Besonders muss man auf den rechten blaugrünen Bereich achten.

Da folgende Video wurde mit den gleichen Einstellungen, aber auf meinem Laptop exportiert. Gleiches Verhalten!

frankberger85 schrieb am 23.10.2017 um 22:48 Uhr

Hallo @manfred-salzmann,

ich kann den "Pumpen"-Effekt in Deinen Videos nicht entdecken... Was meinst Du genau?

LG

- Frank

 

UFO schrieb am 23.10.2017 um 22:52 Uhr

Genau so ging es mir auch....

VDL premium 2016 und (15.0.0.114)
VDL premium 2018 (17.0.1.141)
WIN10 64bit
AMD FX-8350 8 Kern / 8 Threads CPU in einem
ASUS M5A99X Mainboard und einer
NVIDIA GTX960 Grafikkarte
--> also leider keine Hardwarebeschleunigung... 😢

manfred-salzmann schrieb am 24.10.2017 um 08:03 Uhr

Genau so ging es mir auch....

..und was war DEINE Lösung des Problems? Bitte um HILFE!

manfred-salzmann schrieb am 24.10.2017 um 08:04 Uhr

Hallo @manfred-salzmann,

ich kann den "Pumpen"-Effekt in Deinen Videos nicht entdecken... Was meinst Du genau?

LG

- Frank

 

Der Blick sollte sich auf den rechten Seebereich konzentrieren. Dort schwankt das blau/grün im Sekundentakt (GOP=50, FHD 50Hz). Das ist besonders stark natürlich auf einem Beamer zu sehen oder auf einem 24" Bildschirm.

BilderMacher schrieb am 24.10.2017 um 08:53 Uhr

..und was war DEINE Lösung des Problems?

Es gibt Vorschläge, ob sie die Lösung sind(?):

  • newpapa: Und nur mal so eine Idee: Encodiere mal ohne Hardwarebeschleunigung.
  • ich: Export mit aktivierter Option "Videoeffekte auf GPU berechnen"
manfred-salzmann schrieb am 24.10.2017 um 10:04 Uhr

..und was war DEINE Lösung des Problems?

Es gibt Vorschläge, ob sie die Lösung sind(?):

  • newpapa: Und nur mal so eine Idee: Encodiere mal ohne Hardwarebeschleunigung.
  • ich: Export mit aktivierter Option "Videoeffekte auf GPU berechnen"
  • Es erfolgt bei mir immer Software-Encoding, unabhängig was eingestellt wurde. Deshalb habe ich auch mal den Mixdownfortschritt gezeigt:...keine Hardwarebeschleunigung.
  • Habe ich schon versucht mit und ohne GPU.

Leider nicht erfolgreich.

manfred-salzmann schrieb am 24.10.2017 um 17:31 Uhr

Hallo,

habe ich gemacht = Nachtrag 2 in der vorhergehenden Antwort - kann den Fehler bei mir nach wie vor nicht reproduzieren.(Immer nur AVCHD)

Kannst du mal dein AVCHD Video mit meinen Bild (20s Dauer wäre schön) hochladen, damit ich mir deinen Export mal ansehen kann?

newpapa schrieb am 24.10.2017 um 17:52 Uhr

Hallo,

Intel-Encoder /AVCHD; encodierte m2ts nach mts umbenannt und so hochgeladen.

Video
ID                                       : 4113 (0x1011)
Menü-ID                                  : 1 (0x1)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format-Profil                            : High@L4.2
Format-Einstellungen für CABAC           : Ja
Format-Einstellungen für RefFrames       : 3 frames
Codec-ID                                 : 27
Dauer                                    : 41s 80 ms
Bitraten-Modus                           : variabel
Bitrate                                  : 19,8 Mb/s
maximale Bitrate                         : 28,0 Mb/s
Breite                                   : 1 920 Pixel
Höhe                                     : 1 080 Pixel
Bildseitenverhältnis                     : 16:9
Bildwiederholungsrate                    : 50,000 FPS
ColorSpace                               : YUV
ChromaSubsampling/String                 : 4:2:0
BitDepth/String                          : 8 bits
Scantyp                                  : progressiv
Bits/(Pixel*Frame)                       : 0.191
Stream-Größe                             : 96,7 MiB (94%)

Bei der Wiedergabe sehe ich hier geringe Bildsprünge. Die habe ich jedoch nicht beider Wiedergabe dieser Datei am PC mit dem VLC-Player.

manfred-salzmann schrieb am 24.10.2017 um 18:23 Uhr

Danke für Dein Video! Aber ich sehe auch da Sprünge im Bild....Allerdings nicht im Sekundentakt, sondern langsamer. Habe das mit 3 versch. Playern getestet. Bist du sicher, dass das Video bei Dir die ganze Zeit nicht springt. Vor allem im rechten blau/grünen Bereich?

Danke für Deine Mühe!

P. S. Kannst du das noch einmal mit der Größenänderung des Bildes auf 1920x1080 + Zentrierung machen? Das Bild ist nämlich kleiner.

newpapa schrieb am 24.10.2017 um 19:57 Uhr

Hallo,

so wie ich Dein Bild (in deiner Antwort) hier sehe, so erhalte ich es auch kopiert auf meinem PC. So sieht es dann auch encodiert als Video aus und so sehe ich es auch in meiner Antwort hier in Magix wieder. Kann nicht finden, das was fehlt. Überprüfung (Mediainfo und auch Magix) ergibt, dass ich dein Bild in der Auflösung 1879 x 1080 erhalte. Encodiert habe ich natürlich 1920x1080. Insofern ergibt sich ein Rand, weil es in der Breite nicht bildfüllend ist. Die Alternative wäre eine (geringe) Verzerrung des Bildes.

Wie schon geschrieben, die Bildsprünge hier habe ich bemerkt. An meinem PC sehe ich das Video (die Datei auf meiner Festplatte) fehlerlos.

manfred-salzmann schrieb am 25.10.2017 um 09:45 Uhr

Hallo,

so wie ich Dein Bild (in deiner Antwort) hier sehe, so erhalte ich es auch kopiert auf meinem PC. So sieht es dann auch encodiert als Video aus und so sehe ich es auch in meiner Antwort hier in Magix wieder. Kann nicht finden, das was fehlt. Überprüfung (Mediainfo und auch Magix) ergibt, dass ich dein Bild in der Auflösung 1879 x 1080 erhalte. Encodiert habe ich natürlich 1920x1080. Insofern ergibt sich ein Rand, weil es in der Breite nicht bildfüllend ist. Die Alternative wäre eine (geringe) Verzerrung des Bildes.

Wie schon geschrieben, die Bildsprünge hier habe ich bemerkt. An meinem PC sehe ich das Video (die Datei auf meiner Festplatte) fehlerlos.

Danke.

Ich wollte ja nur prüfen, ob bei die bei einer Vergrößerung des Bildes (nicht Verzerrung) auf 1920 x XXXX dieser Effekt stärker auftritt, also vielleicht ein Problem mit der Effektbibliothek ist.

Übrigens, was meinst du mit HIER?