AVCHD & HEVC Encoder Export "atmen" führt zu unscharfem Video-Export

Kommentare

Thomschi schrieb am 25.10.2017 um 10:59 Uhr

Das mit dem "Atmen" ist so eine Sache. Auch bei mir ist es in fertigen Projekten zu sehen, deshalb habe ich auch sofort gesehen, was der Herr Salzmann meint.Ich brenne, "oldielike" noch auf BluRay. Besonders ist der Effekt bei vielen Blättern, Büschen oder Gras zu sehen. Da "atmet" mein Bild auch richtig. Nur wenn ich das jemandem zeigen will, so sehen die Leute das auch nicht. Ich habe gedacht nur mir würde so etwas auffallen, deshalb finde ich den gesamten Thread doch interessant. Das ist jetzt kein Beitrag zur Lösung oder eine wirkliche Hilfe, aber ich möchte eben anfügen, dass es diesen Effekt auch bei mir gibt. Meine private Lösung - ich akzeptiere es halt, in dem Wissen, dass es nur mir auffällt.

manfred-salzmann schrieb am 25.10.2017 um 11:26 Uhr

Das mit dem "Atmen" ist so eine Sache. Auch bei mir ist es in fertigen Projekten zu sehen, deshalb habe ich auch sofort gesehen, was der Herr Salzmann meint.Ich brenne, "oldielike" noch auf BluRay. Besonders ist der Effekt bei vielen Blättern, Büschen oder Gras zu sehen. Da "atmet" mein Bild auch richtig. Nur wenn ich das jemandem zeigen will, so sehen die Leute das auch nicht. Ich habe gedacht nur mir würde so etwas auffallen, deshalb finde ich den gesamten Thread doch interessant. Das ist jetzt kein Beitrag zur Lösung oder eine wirkliche Hilfe, aber ich möchte eben anfügen, dass es diesen Effekt auch bei mir gibt. Meine private Lösung - ich akzeptiere es halt, in dem Wissen, dass es nur mir auffällt.

ENDLICH!!!

Ich gehöre auch zu den Leuten, die Fehler in Videos sehen, die andere nicht wahrnehmen. Manchmal bin ich überrascht, wie Offensichtliches nicht gesehen wird. Allerdings wird es auf einem Beamer (Bild ca. 5x3m) dann auch für die "Blinden" meistens auch sichtbar.

Wie bei Thomschi ist es mir auch zuerst besonders bei Videos mit Blättern, Büschen oder Gras aufgefallen. Ich dachte zuerst meine NEUE, TEURE Kamera ist Schrott! Bis ich der Sache auf den Grund gegangen bin. Wie schon gesagt, da sind mittlerweile mehrere Manntage an Arbeit von mir hinein geflossen.

ABER: Wie schon häufig in diesem Thread von mir erwähnt: Mit anderen Encodern tritt dieser Effekt NIE auf! Also ist das nicht "naturgegeben"!

Beim MP4-Export von MAGIX ist das Ergebnis schon o. k. Aber AVCHD UND HEVC ist für mich nicht akzeptabel!

Meine im Moment verfolgte Lösung ist der Wechsel zu einer Kombination von MAGIX & Pegasys. Diese Lösung musste ich schon bei MPEG-2 verfolgen: MJPEG-Export von Magix - Encoding mit Pegasys. Einwandfreie Ergebnisse.

Aber das kann doch nicht immer so bleiben, weil der Rechenaufwand trotz meiner HighPower-Maschinen langsam Tage in Anspruch nimmt! Deshalb dieser Thread, in der Hoffnung einer LÖSUNG.

GuenthiG schrieb am 25.10.2017 um 12:12 Uhr

Ich glaube, das Problem liegt nicht bei Magix. Ich sehe ebenso absolut nichts, was pumpt oder sich irgendwie bewegen würde.

Hast du dir mal die Szene hier im Forum angesehen? Siehst du das hier auch oder nur bei dir am Rechner? Wenn du hier nichts siehst, können wir das auch nicht.

manfred-salzmann schrieb am 25.10.2017 um 12:43 Uhr

Downloaden und dann mit einem Player ansehen.

Beim Video von NewPapa, das ich heruntergeladen habe, sehe ich diesen Effekt auch (wurde an seinem PC gerendert), nur mit einer niedrigeren Frequenz. Übrigens verwende ich 4 verschiedene PC's und Player zum abspielen und 2 verschiedene PC's zum rendern. Wer da was von Hardware/Softwarekonfiguration faselt erinnert mich immer an die Ausreden, die man im Internet auch von anderen Softwareherstellern hören kann.

Und noch einmal: Mit einem anderen Encoder ist alles o. k.!

newpapa schrieb am 25.10.2017 um 13:03 Uhr

Hallo,

@manfred-salzmann

Danke.

Ich wollte ja nur prüfen, ob bei die bei einer Vergrößerung des Bildes (nicht Verzerrung) auf 1920 x XXXX dieser Effekt stärker auftritt, also vielleicht ein Problem mit der Effektbibliothek ist.

Übrigens, was meinst du mit HIER?

Also ich habe nun das Bild auf 1920 proportional vergrößert. Nach wie vor sehe ich an meinem PC sowohl mit dem VLC- als auch Power-DVD-Player keinerlei Bildsprünge. Zur Kontrolle für Deine Vermutung habe ich auch Effekte angewendet (Kontrast /HDR /Schärfe). Auch in diesem Fall konnte ich keinerlei Unregelmäßigkeit entdecken.

Hier: Die Worbedeutung ist "an diesem Ort". Damit wollte ich zum Ausdruck bringen, dass es sich um die Wiedergabe "hier" im Forum handelt und nicht an meinem PC.

Habe etliche Varianten probiert, das hier beschriebene (und von mir auch gesehene) Fehlerbild konnte ich an meinem PC nicht reproduzieren.

manfred-salzmann schrieb am 25.10.2017 um 13:14 Uhr

Danke nochmals für deine Arbeit. Kannst du das Video noch einmal hochladen?

Das du mit HIER das Forum meinst, habe ich mir schon gedacht. Deshalb die Frage.

Dein letztes Video habe ich mir auf meinen PC's als download angesehen. Und wie schon gesagt, den Fehler habe ich da auch gesehen, nur mit einer geringeren Frequenz. Ich schaue mir die Videos immer nur nach einem Download an, denn die Internetexplorer sind meist nicht so gut wie die Player!

Hier noch einmal HEVC-Video zum Download und schauen:

 

P. S. Mit dem Opera-Player sehe ich den Fehler im Forum auch nicht. Aber mein Opera unterstützt NICHt HEVC. D. h. lokal kann ich das Video nicht abspielen! Da bedeutet, was man im Forum sieht ist nicht das Original!

newpapa schrieb am 25.10.2017 um 16:34 Uhr

Hallo,

@manfred-salzmannDa bedeutet, was man im Forum sieht ist nicht das Original!

So ist es. Was ich mit meiner Datei geliefert habe war mts (m2ts) mit 50p und 96MB. Wenn ich die Datei im Magix-Forum jetzt analysiere ist das mp4 mit 30p und 6MB. Ich denke eine weitere, modifizierte Datei kann keine neuen Erkenntnisse liefern. Die MAGIX-mp4-Datei im Forum angesehen und am PC mit dem VLC-Player zeigt jeweils den selben Fehler.

manfred-salzmann schrieb am 26.10.2017 um 08:43 Uhr

LÖSUNG!!!!!! Alte PC-Regel: Never change a running system!

Ich exportiere die Videos mit MAGIX VDL 2014! Da sind die exportierten Videos o. k.!

Leider gilt das nicht für HEVC (war der Grund warum ich auf VDL 2017 aufgerüstet habe! Den Kauf hätte ich mir ersparen sollen!)

Aber der Fehler ist ein Problem der neuen Magix VDL-Version. Mal sehen wie lange es dauert, bis das Pumpen der Videos auch anderen auffällt!

 

  AVCHD-Video mit Magix VDL 2014 encodiert ohne den Pumpeffekt..

Scenestealer schrieb am 27.10.2017 um 00:35 Uhr

Hi

The difference is because 2014 can only use the Main Concept encoder and 2017's default is the Intel encoder which creates the pump effect.

Install and select the Mainconcept codec and encode with the MC encoder in 2017 and the result to .m2ts will be perfect!

Does not help HEVC though....

Peter

English Forum Moderator

System Specs: Intel 6th Gen i7 6700K 4Ghz O.C.4.6GHz, Asus Z170 Pro Gaming MoBo, 16GB DDR4 2133Mhz RAM, Samsung 850 EVO 512GB SSD system disc WD Black 4TB HDD Video Storage, Nvidia GTX1060 OC 6GB, Win10 Pro, MEP2016, 2017, 2018, 2014 Premium and prior, VPX7, 8, 9. Microsoft Surface Pro3 i5 4300U 1.9GHz Max 2.6Ghz, HDGraphics 4400, 4GB Ram 128GB SSD + 64GB Strontium Micro SD card, Win 10Pro, MEP2015 Premium.

manfred-salzmann schrieb am 27.10.2017 um 07:03 Uhr

Thank you for your answer!

Why comes this answer not from german moderators? As you have problably seen, this thread is very long and the main answers where:

Reasons for pumping: Your PC, your installation, your configuration, nothing to see, etc......

I tried today the Mainconcept code in Magix VDL 2017 and it works well as in VDL 2014 and VDL 2015 I have also installed on other PC's.

But two remarks:

a) Mainconcept code is not the newest one

b) What about HEVC?

Magix should give the VDL user also the chance to install an additional codec.

Once again: Thank you very much for your information!!!

Best regards

juergendiener schrieb am 27.10.2017 um 10:14 Uhr

Die Antwort hast du schon am 20.10. bekommen, da wurde dir empfohlen andere encodereinstellungen zu testen.

manfred-salzmann schrieb am 27.10.2017 um 10:26 Uhr

Die Antwort hast du schon am 20.10. bekommen, da wurde dir empfohlen andere encodereinstellungen zu testen.

Das sind nicht andere Encodereinstellungen, sondern das ist ein ANDERER (alter) Encoder. Der musste erst zusätzlich installiert werden. Und das löst auch nicht das Pumpen mit HEVC!

FredW schrieb am 27.10.2017 um 11:47 Uhr

@manfred-salzmann,

ich hatte dir fast eine ähnliche Antwort bereits zu Beginn des Threads geschickt, ebenso die Möglichkeit, dass sich hier Codecs (dll's) vermischt haben. Nachdem du meine Antwort völlig ignoriert hattest, habe ich mir erlaubt sie wieder zu löschen ...

manfred-salzmann schrieb am 27.10.2017 um 12:35 Uhr

@manfred-salzmann,

ich hatte dir fast eine ähnliche Antwort bereits zu Beginn des Threads geschickt, ebenso die Möglichkeit, dass sich hier Codecs (dll's) vermischt haben. Nachdem du meine Antwort völlig ignoriert hattest, habe ich mir erlaubt sie wieder zu löschen ...

Ich verstehe diese Bemerkung einfach nicht!

Hier wurden keine dll's vermischt!

Scenestealer hat sehr wohl bestätigt, dass das Pumpen von den Intel-Codecs kommt, die Magix VDL 2017 standardmäßig verwendet. Eine Erweiterung von Magix VDL 2017 um den Mainconcept Encoder löst das AVCHD-Problem (wobei der Mainconcept Encoder schon lange nicht mehr weiter entwickelt wird und langsam ist).

Das HEVC-Problem lässt sich damit nicht lösen, da MAGIX für VDL 2017 keinen externen Encoder anbietet.

Also ist das nur eine Teillösung und hat aus meiner Sicht NICHTS mit irgendwelchen PC-Konfigurationen zu tun. Denn das Problem macht der INTEL- Encoder (lt. Scenestealer, was ich bestätigen kann) und der sollte bei allen Magix VDL-Usern gleich sein, oder irre ich mich da?

P. S. Habe das gleiche Bild jetzt mit Magix VDL 2015 auf einer Win7-Maschine (also völlig andere Installationsumgebung) im AVCHD-Format exportiert (wird auch der IntelEncoder verwendet). Das gleiche Pumpen.

Also kann ich diesen Effekt auf 2 verschiedenen PC's und 3 verschiedenen Arbeitsumgebungen (2xWin10, 1x Win7) reproduzieren. Ich halte es deshalb für unwahrscheinlich, dass meine Installationsumgebungen für das Pumpen verantwortlich sind.

Eine Lösung für das HEVC-Problem wäre ebenfalls die Bereitstellung eines zusätzliche Encoders.

MfG

Einstellungen unter Win7, Magix VDL 2015:

FredW schrieb am 27.10.2017 um 12:54 Uhr

@manfred-salzmann,

ich hatte meine Bemerkungen und auch Tests gleich zu Beginn gemacht, meinen Kommentar aber wieder gelöscht nachdem die Diskussion in eine andere Richtung ging. Wie auch immer ... ich kann dir nur empfehlen das Beispiel dem Support zu melden.

 

Scenestealer schrieb am 27.10.2017 um 13:23 Uhr

Hi Manfred

Glad to be able to help. An interesting thread!

Your Intel settings in your last screenshot were the same as I used.

The MC encoder is old but there have been a couple of adjustments to the Advanced settings ( and some of the non user adjustable settings) since V2014.

With HEVC and the Intel Encoder I found less pumping with the GOP structure set to Auto.

I have always felt that this pumping in the darker low contrast areas has something to do with the GOP structure / length and raised this some years ago with support, but with no result. Your observations have stirred my interest again.

Best

Ss

System Specs: Intel 6th Gen i7 6700K 4Ghz O.C.4.6GHz, Asus Z170 Pro Gaming MoBo, 16GB DDR4 2133Mhz RAM, Samsung 850 EVO 512GB SSD system disc WD Black 4TB HDD Video Storage, Nvidia GTX1060 OC 6GB, Win10 Pro, MEP2016, 2017, 2018, 2014 Premium and prior, VPX7, 8, 9. Microsoft Surface Pro3 i5 4300U 1.9GHz Max 2.6Ghz, HDGraphics 4400, 4GB Ram 128GB SSD + 64GB Strontium Micro SD card, Win 10Pro, MEP2015 Premium.

juergendiener schrieb am 27.10.2017 um 14:32 Uhr

@manfred-salzmann

Es scheint mir auf diesen drei Seiten einzig darum zu gehen, dass Du immer wieder zu erklären versuchst, dass Deine Software schlecht ist und nicht anständig encodiert.

Alle Lösungsvorschläge wurden aber ignoriert.

Das Pumpen in Deinem Video kommt etwa nach 1 Sekunde und du hast GOP auf 30 stehen. Das passt und ist somit kein Software, sondern ein Bedienfehler.

Ich habe mehrfach den Tipp gegeben, die GOP - Struktur und andere Parameter zu variieren.

Du bekommst auch mit dem Intel Encoder ein ruckelfreies Bild hin.

newpapa schrieb am 27.10.2017 um 16:19 Uhr

Hallo,

langsam drehen sich die Antworten im Kreis. Wer kann noch alle Argumente überblicken!

Feststellungen:

- Bei manchen liefert der Intelencoder Bildschwankungen, hier als "pumpen" bezeichnet. Das ist inzwischen unstrittig. (Bei mir tritt dieser Fehler nicht auf; für HEVC kann ich nicht mitreden.)

- Offensichtlich kann dieser Fehler nicht reproduzierbar durch Encodereinstellungen vermieden werden.

Vorschlag (Moderatoren):

Der Fehler wird MAGIX gemeldet.

Der Thread wird geschlossen.

Wenn jemand eine reproduzierbare Lösung hat oder MAGIX antwortet und eine Lösung hat, dann wird mit Hinweis auf diesen Thread berichtet.