Video Galerie

Kommentare

Skimausi schrieb am 13.02.2019 um 10:39 Uhr

Wäre Vimeo da eine Alternative?

marboe schrieb am 13.02.2019 um 11:15 Uhr

Wäre Vimeo da eine Alternative?

Dann wärst du statt von der Liefergeschwindigkeit von YouTube von der des Vimeo-Anbieters abhängig.

Was BeRo meinte, ist dein eigener Server wo du auch deine Seite hochlädst. Dazu benötigst du nur ein FTP-Programm (wie zB das kostenfreie FileZilla). Wenn du nicht allzu viele Videos hast, dürfte dein Platz auf deinem https-Account durchaus reichen. Gruß Marboe

Skimausi schrieb am 13.02.2019 um 11:20 Uhr

Hallo marboe, vielen Dank auch für Deine Zeilen. Was meinst Du jetzt mit dem https-Account?

Skimausi schrieb am 13.02.2019 um 16:47 Uhr

Ich bin nun gerade richtig unsicher. Das ist alles mega kompliziert. Für die alte Seite, die mit Web Site Maker gemacht wurde, brauchte man auch keinen Server. Das lief doch alles über Magix.
Wenn wir die Seite nun neu designen, dann soll sie natürlich für den Besucher attraktiv, leicht bedienbar und natürlich schnell sein. Da wir für unser Gewerbe Videos brauchen, sollen diese dann auch nicht ewig laden oder schlimmsten Falles noch ruckeln. Weiß gerade nicht, wie ich das lösen kann.

 

marboe schrieb am 13.02.2019 um 18:06 Uhr

Genauso, wie du es grad planst, ist es für ein Unternehmen sehr sinnvoll.

Gemeint war natürlich euer Account bei Magix (oder wahlweise jeder andere Anbieter). Da hast du Zugangsdaten bekommen; du lädst deine Homepage ja "hoch". Und genau diese Daten kannst du auch in jedes FTP-Programm eingeben.

Dort könnten dann auch deine Videos lagern und müssten für die Besucher eurer Seite nicht erst bei YouTube und Co geladen werden. Das ist alles. Gruß Marboe

 

Ergänzung: wenn das für dich in Frage kommt, dann installiere dir ein FTPprogramm, so du noch keines hast. Beispielsweise FileZilla.(gibt es für 32 und für 64 bit)
Dann gib dort deine Zugangsdaten ein - und zack, bist du auf dem benannten "Server". Dann helfen wir dir hier weiter. Das ist nicht schwer und funktioniert wie ein Explorer bei Windows.

BeRo schrieb am 13.02.2019 um 18:06 Uhr

[...] Für die alte Seite, die mit Web Site Maker gemacht wurde, brauchte man auch keinen Server. Das lief doch alles über Magix.[...]

Na ja, da war natürlich auch ein Server im Spiel, nämlich der von Magix. 😊

Genauso kannst Du das auch jetzt handhaben, also alle Videodateien auf dem Server ablegen, auf dem auch Deine Website gehostet wird.

[...] dann soll sie natürlich für den Besucher attraktiv, leicht bedienbar und natürlich schnell sein [...]

Wie schnell der Server ist, das kannst Du bei Deinem ISP (Internet Service Provider) erfragen. Normalerweise reicht die Geschwindigkeit für einfache Videos völlig aus. Da dürfte es also kein Ruckeln oder Aussetzer geben.

Der einfachste Weg, die Videos auf dem Webspace (Server) abzulegen, ist die Benutzung des Hilfsverzeichnisses das der WD automatisch erstellt wenn Du z. B. ein Video per drag & drop in den WD Editor ziehst. Anschließend löschst Du das Video wieder im Editor Fenster und im Hilfsverzeichnis.

  • In das jetzt leere Hilfsverzeichnis kopierst Du dann alle Videos im MP4 Format, die Du später auf einer Deiner Seiten zeigen willst.
  • Alle Links oder Referenzangaben, die sich auf eine der Dateien im Hilfsverzeichnis beziehen, müssen immer auf das Verzeichnis "index_htm_files" Bezug nehmen, nicht auf das Hilfsverzeichnis, auch wenn die Dateien zu dem Zeitpunkt noch da liegen.
    Beim Export/Upload werden sie vom WD ja in das Verzeichnis "index_htm_files" kopiert.

Ein klarer Vorteil der Methode ist die deutliche Volumenreduzierung des Projekts. Jetzt kann ein Projekt, das z. B. nur 200 kB groß ist, Videodateien von 100 MB oder mehr managen, ohne dass der Besucher der Site das Megapack laden müsste.
Der Seitenbesucher sieht also blitzschnell die Seite inkl. aller Vorschau Bilder. Er wird nur dann ein paar Sekunden warten müssen, wenn ein Video nachgeladen wird.

In dem Seitenentwurf, den Du heruntergeladen hast, findest Du im HTML Body des Video Platzhalters 2 URL, die 2 Videodateien referenzieren, die nach einem Export/Upload des Projekts im Verzeichnis "index_htm_files" liegen.
Der WD hat sie aus dem Hilfsverzeichnis dahin kopiert...

Mit der Lösung solltest Du die Videos schnell online lauffähig bekommen.

Wenn Du stattdessen lieber die iframe Variante benutzten möchtest, weil Du dann die YouTube Videos direkt einbinden kannst, musst Du alle URL Einträge anpassen, in denen andere Server (außer YouTube) enthalten sind.
Werden in einem iframe fremde Server referenziert, greift die "Same-Origin-Policy". die das Einbinden des fremden Seiteninhalts verhindert.
Damit die Videos trotzdem angezeigt werden, müssen sie, wie weiter oben gesagt, auf Deinem eigenen Webspace /Webserver abgelegt werden, also am besten wieder mit der Hilfsverzeichnis Methode.
Dann müssen die zugehörigen URL Angaben wieder so aussehen, wie im o. a. Screenshot gelb markiert.

Eine URL Eintrag zu einem YouTube Video sollte dann im JScript so aussehen:

var Video3 = 'https ://www.youtube-nocookie.com/embed/Oj2mS3Dy6RU?&rel=0&modestbranding=1&autoplay=1&loop=1&playlist=Oj2mS3Dy6RU'; // Leerzeichen zw. "http" und ":" entfernen!

Die zusätzlichen Parameter "&rel=0&modestbranding=1&autoplay=1&loop=1&playlist=Oj2mS3Dy6RU" sorgen dafür, dass...

  • das eigene Video automatisch startet.
  • nicht automatisch das nächst YouTube Video abgespielt wird.
  • das untere YouTube Logo ausgeblendet wird.
  • das Video in einer Endlos Schleife wiederholt wird

Damit die YT Videos wiedergegeben werden können, muss noch der Video TAG aus dem HTML Body des Video Platzhalters gelöscht werden (im folgenden Screenshot rot markiert) und stattdessen der unten grün markierte iframe Code eingetragen werden.

Hier noch der komplette iframe Code, den Du per copy & paste übernehmen kannst:

<iframe id="Video" width="100%" height="100%" frameborder="0" scrolling="none" ><p>Your browser does not support iframes.</p></iframe>

Jetzt bist Du wieder am Zug 😊

Zuletzt geändert von BeRo am 13.02.2019, 23:24, insgesamt 4-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 14.02.2019 um 09:15 Uhr

Vielen Dank Euch. Es gibt nun Probleme mit der Verbindung mit File Zilla zum ftp Server. Die Zugangsdaten funktionieren wenn ich mich direkt bei Magix damit anmelde. Beim recherchieren bin ich darauf aufmerksam geworden, dass es entweder an der Telefonanlage oder an der Firewall liegen könnte. Hat jemand noch einen Tip?

 

BeRo schrieb am 14.02.2019 um 09:37 Uhr

[...] Hat jemand noch einen Tip?

Ja... 😊

Du hast bei den Einstellungen in FileZilla vermutlich TLS vorgegeben und das wird vom Magix Server nicht unterstützt.
Probier's mal mit den folgenden Einstellungen, dann sollte es klappen.

   

 

Viel Erfolg 👍

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 14.02.2019 um 10:10 Uhr

ich habe es genauso nochmal probiert, leider ohne Erfolg. Hatte im Internet noch gelesen, den File Zilla Client nochmal zu deinstallieren und wieder neu zu installieren. Das hat aber auch keinen Erfolg gebracht.😪

BeRo schrieb am 14.02.2019 um 10:43 Uhr

[...] Die Zugangsdaten funktionieren wenn ich mich direkt bei Magix damit anmelde. [...]

Wie machst Du das?

  • direkt mit dem Browser (Internet Explorer, Firefox, Chrom, ...)
  • direkt mit dem FTP Client des Web Designer, also mit der Funktion "veröffentlichen"?
  • Wenn die Verbindung direkt mit dem Web Designer klappt, welche Einstellungen machst Du da?

Wenn die Verbindung direkt mit dem WD klappt, kannst Du dann auch den Webspace Inhalt sehen, der Dir zur Verfügung steht?

Probier das mal...

Zuletzt geändert von BeRo am 14.02.2019, 10:57, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 14.02.2019 um 11:03 Uhr

Ich habe es direkt über den IE probiert, geht! Über den WD "veröffentlichen", es kommt ein Fenster mit dem User Namen, ich gebe das PW ein und lande dann bei Xara Online. das ist doch so i.O.???

Wenn ich das über den File Zilla Client so eingebe, wie Du mir die Optionen vorgeschlagen hast, kommt dann die Fehlermeldung, die ich geschickt habe. Ich habe gerade einen Assistent zur Firewall und Routerkonfiguration gefunden und den test gemacht. Hier das Ergebnis.

Skimausi schrieb am 14.02.2019 um 11:19 Uhr

das ist das Ergebnis.

BeRo schrieb am 14.02.2019 um 11:39 Uhr

[...] Firewall und Routerkonfiguration gefunden und den test gemacht. Hier das Ergebnis. [...]

[...] ich gebe das PW ein und lande dann bei Xara Online. das ist doch so i.O.? [...]

Dein Webspace sollte über "ftp.magix-online.com" zu finden sein, nicht bei "Xara online".
Mit dem FTP Client des WD kommst Du so dahin:

Ob die Verbindung klappt, das kannst Du vorab testen, wenn Du vor dem Klick auf "OK" den Button "Webspace durchsuchen" klickst. Dann sollte in einem Fenster der Inhalt Deines Webservers zu sehen sein.

Bleiben die Probleme bestehen, solltest Du vom Magix Support klären lassen, ob Du einen vollwertigen FTP Zugang hast.
Ich habe zwar nie mit dem Website Maker gearbeitet, ich meine aber gelesen zu haben, dass es in dem Zusammenhang Einschränkungen beim FTP gegeben hat... 😟

Vielleicht kann ja auch schon einer der mitlesenden "Helferlein" mehr dazu sagen.

Zuletzt geändert von BeRo am 14.02.2019, 11:50, insgesamt 2-mal geändert.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 14.02.2019 um 11:47 Uhr

die Fehlermeldung kommt genau dann, wenn ich "Webspace durchsuchen" klicke. Ich habe jetzt eine Support Anfrage gestellt.

BeRo schrieb am 14.02.2019 um 12:09 Uhr

[...] die Fehlermeldung kommt genau dann, wenn ich "Webspace durchsuchen" klicke. [...]

Wenn die von Dir eingegebenen Zugangsdaten korrekt sind, bedeutet die Fehlermeldung wohl, dass kein "normaler" FTP Zugang besteht.

Lies Dir dazu auch mal die Kommentare in diesem und in diesem Thread durch.

Ob Deine bestehende Domain "feuerwerk-fuchs.de" für den Zweck weiter genutzt werden kann, das kann Dir der Support sicher beantworten.

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 15.02.2019 um 08:25 Uhr

Das Ticket was ich gestern bei Magix gemacht habe, wurde gestern Nachmittag noch beantwortet! Man schrieb uns, dass die Fehlermeldung eindeutig sagt, dass Username oder PW falsch wären und wir es doch nochmal versuchen sollten......😡Nun ist heute morgen wieder eine lange Mail dorthin gegangen, es heißt warten......

Skimausi schrieb am 22.02.2019 um 19:52 Uhr

Hallo BeRo,

es hat ein wenig gedauert, bis ich weiter konnte mit unserer Seite. Wir standen mit Magix einige Tage in Kontakt, da das Problem File Zilla nicht gelöst werden konnte. Es war im Prinzip das fehlende Login bei Xara das Problem. Wir sind immer davon ausgegangen, das alles, was unter Magix gekauft wird auch irgendwie über Magix läuft. Dem ist wohl nicht so.

Ich habe nun unsere Videos im Webspace und möchte nun endlich an die Verlinkung gehen. Dazu habe ich noch eine Frage und möchte Dich um eine Erklärung bitten. Bei Deinem HTML Body Skript weichen die ersten beiden Videos vom Rest ab. Warum ist das so??

<script> // ID der aktuellen Ebene festlegen
document.write('<div id="Videos"></div>');
var layername= 'Videos';
</script>

<video id="Video" width="100%" height="100%" controls autoplay loop>
  <source  type="video/mp4" />
  Your browser does not support the video tag.
</video>

<script>  //URL der Media Datei festlegen
var Video1 = './index_htm_files/Crying_Wolf.mp4';
var Video2 = './index_htm_files/Unicorn_Impressions.mp4';
var Video3 = 'http://www.magix-website.com/mpo10/30/CF7/CF733170AB2911E592E9D5725B205A6F.mp4';
var Video4 = 'http://www.magix-website.com/mpfo10/30/80E/80EDEF3062BF11E495844CD25B205291.mp4';
var Video5 = 'http://www.magix-website.com/mpo13/30/4F2/4F2CC8B062C211E4BBA9D9955B205291.mp4';
var Video6 = 'http://www.magix-website.com/mpfo17/30/DC5/DC5DFF5062C311E498B6D0DC5B205291.mp4';
var Video7 = 'http://www.magix-website.com/mpo11/30/95D/95E22C705DAA11E69ACF34375B20618E.mp4';
var Video8 = 'http://www.magix-website.com/mpo08/30/2F8/2F8575E057DE11E586534DF85B20419B.mp4';
</script>

<script>  //Übernahme der URL für die "src=" Angabe im Video Tag
function media_open(Link) {
document.getElementById("Video") .src=Link;
}
</script>

VG Skimausi.

 

BeRo schrieb am 22.02.2019 um 20:14 Uhr

[...] Bei Deinem HTML Body Skript weichen die ersten beiden Videos vom Rest ab. Warum ist das so?? [...]

Die beiden ersten Videos sind lokal referenziert.
Das heißt, sie liegen im gleichen Speicherbereich in dem auch die HTML Seiten des Projekts liegen. Konkret liegen sie da im Verzeichnis "index_htm_files", das der WD beim Export/Upload des Projekts anlegt.
Wie weiter oben schon beschrieben, werden die Videos vom WD automatisch auf den Webserver geladen und im richtigen Verzeichnis abgelegt, wenn sie vor dem Veröffentlichen (Upload) von Dir in dem zum Projekt gehörenden Hilfsverzeichnis gespeichert wurden.

Die restlichen 6 Videos sind extern referenziert. Sie liegen also irgendwo im WWW auf einem anderen Server. Konkret sind das Deine Videos, die Du noch mit dem Website Maker erstellt hast. Sie liegen aktuell auf einem Magix Webserver (www.magix-website.com).

Für Dein Projekt bietet es sich an, die Videos lokal zu speichern, also sie über das Hilfsverzeichnis zu organisieren. Dann kommst Du ganz ohne FileZilla aus.
Alternativ kann natürlich auch die andere Variante passen, also die externe Referenz. Das kann dann sinnvoll sein, wenn Du die Videos ohnehin auf einem anderen Webserver geparkt hast, z. B. bei Vimeo oder YouTube.

Bei YouTube & Co. kannst Du aber nicht mit der Video Tag Lösung arbeiten. Stattdessen musst Du Dein Projekt dann auf die iframe Variante umstellen...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 23.02.2019 um 17:39 Uhr

Hallo BeRo, es ist vollbracht, ich kann es kaum glauben - unsere Website Vorschau sieht jetzt richtig toll aus. Vielen Dank an Dich für Deine Hilfe und Deine Motivation. Ich war schon manchmal soweit meinen Laptop zu massakrieren, damit ich mich nicht mehr mir diesem Thema befassen muss. Aber der Laptop kann ja auch nichts dafür, ich bin nun richtig froh über das Ergebnis. Wir müssen jetzt nur warten, bis Magix unsere Domäne umgezogen hat, dann können wir veröffentlichen.

Jetzt noch eine Frage zur Smartphone Seite. Kann man gleich aus der Hauptseite eine fürs Handy mit dem WD generieren?

BeRo schrieb am 23.02.2019 um 18:02 Uhr

[...] unsere Website Vorschau sieht jetzt richtig toll aus. [...]

Meinen Glückwunsch! 👏👏👏

[...] Kann man gleich aus der Hauptseite eine fürs Handy mit dem WD generieren? [...]

Man kann... 😊

Allerdings geht das nicht vollautomatisch. Du kannst zwar vom WD das Grundgerüst automatisch erstellen lassen. Die neue Site enthält dann alle Objekte der Desktop Variante, inkl. aller eventuell eingebauten Platzhalter, Scriptlets, etc. Du musst aber die Größe und die Position der einzelnen Objekte an die schmalere Breite der Smartphone Variante anpassen. Auch bei den Platzhaltern musst Du eingreifen, wenn da z. B. Scriptcode enthalten ist. Da müssen dann zumindest neue IDs vergeben werden... 😎

Wenn Du aber die Vorlage verwendet hast, die ich als Demo online gestellt habe, dann hast Du bereits eine Smartphone Variante.

Schau's Dir mal an...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 23.02.2019 um 18:55 Uhr

okay, die Seite von Dir, das habe ich schon gesehen - ich denke, das ist jetzt nicht mehr so schwierig, hoffe ich.😃

Was ich noch vergessen hatte zu fragen ist das Thema mit den Dummys. Die habe ich jetzt auf meiner Seite alle gelöscht. Fällt mir das bei der Veröffentlichung evtl. auf die Füße? Ich habe den Sinn nicht richtig verstanden.

 

BeRo schrieb am 24.02.2019 um 00:37 Uhr

[...] das Thema mit den Dummys. Die habe ich jetzt auf meiner Seite alle gelöscht [...]

Böser Fehler. 😋

Ohne die Dummy Buttons erkennt der WD die popup Ebenen nicht. Das heißt, dass die Links, die bisher die popup Ebenen geöffnet haben, ins Leere gehen. Damit funktioniert also kein Video mehr. 😭

Der WD erkennt eine popup Ebene immer dann automatisch, wenn Du einen "normalen" Link darauf setzt.
In Deinem Fall wird die popup Ebene aber durch ein JScript indirekt verlinkt, weshalb der WD sie nicht "sieht".

Erstell' die Dummy Buttons also wieder und alles ist gut...

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.

Skimausi schrieb am 24.02.2019 um 10:00 Uhr

können die Dummys auch neben der Seite stehen??

BeRo schrieb am 24.02.2019 um 10:09 Uhr

[...] können die Dummys auch neben der Seite stehen?? [...]

Genau da gehören sie hin, also außerhalb der Seitengrenzen. 👍

Ein Klick auf den "Danke" Button (hier rechts), wäre nett. Perfekt wäre ein zusätzliches Posting mit Deiner Erfahrung zu dem/den erhaltenen Tipp(s).
Alle Forenbesucher , die mit vergleichbaren Problemen ihrer Anwendung zu kämpfen haben  und die ebenfalls auf der Suche nach einer Lösung sind, können dann besser entscheiden, ob die angebotene Lösung für das eigene Problem verwertbar ist.
Klar, dass auch der Tippgeber sich freut, wenn seine Hilfestellung mit einem Feedback belohnt wird und nicht kommentarlos ins Leere geht.