Chroma Key effect does not render in final exported file (?)

marksanche wrote on 4/13/2019, 6:04 PM

Magix Movie Edit Pro Premium (bought April 2018)

I used the CHROMA KEY to produce an effect, using MIX, and then I tried HIDE BLACK, then back to MIX. With MIX this appears on the monitor exactly how I want it to look (using MIX selection). But when I go to finish the project to export, my foreground video image does not appear in the rendered exported file. Why is this? I followed the video tutorials on Chroma Key, the step-by-step instructions. I put the background video on track 1, and the foreground video on track 2. Since the foreground video was black (complete darkness, and the video was put through b/w high contrast beforehand, so it was black) except the lit objects in the center area, I first selected HIDE BLACK. But this did not hide the black. And when rendered, the foreground video wasn't there, or not on top anyway. So I then tried the MIX selection, and my background/foreground appears on the editing monitor exactly the way I wanted it to look. But after rendering, once again, the foreground image was not there, or at least not on top or appearing in the video as it was on the monitor during editing.

What is wrong with my procedure? Is there something I'm overlooking?

Can anyone help with this issue or know what is wrong? SEE ATTACHED SCREENSHOTS x2

It would be much appreciated :)

Thank You,

Mark Sanche

In the monitor is exactly the way I want it to look.

But this is the rendered exported result. My main foreground image is not there as you can see.

Comments

johnebaker wrote on 4/13/2019, 6:34 PM

@marksanche

Hi

. . . I used the CHROMA KEY to produce an effect, using MIX, and then I tried HIDE BLACK, then back to MIX. With MIX this appears on the monitor exactly how I want it to look (using MIX selection) . . .

AFAICS for what you are trying to do the Chromakey, Mix option is not the correct one.

The correct chromakey effect to use is Stamp, Black applied to the video on track 2 - this will make the black areas transparent so the background on track 1 shows through and maintains the correct colours as shown below

Mix blends the two videos together based on their brightness. Brighter areas combine and quickly appear white; darker areas have less of an effect on the result - ie the dark background is overpowering the white portions.

The image below is the same clips as above with the Mix effect applied

as you can see there is a very significant difference especially in the colours.

Note: in order to show the difference how Stamp and Mix work, I had to use Stamp Blue to remove the blue sky behind the bird on the tree.

Alternatively, as your video the effect is being applied to is almost black/white you could use use Chromakey Alpha, however you then have to make sure the direction arrow, that appears when you hover the mouse near the start of the clip, points in the correct direction - in this case upwards.

HTH

John EB

 

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

marksanche wrote on 4/13/2019, 8:36 PM

Thank you very much, John!

After I made the change to STAMP-BLACK, the project did render and export with the foreground there...

But, it did look a bit too much like a cookie cutout on top of the background, compared to when I had used MIX with the editing monitor showing the foreground image blending in with the background image, almost looking as if the foreground was in the background. I guess that was the effect of the MIX. I liked that look, but as we know, it will not render the way I see that on the editing monitor due to, like you were saying, the dark background is overpowering the white portions. Is there a way to adjust that? Or a way to render it having used MIX and have the exported render as I saw it on the editing monitor?

I did try STAMP-ALFA unsuccessfully, as the foreground appeared either as a black box (size of foreground video 4:3. Background 16:9) or no black box on top of the background video. And no white portions, even if I'd adjust the two levels there. Also, the arrow at the beginning of the clip was pointing 'down'. Is there a way to make it point 'UP'? Or is that something that is 'set'?

Thanks again for your help, John.

Mark

Last changed by marksanche on 4/13/2019, 8:50 PM, changed a total of 1 times.

Dell XPS 8500 Special Edition,Intel (R) Core (TM), i7 3770 CPU @ 3.40 GHz 3.40 GHz, Installed Memory 16 GB (RAM), 64-bit operating system x64-based processor

johnebaker wrote on 4/14/2019, 6:13 AM

@marksanche

Hi

. . . . it did look a bit too much like a cookie cutout on top of the background . . .

Try this method to get the effect you want.

. . . . STAMP-ALFA unsuccessfully . . . . the arrow at the beginning of the clip was pointing 'down'. Is there a way to make it point 'UP' . . .

Yes - click the arrow.

HTH

John EB

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

marksanche wrote on 4/15/2019, 9:47 AM

Hi John,

I tried the method you gave a link to in the above message, using the MASK GENERATOR and then STAMP-ALFA.

At first, I used the mask with my foreground video and moved the background video to track 4. But this gave me the cookie-cutter look again. So I tried adjusting levels and didn't get what I was looking for. So I then switched up (reversing background/foreground videos) deciding to try to mask the background image I had moved to track 4, moving that back up to track 2 and copy to track 1. Then moved my foreground video to track 4, to use as background video. This appeared to work, at least in the editing monitor. But when I rendered and exported it, the background track 4 didn't appear in the video. (I tried to render/export about 6+ tries, adjusting each time)

See Screenshot (this is the current state of tracks/effects)

What do I need to do to get the background image to also appear in the final rendered export, as I see it in the editing monitor? (similar problem as I had using MIX)

I'm sure it's just a matter of a few tweaks/adjustments, but I'm not sure now. I did adjust the levels so it appeared as you see it on the editing monitor, but it wouldn't render that way, as mentioned above.

Any further suggestions?

Thanks again, John!

johnebaker wrote on 4/15/2019, 2:16 PM

@marksanche

Hi

If the video clips are not confidential, can you upload a short section ~ 10 secs of the Zoom ------ movie clip you are trying to use for the foreground to somewhere like Dropbox and post a link to it for testing.

Do not upload to the forum, Youtube, Vimeo etc as they will convert the video, a section of original is needed.

Thanks

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

marksanche wrote on 4/16/2019, 10:32 AM

Hi John,

Here is a 12 sec clip of the Zoom Video. That first part in my timeline. Though this was split with a video splitter, I am not exactly sure if it was altered in any way in the process. I selected 'Direct Stream Cut- No re-encoding mode: https://www.dropbox.com/s/a45s2pbqwqkx7kp/ZOOM0012%2800h00m00s-00h00m12s%29%20via%20BoilSoft%20Video%20Splitter%20NO%20RECODING.m4v?dl=0

And I'll also include the Original Zoom File in full length just in case you prefer that, but may disable sharing once I know you have it or don't need it: https://www.dropbox.com/s/dj7o3x51qqkpkad/ZOOM0012.MOV?dl=0

I had also put this video through stablization, film look- b/w high contrast, while editing. I'm not sure if this is affecting the mask generator and chroma key.

Thanks John,

Mark

johnebaker wrote on 4/16/2019, 11:14 AM

@marksanche

Hi

Thanks for the clips

Is this what you are looking for:

If so then the settings in order are

Note:

  • you may have to slightly adjust all the settings to get the best effect with your background video.
  • against light backgrounds it is very difficult to avoid some border/edge effect around the chromakey video.

Added: for lighter backgrounds use the above settings and then apply the Mask Generator adjusting the High in value to 0.62, Low in, Low out and High out are left at the default values.

HTH

John EB

Last changed by johnebaker on 4/16/2019, 11:26 AM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP Pro Premium, Video Pro X4, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.