How do I get my money back?

Fred-Godsmark wrote on 2/4/2021, 10:47 PM

I bought the upgrade to Samplitude to ProX5 Suite. It included SpectraLayers 7 and iZotope Ozone. There was not registration or coded to be able activate either one. I can't reach anyone at Magix ... it is like they are hiding. Steinberg was nice enough to supply me with a code directly. iZotope will not, they say there are issues. There is no contact information here, or it is hidden so deep. I bought the software at Sweetwater and I am emailing for a refund. This is ridiculous. The software is great and I have been using it since Version 7 but every time I upgrade or change I go through this crap. These people do not seem to care. It's time to look at new software .. a company with people that work there. Sorry for the rant but this is pathetic yet again.

Comments

SP. wrote on 2/5/2021, 2:19 AM

@Fred-Godsmark Here are only users and we can't do anything here to help you. This seems to be a problem in communication between Sweetwater and Magix. Why didn't you buy it directly from Magix? This problems would likely never happened then.

browj2 wrote on 2/5/2021, 7:22 AM

@Fred-Godsmark

Hi,

So, you bought the package from Sweetwater, they didn't give you the activation codes for all products, and that is somehow the fault of Magix. Talk to Sweetwater if you want a refund - you gave them the money, not Magix.

I presume that you received an email from Sweetwater. Did you scroll down the email to see if the activation codes were there? This is a common error.

You say that you can't reach anyone at Magix even though you can click on Support at the top of this forum, select (under more programs) Samplitude, look at and read what is on the screen, follow through the questions, keep going to Ask Support, indicate the category and program and subject, check that the problem has not already been resolved, and then fill in the form - the category, software and title will already have been indicated by you on your way to the form.

If you have problems understanding the above, there is even a tutorial on how to contact support. on the support pages.

Or, you can contact Magix directly about this at proservice@magix.net.

John CB

John C.B.

VideoPro X(14); Movie Studio 2023 Platinum; MM2023 with MM2022 Premium Edition; see About me for more.

Desktop System - Windows 10 Pro 21H1; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

Fred-Godsmark wrote on 2/5/2021, 10:00 AM

@browj2

Thanks for taking the time to reply. My post sounds a bit out of hand and I apologize for this. Being locked up for almost a year is not helping, but that is no excuse for my rant.

My frustration came from multiple things .. I do not blame Magix for not having the code but I do however for not receiving an answer to my support emails and that has been a problem over the years. There has been some sort of issue and apparently Sweetwater is not getting a response or any support in this. I emailed Magix myself as I have been using their software for so long .. and I do love it. It is just now 2 months since this started. I thought I would try support off the website and whenever I clicked support, it directed me to this forum and did not supply any other contact. I spent over half hour trying to get to help (call me stupid if I can't find it, it should not be that hard, honestly) the last time it took me back to this forum I posted out of utter frustration.

Unlike others you chastised me but also took the time to point out a route or solution.

I am going to keep trying. Again, Sorry for the outburst and thank you so much for the help.

 

browj2 wrote on 2/5/2021, 1:51 PM

@Fred-Godsmark

Hi Fred,

I'm not a moderator so I take a little more liberty with my comments. Users complaining about no support from Magix or no way to contact Magix is becoming a pet peeve of mine.

There is a dedicated Samplitude/Sequoia forum here. You should join, or at least try to. Several people have complained about not having not successfully negotiated the captcha test. There is a wealth of information there, very experienced users, and the occasional visit from someone from Magix.

You should not have had to be waiting two months to get this sorted out. If you had been on the Samplitude forum, it's quite likely that someone from Magix would have intervened. However, Sweetwater should have been even more successful than you, them being the reseller. The best method for dealing with Magix has always been to raise a ticket. You get an automated email reply with a ticket number and you can reply to it with more info - and keep chasing after Magix using that ticket number and email reply.

To be clear about iZotope Ozone, from what I see it is Ozone 9 Elements and not Standard or Advanced. You also get RX7 Elements; did you get this at least?

Did you download and install everything under Help, Download Instruments and Sounds (or something like that)? Is Ozone Elements on that list?

Did you successfully install Independence and the 70GB of instruments?

John CB

John C.B.

VideoPro X(14); Movie Studio 2023 Platinum; MM2023 with MM2022 Premium Edition; see About me for more.

Desktop System - Windows 10 Pro 21H1; MB ROG STRIX B560-A Gaming WiFi; Graphics Card Zotac Gaming NVIDIA GeForce RTX-3060, PS; Power supply EVGA 750W; Intel Core i7-10700K @ 3.80GHz (UHD Graphics 630); RAM 32 GB; OS on Kingston SSD 1TB; secondary WD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB, 8TB; three monitors - HP 25" main, LG 4K 27" second, HP 27" third; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer.

Notebook - Microsoft Surface Pro 4, i5-6300U, 8 GB RAM, 256 SSD, W10 Pro 20H2.

YouTube Channel: @JCBrownVideos

Fred-Godsmark wrote on 12/5/2022, 2:07 PM

Hi, I am sorry that I have not properly thanked you for your help ... a RL disaster has kept me away. I appreciate what you have said. I do think it might be easier but if this works here from all of you I am perfectly happy to do this. Now that I am back what I have done is purchased Pro X Suite 7 and done all of the upgrades. All works beautifully except for a slight integration problem .. which I posted here :)

Thanks again.