Is there NO customer support for Magix???

Robin-Bittman wrote on 6/23/2019, 6:21 PM

I bought SF Pro MAC 3. I have had the PC version forever and never needed customer support, now I bought it for MAC and the program crashes constantly. I have tried every which way to contact support and send them my crash descriptions so they can advise me. There is no working phone # or email offered. This is a joke! I threw out $300!!

Comments

emmrecs wrote on 6/24/2019, 3:29 AM

@Robin-Bittman

Welcome to the Magix forums. I'm sorry that SF Mac is proving so problematic for you but you can contact Magix Support by clicking the "Contact" button in the footer of every forum page.

This forum is for user to user interaction so I doubt whether anyone here can help you directly.

HTH

Jeff
Forum Moderator

EDIT: to add; I see you have posted essentially the same question in three other threads. Please do not do this or you may be considered to be spamming the forums. I have hidden your similar posts.

Last changed by emmrecs on 6/24/2019, 3:34 AM, changed a total of 1 times.

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

Robin-Bittman wrote on 6/24/2019, 4:51 PM

Thanks Jeff, I get it. However nothing on that Contact page actually works. The phone number doesn't answer, the webpage to contact support shows up as Error...so my point in contacting other users is to find out what other folks have done. Right now it seems I threw out $300. I have used SF for windows forever and did not expect this to happen. After reading through the forum, it seems I am not alone. This program crashes all the time and others can't find a way to contact customer service as well. t seems some have had success and it leaves the rest of us scratching our heads. If this is not applicable to the forum, it makes no sense. I would like o use the software and discuss but right now, I have to figure out how to get the software up and stable.

emmrecs wrote on 6/25/2019, 3:54 AM

@Robin-Bittman

Thanks for the updated information.

It is very concerning if that Contact link is not working for you. It actually leads to https://support2.magix.com/customer/index.php, which, if you click through should take you to a page where you enter your registered email address and password. On the right side of the page are various different options for which department you wish to contact, one of which is Technical Support. Do you not see these? If not, can you post a screenshot of what you actually do see and I will raise the matter with the forum admin, who is a Magix staff member.

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

Robin-Bittman wrote on 7/8/2019, 9:37 PM

When I go here I get an error page: https://support2.magix.com/customer/index.php

emmrecs wrote on 7/9/2019, 4:27 AM

@Robin-Bittman

I think the web site must have been temporarily down when you attempted to access it. I've just clicked through the link in your post and it went to this page (part shown below) with the access to log in.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

Robin-Bittman wrote on 7/9/2019, 6:25 PM

I have tried it again today at different times of the day...as on so many other days before, it never works. I am in the US, is that where you are? Not sure why you can reach it and I can't and so many others can't. Really odd. Thanks for trying.

emmrecs wrote on 7/10/2019, 3:51 AM

@Robin-Bittman

I'm in the UK but I don't think that should affect the availability of the web link.

However, I will alert Magix staff to your problem.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

ralftaro wrote on 7/11/2019, 2:42 AM

Hi Robin,

Jeff pointed me to this thread. Sorry to hear about the problems you're having with the product and the website. I appreciate your frustration. However, I'm not aware of this being any kind of common or temporary website problem among users in the US (or anywhere, for that matter). You might want to try emptying your browser cache and/or using a different web browser and give it another shot. I can only guess that this may be due to some corrupted cached data or some browser plug-in going delinquent on you. One way or another, I also manually created a support ticket for you, and passed it on to our SOUND FORGE product specialist. He'll be in touch to see what he can do for you regarding the original problem.

Cheers!

 

Robin-Bittman wrote on 7/11/2019, 12:12 PM

Thanks for contacting me and creating the ticket for me. I will experiment with everything you said, however I did already try another browser and another computer without any positive effect. If you look through some of the Forum pages in reference to SFPM where people are having issues...90% of the folks couldn't reach customer support through the website. I also tried to use this tel # listed in Nevada, US I assume +1 775 562 0528 Mon – Fri, 1pm - 5pm EST for Pro-Audio Support and it is a non-working #.