On-screen keyboard problem

Telroshan wrote on 11/25/2017, 9:07 AM

Hello, I'm having a problem with the on-screen keyboard on Magix Music Maker ; it seems zoomed in, and I can't click properly on the differents items. The rest of the interface doesn't have any problem though, it's just the keyboard.

Whenever I click in the keyboard interface, it seems the click event is detected with a position gap.

I'd like to mention that I checked this thread out before posting here, but resizing didn't solve my problem.

Here's a screen of my interface :

And a video showing the position gap I'm talking about, hoping it helps :

If that can help you, my software version is the 24.1.6.127, and I'm running it on Windows 10.

I tried to uninstall / reinstall, but that didn't solve it.

Thank you in advance for your help !

Comments

johnebaker wrote on 11/25/2017, 9:38 AM

Hi

Welcome to the forum.

Before posting please search the forum for the issue you are having you may find the issue you are having has already been discussed and resolved - see this topic .

Also please read this topic - there are guidance lines to what information is required.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Telroshan wrote on 11/25/2017, 10:02 AM

Thanks for your answer.

As I said though, I already checked the thread you linked, and it didn't help me solve my problem.

Here's a video I just recorded, where I try the solution you mentioned in this thread :

Sorry if I missed something, but nothing changed when resizing the keyboard.

johnebaker wrote on 11/25/2017, 11:03 AM

Hi

Thanks for the video clip that helps.

The problem looks like there is insufficient space on your screen area to accommodate the full width keyboard - this could be due to the monitor resolution being set low or is physically lower than that need for MMM. I am using 1920 x 1080 resolution monitors from which my videos were recorded.

An option if your screen resolution is lower, is to minimise the right pane using the button directly below the close program X, top right of the screen.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Telroshan wrote on 11/25/2017, 11:23 AM

Thanks again for your answer.

My monitor's resolution is 1920 x 1080.

Minimising the right pane unfortunately didn't solve it ; I guess it lessened the gap a little bit, but it's still here.

Actually, I wasn't having this problem until a few days ago, when it suddenly became like that when I started the software, and I can't recall anything that could have caused it 😕

johnebaker wrote on 11/25/2017, 3:08 PM

Hi

Assuming other programs are displaying normally when full screen, I suspect that you have accidentally hit the Tab key which is the Zoom Soundpool and Keyboard shortcut - press the Tab key once should return to normal.

The timeline track heights look too big as well - did you zoom these? If not try reducing their height using the + and - zoom keys just below the vertical slider at the right side of the timeline pane.

HTH

John EB

 

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Telroshan wrote on 11/25/2017, 3:40 PM

Hi, thanks again for taking time to help me.

Pressing the Tab key fixed the height of the timeline track (thanks for that !).

The keyboard is still the same though 😕 (the first time I pressed tab actually zoomed it even more)

johnebaker wrote on 11/26/2017, 4:26 AM

Hi

This looks like there have been multiple 'issues' - try pressing F4 to reset the window layout of MMM.

HTH

John EB

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

Telroshan wrote on 11/26/2017, 6:27 AM

Hi

Pressing F4 didn't change anything 😕 (it "refreshed" the layout but the interface remains the same)

ralftaro wrote on 11/27/2017, 4:49 AM

Hi Telroshan,

This is most likely another problem that falls into the category of compatibility issues between the graphics engine currently used in Music Maker and certain graphics chipsets/drivers. This also only started popping up in the past few weeks, possibly triggered by a recent Windows (10) update (or graphics driver update). Your easiest way out is probably the operation of Music Maker in a more compatible graphics rendering mode. You can accomplish this configuration by downloading and running the following fix:

https://support2.magix.com/customer/en/download_do/294659

 

I hope this helps!

 

Telroshan wrote on 11/27/2017, 11:34 AM

The fixer solved it !

Thanks a lot to both of you for your help ! 😃

johnebaker wrote on 11/27/2017, 12:29 PM

Hi

@Telroshan

Pleased to know you are now sorted.

@ralftaro

Thank you for letting us know there is an issue with some hardware combinations and/or possible Windows 10 updates.

Windows 10 updates have indeed caused many issues, and not just with Magix products, but others as well.

Best wishes

John EB

Last changed by johnebaker on 11/27/2017, 12:29 PM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

fsb wrote on 12/4/2017, 7:27 PM

@ralftaro

 

Many thanks for the fix - that had me worried :)

dark_spartan wrote on 12/22/2017, 11:59 AM

Hi Telroshan,

This is most likely another problem that falls into the category of compatibility issues between the graphics engine currently used in Music Maker and certain graphics chipsets/drivers. This also only started popping up in the past few weeks, possibly triggered by a recent Windows (10) update (or graphics driver update). Your easiest way out is probably the operation of Music Maker in a more compatible graphics rendering mode. You can accomplish this configuration by downloading and running the following fix:

https://support2.magix.com/customer/en/download_do/294659

 

I hope this helps!

 


Windows is detecting this as a threat and wont let me apply it. Is there an easier (registry/config) method to make this change?

tylor wrote on 12/23/2017, 7:07 PM

Yeah when I downloaded that link and scanned it windows defender said there was a trogan attached to the download. Any other solutions?

johnebaker wrote on 12/24/2017, 5:01 AM

@tylor

. . . .windows defender said there was a trogan attached to the download . . . .

Windows Defender has a reputation for giving false positives for Trojans, particularly when using the Heuristics engine, my AV and Malwarebytes report the file as being clean.

What was the specific 'trojan' that was identified by Defender?

John EB

 

Last changed by johnebaker on 12/24/2017, 5:01 AM, changed a total of 1 times.

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

dark_spartan wrote on 12/24/2017, 12:02 PM

@tylor

. . . .windows defender said there was a trogan attached to the download . . . .

Windows Defender has a reputation for giving false positives for Trojans, particularly when using the Heuristics engine, my AV and Malwarebytes report the file as being clean.

What was the specific 'trojan' that was identified by Defender?

John EB

False positive or not, it won't let Windows user using Windows Defender (which I'd guess is probably 95% of users) run the application - there is no option to exclude or bypass.

That said, you've had a different experience than I have. I haven't had a false positive with Windows Defender yet and had plenty with Malwarebytes.

Either way, is there a solution that doesn't involve running this executable? Is it changing a setting, swapping a DLL? It was posted by the team so nonchalantly I'm hoping it is a trivial modification.

johnebaker wrote on 12/24/2017, 5:27 PM

Hi

. . . . run the application - there is no option to exclude or bypass . . . . is there a solution that doesn't involve running this executable

You have a Catch 22 situation - turn off Windows Defender while you run the fix, if you do not want to do that then you cannot run the fix.

John EB

 

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

AtomToast wrote on 12/26/2017, 11:39 AM

When executing the exe and the Windows Defender popup appears, you can simply click "more information" and a button to execute it anyways should appear.

At least that's how I always do it(W10)

Accelr8r wrote on 12/26/2017, 9:41 PM

Hi Telroshan,

This is most likely another problem that falls into the category of compatibility issues between the graphics engine currently used in Music Maker and certain graphics chipsets/drivers. This also only started popping up in the past few weeks, possibly triggered by a recent Windows (10) update (or graphics driver update). Your easiest way out is probably the operation of Music Maker in a more compatible graphics rendering mode. You can accomplish this configuration by downloading and running the following fix:

https://support2.magix.com/customer/en/download_do/294659

 

I hope this helps!

 

When executing the exe and the Windows Defender popup appears, you can simply click "more information" and a button to execute it anyways should appear.

At least that's how I always do it(W10)

Worked for me, thanks!

dark_spartan wrote on 12/29/2017, 11:53 AM
You have a Catch 22 situation - turn off Windows Defender while you run the fix, if you do not want to do that then you cannot run the fix.

John EB

 

I am aware of that - that is why I chose option #2 and am asking for an alternative fix from the developer of the application :)

Well, I went ahead and installed the "patch" and now Music Maker is all messed up. When I launch it, half the interface jumps to 2x the height and goes off screen, while the other half stays usable. F4 seems to fix the issue temporarily ... too bad this was an executable patch, because now the only way to undo this is a reinstall.

I'm also worried because this EXE patched my "Samplitude" which I had no issues with, and I'm wondering what it broke there as well now.

jasenpai wrote on 1/2/2018, 3:21 PM

Hi, I have been having this exact same issue, but when i open the patcher it says it is expired (see image): http://puu.sh/ySTXK/d99b829421.png

What now?
 

DZNRandom wrote on 1/4/2018, 7:58 AM

Hi, I have been having this exact same issue, but when i open the patcher it says it is expired (see image): http://puu.sh/ySTXK/d99b829421.png

What now?
 

I have the same Problem... I think the patch is just for 2017 Version not for 2018...

ralftaro wrote on 1/4/2018, 9:42 AM

Hi, I have been having this exact same issue, but when i open the patcher it says it is expired (see image): http://puu.sh/ySTXK/d99b829421.png

What now?
 

I have the same Problem... I think the patch is just for 2017 Version not for 2018...

 

Please try again now, from the same link posted above. The fix has been updated. If you still get the old version (with the expiration message) this might be due to a caching mechanism in your web browser, since neither the URL nor the file name for the fix has changed. It might help if you explicitly save the patch to a different location, rather than opening it directly from the URL, or if you clear out the cache of your browser first.

I hope this helps!

 

hazencruz wrote on 1/8/2018, 5:40 PM

I registered just to ***** thank you guys for that fix. I was really pulling my hair out after swapping to my new Nvidia card.