On-screen keyboard problem

Comments

Shobu wrote on 2/16/2018, 7:53 AM

Hi,

here is an interesting thread (in german):

https://www.magix.info/de/forum/keyboard-auflsung-zu-gross--1200778/#ca1376789

 

Shobu

johnebaker wrote on 2/16/2018, 11:34 AM

Hi

Fixing MMM keyboard size issue.

This is a translation of German post by @Shobu linked to above, with added additional comments.

  1. Find the install.cfg for the Music Maker, this is located in the program installation directory, if the default installation directory was used during installation then this is

    c:\Program Files (x86)\Magix\Music Maker version

    in a subfolder called 2017 or 25, depending on the version of MMM open it with Notepad
  2. In the section [qml] - locate the line QT_OPENGL =dynamic.
     
  3. Change the value dynamic to angle
     
  4. Save the file and start Music Maker, the keyboard should now appeared correctly again.
     

Note: the QT_OPENGL = can be set to one of four different values ie "dynamic", "angle", "desktop" (this forces OpenGL), or "software"

If the keyboard is still not displayed correctly, close Music Maker and repeat steps 1 to 4 changing the setting option to software.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

dark_spartan wrote on 2/25/2018, 12:25 PM

Hi,

here is an interesting thread (in german):

https://www.magix.info/de/forum/keyboard-auflsung-zu-gross--1200778/#ca1376789

 

Shobu


Finally the answer I needed, thanks :) 1 problem down, 49 more to go.

Fabibassi wrote on 3/7/2018, 10:59 AM

fixed it for me aswell. Thx! (btw gtx 1080 if this helps)

RendCycle wrote on 3/20/2018, 11:36 AM

Doesn't work for the 2017 Premium Steam Edition version 24.1.5.115 (UDST).

ralftaro wrote on 3/21/2018, 10:56 AM

Hi there,

I have updated the fix to now also look for the registry key of the MM 2017 Steam Edition. So, it should now apply to that as well. Please note that you might be getting the older version from the original download link again, due to the caching mechanism of the browser. Try emptying the cache and/or saving the download specifically to a different location on your computer. Alternatively, try downloading from the following link, to bypass any potential caching problems:

https://support2.magix.com/customer/en/rdl/VW9C6X

Hope this helps!

 

fury wrote on 4/25/2018, 9:57 PM

Thanks for the fix. Should be fixed in the latest version IMO instead of having us discover this thread and apply a patch.

ralftaro wrote on 4/27/2018, 3:47 AM

Hi Fury,

I appreciate the sentiment. Unfortunately, it's not quite that easy. This is not a program bug per se. The problem is caused by your graphics hardware/driver not fully meeting the requirements of Qt, the software development framework Music Maker is now using for big parts of its graphical user interface. (For some users, this problem was triggered by a specific Windows update messing with perfectly fine drivers they had already installed.) The fix is essentially a workaround solution that results in the use of an alternative Qt rendering mode, which is more compatible, but potentially delivers inferior graphics/program performance. The latter aspect is the reason why MAGIX development is currently reluctant to always run the software in this rendering mode by default. (In practical terms, I haven't heard any complaints from any Music Maker users about complete program performance breakdowns after applying the fix.) There may or may not be a better way to deal with this kind of problem on the end of the application in the future, but, for the time being, this workaround solution will have to do. (For some users, a graphics driver update or better graphics hardware will fix the problem.)

Thanks for your understanding!

cougrrr wrote on 4/30/2018, 12:41 AM

Hi there,

I have updated the fix to now also look for the registry key of the MM 2017 Steam Edition. So, it should now apply to that as well. Please note that you might be getting the older version from the original download link again, due to the caching mechanism of the browser. Try emptying the cache and/or saving the download specifically to a different location on your computer. Alternatively, try downloading from the following link, to bypass any potential caching problems:

https://support2.magix.com/customer/en/rdl/VW9C6X

Hope this helps!

 

Having the same issue (GTX 1080 also) but when I try to hit this link up it gives me a 404 (Sorry This Page doesn't exist).

As it is the keyboard is completely unusable, the older patches from this thread and a few others had no effect. One got flagged by Norton, which I then allowed, and then Windows said that that file wasn't able to run on this computer.

ralftaro wrote on 4/30/2018, 5:49 AM

Hi there,

I have updated the fix to now also look for the registry key of the MM 2017 Steam Edition. So, it should now apply to that as well. Please note that you might be getting the older version from the original download link again, due to the caching mechanism of the browser. Try emptying the cache and/or saving the download specifically to a different location on your computer. Alternatively, try downloading from the following link, to bypass any potential caching problems:

https://support2.magix.com/customer/en/rdl/VW9C6X

Hope this helps!

 

Having the same issue (GTX 1080 also) but when I try to hit this link up it gives me a 404 (Sorry This Page doesn't exist).

As it is the keyboard is completely unusable, the older patches from this thread and a few others had no effect. One got flagged by Norton, which I then allowed, and then Windows said that that file wasn't able to run on this computer.

Oops, sorry. That was just a temporary link, specifically created for the people that were apparently having problems with the caching of the outdated fix under the original link. Please try again with this link:

https://support2.magix.com/customer/en/download_do/294659

If this is the one that was causing you problems with the security software, you may also need to reconfigure Windows "SmartScreen" accordingly.

https://www.howtogeek.com/75356/how-to-turn-off-or-disable-the-smartscreen-filter-in-windows-8/

https://www.technobezz.com/how-to-change-the-smartscreen-filter-settings-in-windows-10/

jakobjoergensen wrote on 10/5/2018, 3:11 PM

Hi Telroshan,

This is most likely another problem that falls into the category of compatibility issues between the graphics engine currently used in Music Maker and certain graphics chipsets/drivers. This also only started popping up in the past few weeks, possibly triggered by a recent Windows (10) update (or graphics driver update). Your easiest way out is probably the operation of Music Maker in a more compatible graphics rendering mode. You can accomplish this configuration by downloading and running the following fix:

https://support2.magix.com/customer/en/download_do/294659

 

I hope this helps!

 

Not even Magix support can fix this.

Thanks Telroshan