SP. wrote on 5/16/2024, 7:31 PM

@Gary-Burton3184 Maybe your firewall is blocking the connection? Try to disable Windows Defender temporarily or try to run Sound Forge as administrator by right clicking on the program icon.

Is TLS encryption enabled on your system?

Gary-Burton3184 wrote on 6/2/2024, 4:52 PM

Yes, it was an 3rd party firewall that I uninstalled, but the thing kept working in the background.