Comments

browj2 wrote on 11/23/2016, 11:07 PM

Hi Hector,

I don't have 2017, only 2016 and VPX8 (should be the same engine) so I probably can't help much. Try posting screen shots of the offending title and the title parameters and maybe someone can spot something.

Did you use a normal title, that is, one that you made by clicking on the Title button? Does this happen in a new project as well?

Last changed by browj2 on 11/23/2016, 11:07 PM, changed a total of 1 times.

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

dkw wrote on 1/12/2017, 2:41 PM

Hi,

I've the same problem (black background in Title object), in Movie Edit Pro Premium 16.0.2.56 (UDP3).

This effect is in normal title (Title button) and with title template - also in a new project.

The black rectangular is also when "radio button" in option of Title object is set to "white background".

I can change many text (font) attribute, (color, border color and width, shadow with color, blur and transparency etc) but black rectangle is all the time.

Please help

Best Regard

Darek

terrypin wrote on 1/14/2017, 12:41 PM

Hi,

I'm using MEP 2017 Premium Version 16.0.2.56 (UDP3), the latest update. The newly-placed title initially appears with a black background, as shown. But as soon as I confirm it (by clicking the checkmark or in an empty part of the timeline) it is displayed normally.

I also tried MEP 2014 Premium which gave the same behaviour. And also in MEP 2016 Premium.

You might try experimenting with the settings under the Display tab of Program settings. I vaguely recall some odd effects when using the standard HW accel option years ago.

Terry

 

hector2 wrote on 1/14/2017, 12:49 PM

I tried everything to get rid of that! Finally just reset program to factory settings and it worked

terrypin wrote on 1/14/2017, 1:18 PM

Pleased to hear it.

But a reset would have been one of the first things I'd have tried!

hector2 wrote on 1/14/2017, 4:54 PM

Pleased to hear it.

But a reset would have been one of the first things I'd have tried!

😐 yeah well new to the program.

dkw wrote on 1/15/2017, 4:55 AM

Hi,

But a reset would have been one of the first things I'd have tried!

After using "File>Settings>Reset program settings to default" - I've no change, BUT

after changing setting from:

"File>Settings>"Program>Display options>Preview in arranger>Video mode>Standard mode (Direct3D, hardware acceleration)"

to:

"File>Settings>"Program>Display options>Preview in arranger>Video mode>Compatibility mode (VideoForWindow)"

It's OK

Maybe, this is problem with configuration in my NVIDIA GeForce 9600 GT?

Thanks You very much

terrypin wrote on 1/15/2017, 5:33 AM

@dkw

Glad to hear you fixed it. That's the same work-around I recall from a few years ago, although it wasn't for titles. Can't remember if I found the ultimate cause. And it was on my old PC under XP, but interestingly with NVIDIA GeForce 9600 GT.

 

 

artyone01 wrote on 1/9/2018, 9:14 AM

Thanks terrypin. I experienced the same titles problem with latest Edit Pro Premium (2018), followed your advice on changing the Video mode setting. Problem now appears to be corrected. System using Nvidi GeForce 8400 GS display..

john-m33 wrote on 5/12/2018, 5:46 AM

I'm having a caption background problem (e.g. with Neutral 12 caption) when exporting a movie. The purple background changes to black during the export, and then disappears completly. It usually about 25 mins into a 34 min movie but happens at different points each time, so random. One its gone wrong (during the export), the background when wont preview or display in the monitor until I restart Magix.  I’ve tried resetting Magix, rebooting, checking PC and drive for errors, using a new copy of the project, using VideoForWindow, different GPU and video formats, so now asking for help!

The 5-track movie consists of about 300 photo and video clips with lots of subtitles and background music (captions), smaller than many of my movies but perhaps more captions this time.  I gone back and looked at another movie from last year and have just realised that also lost the purple caption background 28 mins into the 30 min movie, so I think it must be some kind of a bug and not a new fault.

I have a hi-spec PC with Win10 64-bit, i7 4GHz processor, 16GB DDR4, 512GB NVMe system disc (with 340GB free), and MEP 2016 Plus.  Any suggestions?

terrypin wrote on 5/12/2018, 7:28 AM

Hi,

I’m not sure I fully understand your problem description. I interpret it that you suspect a bug in the caption ‘Neutral 12’. A strange bug, that only arises some 25-28 minutes when playing the video after export (to an unspecified format and with unspecified settings). Is that right?

If so, have you simplified the project to a single image in track 1 and the caption in tracks 3 and 4, with both given a duration of 35 mins? I did that in MEPP 2016, exported to MP4, 1920 x 1080, 25 FPS, and found no change at any point in the background colour of the caption. (BTW, the colour here is not purple, but blue/turquoise.)

Or are you reporting this as odd behaviour in the project overall, not necessarily related to the caption? If so, presumably there’s no problem in any other track at that point near the end of the project?

john-m33 wrote on 5/13/2018, 3:50 AM

Hi Terry

Not a bug in the caption itself, but the way captions are handled! It also happens on playback. I think it is a memory or file handle limitation for projects containing movies with lots of captions etc. Perhaps the number of times a single caption can held open. I have run the mdsched.exe memory check and thats ok. I split the movie into three (within the one project), rendered the three separate shorter movies and then joined them together. That works but not very practical. I still get the error if I do one after the other, but ok is I restart Magix between each movie.

After I open a movie, Magix Video deluxe process is using about 430MB memory, which increases as you scroll through the timeline to preview the movie (and the movie and caption thumbnails get created). The captions fail at 23 to 35 mins into the movie with 1300MB used. Continuing to the end, 1800MB of memory is used, so its not a memory limit, but could be a (concurrent) file handle limit. If I start at the end and work backwards then it fails near the start. If I dont preview the movie, then it fails during the export.

I tried another experiment. I removed the music track and all the video clips to leave a simpler shorter 3-track movie with only photos, transitions and most of the captions. I still get the same problem with the caption background failing to render after 20 mins into a now shorter 23 min movie.

terrypin wrote on 5/13/2018, 2:49 PM

If you’re happy to share the smaller project exhibiting the problem we could try to reproduce it as one step in establishing whether it’s a bug. Use File > Backup copy > Copy project and media into a folder, zip it up and upload it to a host site. I use Dropbox for instance. Or if you prefer you could email it to me. Use the PM section to establish contact.

Terry, UK

john-m33 wrote on 5/14/2018, 3:49 AM

I can delete all the media (photos and video), just keeping the titles and captions, and still reproduce the problem. It fails after rendering about 180 captions. I can simply send you the project files without media (or you could make your own movie and copy 200 captions).

p.s. I've sent a zipped backup (and my email) by PM.

terrypin wrote on 5/14/2018, 7:19 AM

I have not received your PM.

johnebaker wrote on 5/14/2018, 2:19 PM

@john-m33. . . .

. . . . I've sent a zipped backup (and my email) by PM . . . .

If you tried to upload the zip file in the PM it is likely that the file was dropped and the PM not sent.

The zip file should be uploaded to Dropbox or a similar file sharing site, as Terry requested, and the link for it put in the PM.

@terrypin

Test PM sent to you.

HTH

John EB

Lateral thinking can get things done!

VPX, MEP Premium, MEP 2016, and earlier versions, Music Maker Premium, Music Maker 2016, 2015.

Running Windows 10 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 1Tb + 2 x 2Tb internal HDD + 60Gb internal SSD, + 6 x 2Tb ext HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

terrypin wrote on 5/15/2018, 3:13 AM

OK john-m33, safely received your emailed ZIP.

I'm about to go out but will study it properly this evening. Meanwhile I've renamed it to CaptionProblem.zip and uploaded it here to open up the discussion. With luck maybe the problem will have been resolved by the time I get back on the case!

https://www.dropbox.com/s/mcsdn4hk8bi9vk0/CaptionProblem.zip?dl=0

Some initial observations.

1. Did you create that ZIP the way I described? (I expected to see an MVP not an MVD.)

2. Did you mean to use only 4 tracks?

3. In my first brief look haven't figured out why the 2nd object ('Seville Mushrooms (Metropol Parasol)') is displayed on the timeline with different colouring

4. I do see the inconsistencies in display on playback. For example the first 'no blue caption ellipse' was at14:43:11 ('Lion's Gate, Alcázar of Seville'). But at 23:03:11 correct display returned (not necessarily permanently).

5. Exploring, I encountered intermittent messages that the relevant TGA file could not be read.

6. Bizarre though it sounds, I think some of the 'blue, faded ellipses' that make up the Neutral 12 caption effect disappeared simply with the passage of time! Or maybe I needed more caffeine.

7. Neutral 12 actually uses the file neutral15_wide.tga

8. Other captions I hurriedly tried that also gave me erratic messages about invalid format were Neutral 03 and Neutral 09.

Must go.

john-m33 wrote on 5/15/2018, 7:29 AM

Hi Terry,

If files are missing, I probably backed up the movie, not the project. The movie had 5 tracks (video,audio,caption,caption,music) but I removed the music earlier, then all the media.

Where the problem occurs depends on the order the movie is previewed. After scrolling through the arranger and displaying about 170 captions the caption background goes black, and after another eight or so, disappears completely. Once gone (about the 180th), all the captions lose their background, including those that were displaying correctly. They only reappear again after the program is re-started (reloading the project doesnt work). It seems you have reproduced what I see, but I only got an error message that the file couldnt be read when previewing the caption (I normally add captions by cut and paste). Also after error has occured, all the caption backgrounds wont preview.

Other captions of the same class show the same problem, but others using three tracks seem to be ok, although I havent tried using one of those 200 times!

John

terrypin wrote on 5/15/2018, 8:42 AM

Hi John,

"If files are missing, I probably backed up the movie, not the project."

IMO it's looking increasingly like an MEPP bug concerning TGA files. However, to continue the discussion without ambiguity we need the backup I described, of the precise project under discussion, not the movie. I've assumed you've pruned the project to its simplest form, with a single movie (a single tab), displaying the strange behaviour. But a project contains more 'global' detail.

I used MEPP 2016, 15,0.0.114 (UDP3) to run 2018 Seville.MVD. I get similar (but not yet sure if identical) results in MEPP '2017',16.0.4.119 (UDP3).

The problem does not appear to occur in MEPP 2014

I've submitted a formal support request to Magix, referring them to this section of this thread, and received the standard reply:

"A confirmation email should have already been sent to you. Your request will be reviewed as soon as possible by a MAGIX representative. We aim to answer all requests within 2 business days. In the meantime, there is no need to raise further requests, we will be in contact shortly."

In many years I've never had such a prompt response as that suggests, but maybe this will be the first!

 

 

Terry, East Grinstead, UK

 

john-m33 wrote on 5/15/2018, 10:31 AM

Terry - I've emailed you the Project zipped file. Once the error has manifested, and tga read error is given if you try to preview "Neutral 03 09 12 15 (but not 01, 02, 03, 04, 05, 06, 07, and 08). Neutral 11 (and Plain 2 and 3) gives a different read error. The common factor is that these are a more basic static (not animated) class of caption that take up two tracks on the timeline. The ones that continue to work are the animated captions (using three tracks of the timeline). So the bug isnt just with one caption. It affects a whole set or class of titles.

I suspect its an open file handle limitation in the programming language, the limit being about 180. Perhaps a compile parameter needs a tweak. I dont believe Windows 10 has a file handle limit, certainly not one so small.

terrypin wrote on 5/15/2018, 11:46 AM

Are you sure you made the project + media backup carefully? I had an error message on running your MVP, including something like "No default presets found".

Despite that it did load, producing worse results than before.

Your suggestion sounds plausible. It's a messy issue so let's see what if any response we get from Magix Support.

BTW, did you try setting up a fresh test project, but this time first configuring for 32 tracks? It's possible MEPP wants to place an element in tracks around 16 at least.

Starting a new project I could not place a Neutral 15 caption here, consistently getting the error message. After closing and restarting MEPP 2016 I could do so. I duplicated that 7 s object to give a timeline with no gaps that was over 25 mins long, with 216 objects. All effects were correct. I previewed them (rapidly, using a macro) and all stayed correct. Repeated that several times.

Exactly how did you create your captions? If by copy/pasting, I'd expect the same results as my test above.

Note that I am still not getting the issue in MEPP 2014.

browj2 wrote on 5/15/2018, 1:04 PM

Hi,

I took a look but with VPX. First go-round, same result as you; the captions lost their tga part. I had imported the MVD into a new project so I had a first empty tab. I created a caption (neutral 03, I think) and then accidently imported a hundred or so images. I undid that. Then I noticed that I had lost the tga of the caption, and it was on the first image and it was the one and only caption in this movie. Trying a new one gave me the file not found error. Back in the imported movie (I imported enough photos to fill to the end of the captions), all tga parts were gone.

So, this is not just MEP, but also VPX.

I saved, exited VPX, reopened it and the project and the captions were all visible, right to the end. I played around a bit, added some photos, still had the subtitles ok.

When you save, exit and reopen, do the captions now work to the end?

I just learned something new that I should have already known. Once the text is typed in for a subtitle model, click on import a different one. The text is applied to the new model. I never noticed that before.

@john-m33

Looking at neutral12 (or 15), there is a light line in the middle. This works for a 2-line subtitle, but I don't like it with a 1-line title with the light line through it. Simple workaround, if there is no second line, put in an Enter to force the first line to be above the light line.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

terrypin wrote on 5/15/2018, 2:48 PM

Hi John CB,

At first that bizarre work-around of saving (an incorrectly displayed project!), exiting and restarting seemed to work. But when I previewed all the objects, the effect was gone again. (Ive written a macro that jumps quickly to each object and stops whenever the Neutral 12 effect is not present.)

Reading up briefly on TGA files, they contain an 'alpha channel'. This behaviour is almost as if that's getting toggled on/off in some way.

Terry, East Grinstead, UK

john-m33 wrote on 5/15/2018, 5:18 PM

Hi Terry.

I do get that occasional spurious and occasional "No default presets found" message when opening a new project for the first time (regardless of whether it has any captions).  It may be related but I doubt it.

It’s easy to be fooled into thinking everything is ok.  Have a project with 200+ titles (the simple text and background type) and look at the start and end and everything looks fine.  Make Magix create the thumbnails for all the captions, and those created after 176 will have a erroneous black thumb.  Then look at those that were ok, and the background is gone.  In reality, I thought everything was fine, made my export, showed it to friends and then found I had lost the background half way through the video – very annoying!

I do like this simple “Neutral 12” caption (which oddly uses neutral15_wide.tga) as it is not too distracting (like the animated ones) and helps highlight the caption over a coloured background.  I normally create one, adjust the length, position, etc to suite, copy it, and the paste lots into the timeline for each picture I need a caption.  It would be nice to be able to change the colour!

I’ve just tried another test.  I created 10 captions (neutral 12, no media, 32 tracks for Terry!), copied them all and pasted to make 20.  Repeated to make 40, 60, and so on ... no errors after 260 captions.  Saved the project and opened it again (and got the “No default presets found error”), and slowly scrolled through the timeline.  The 177th caption onwards lost the background, and then the background was gone for the others as well.  However, project with 175 captions is good, and 176 tips the balance.  There is a 175 limit !!!