Bugs not fixed for 1 year

ProMagixUser wrote on 8/6/2020, 3:26 AM

-When bulk editing is done, the centered text is left-justified.

-Image distortion and stuttering after some rendering.

-Deadlocks experienced during the project. (These problems never happen when photoshop application is used extensively)

-Setting to keep the text within the TV area does not work.

-Other serious stability issues in the program

Note: Every new update is breaking some features. Updates should be done more carefully.

(Image distortion and stuttering after some rendering.)

 

Windows computer with:
- Windows 10 Home, 64-Bit
- Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz
- 16321 MB RAM

- NVidia RTX 2070

-System full update.

Comments

emmrecs wrote on 8/6/2020, 3:47 AM

@ProMagixUser

Welcome to the Magix user to user forums.

I have never experienced the problems you list in your post so cannot comment on them specifically. Except that I am not sure what you are wishing to show in that screenshot?

Have you raised any or all of these issues direct with Magix Support? In my experience, although a resolution of the problem may not be immediately available, the video products support staff are very quick to respond and offer advice, where appropriate.

Jeff
Forum Moderator

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

johnebaker wrote on 8/6/2020, 4:00 AM

@ProMagixUser

Hi

What is the full name and version number of the software as found under Help, About?

Like @emmrecs I have not experienced the issues you say you are having.

. . . . These problems never happen when photoshop application is used extensively . . . .

Where does Photoshop come in to this - it has no connection with Magix software?

John EB
Forum Moderator

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021 and Music Maker 2020.

Running Windows 10 2004 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 3 x 2Tb internal HDD + 60Gb internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

ProMagixUser wrote on 8/6/2020, 4:55 AM

@ProMagixUser

Hi

What is the full name and version number of the software as found under Help, About?

Like @emmrecs I have not experienced the issues you say you are having.

. . . . These problems never happen when photoshop application is used extensively . . . .

Where does Photoshop come in to this - it has no connection with Magix software?

John EB
Forum Moderator

I am using the most current version 18.0.1 The reason I give Photoshop example is to explain that the problem is magix originated. other applications do not have these systemic issues.

ProMagixUser wrote on 8/6/2020, 4:58 AM

@ProMagixUser

Welcome to the Magix user to user forums.

I have never experienced the problems you list in your post so cannot comment on them specifically. Except that I am not sure what you are wishing to show in that screenshot?

Have you raised any or all of these issues direct with Magix Support? In my experience, although a resolution of the problem may not be immediately available, the video products support staff are very quick to respond and offer advice, where appropriate.

Jeff
Forum Moderator

The screenshot shows distortion after rendering. We sent these errors to magix with screenshots and videos. but unfortunately there was no improvement.

emmrecs wrote on 8/6/2020, 5:12 AM

@ProMagixUser

Thanks for the additional information.

The screenshot shows distortion after rendering

I'm happy to take your word for it but, in all honesty, I don't see the distortion!

Nor am I sure why you say these Bugs not fixed for 1 year since version 18 was released only in June this year.

Jeff

Win 10 Pro 64 bit, Intel i7 Quad Core 6700K @ 4GHz, 32 GB RAM, AMD Radeon R7 360 and Intel HD530 Graphics, MOTU 8-Pre f/w audio interface, VPX, MEP, Music Maker, Photo Story Deluxe, Photo Manager Deluxe, Xara 3D Maker 7, Reaper, Adobe Audition CS6 and CC, 2 x Canon HG10 cameras, 1 x Canon EOS 600D

ProMagixUser wrote on 8/6/2020, 5:37 AM

@ProMagixUser

Thanks for the additional information.

The screenshot shows distortion after rendering

I'm happy to take your word for it but, in all honesty, I don't see the distortion!

Nor am I sure why you say these Bugs not fixed for 1 year since version 18 was released only in June this year.

Jeff

Many of these errors were also present in previous versions. With version 17, a lot of things started to break down and are never fixed again.

browj2 wrote on 8/6/2020, 7:50 AM

@ProMagixUser

Hi,

I see that you joined the forum today. Are you aware that I have maintained and posted a bug list for the last 2 years? You never contributed. None of your problems are on the list.

Just to confirm, what exactly is the version of VPX that you have? 18.0.1 what? You are missing a dot and number.

-When bulk editing is done, the centered text is left-justified.

What do you mean by bulk editing? Of what? I cannot be centred text to become left-justified by moving or copying a text object, so what exactly did you do?

-Image distortion and stuttering after some rendering.

-Deadlocks experienced during the project. (These problems never happen when photoshop application is used extensively)

What does PhotoShop have to do with VPX? Are you saying that while you are using PhotoShop you do not get a deadlock with VPX?

What do you mean by deadlock? VPX freezes and you have to use the Task Manager to exit?

When does this happen? Just after start up or later on?

-Setting to keep the text within the TV area does not work.

I have TV area set at 10% under Effects, Movie Effects Settings, TV cropping. What is yours set to?

With the above and "Use only visible TV area" checked in the Text Editor dialogue, I cannot move the text outside of this area when just moving the text box. Using animation overrides this. Of course, I can move it anywhere when in Effects, Size/Position. Obviously, this is necessary to be able to have text fly in and out of the screen. Is this what you did?

I have 17.0.3.68, the last version of VPX11. I have not experienced many stability issues. I have managed to crash the program occasionally when doing a lot of text editing, but it is rare. I have VPX on two computers and do not have stability issues on either.

Sometimes stability issues occur when trying to edit certain types of video files, like variable frame rate files, or something. You would have to determine what, when, and how stability issues occur for anyone to be able to confirm your problem, including Magix.

-Other serious stability issues in the program

Note: Every new update is breaking some features. Updates should be done more carefully.

Agree about updates, that is why I have maintained the bug list, however, we cannot reproduce your problems.

No idea what you mean by the following. I do not get any distortion after rendering. Without seeing your timeline and knowing what you did, it is impossible for anyone to respond.

(Image distortion and stuttering after some rendering.)

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/6/2020, 11:02 AM

@ProMagixUser

Hi,

I see that you joined the forum today. Are you aware that I have maintained and posted a bug list for the last 2 years? You never contributed. None of your problems are on the list.

Just to confirm, what exactly is the version of VPX that you have? 18.0.1 what? You are missing a dot and number.

-When bulk editing is done, the centered text is left-justified.

What do you mean by bulk editing? Of what? I cannot be centred text to become left-justified by moving or copying a text object, so what exactly did you do?

-Image distortion and stuttering after some rendering.

-Deadlocks experienced during the project. (These problems never happen when photoshop application is used extensively)

What does PhotoShop have to do with VPX? Are you saying that while you are using PhotoShop you do not get a deadlock with VPX?

What do you mean by deadlock? VPX freezes and you have to use the Task Manager to exit?

When does this happen? Just after start up or later on?

-Setting to keep the text within the TV area does not work.

I have TV area set at 10% under Effects, Movie Effects Settings, TV cropping. What is yours set to?

With the above and "Use only visible TV area" checked in the Text Editor dialogue, I cannot move the text outside of this area when just moving the text box. Using animation overrides this. Of course, I can move it anywhere when in Effects, Size/Position. Obviously, this is necessary to be able to have text fly in and out of the screen. Is this what you did?

I have 17.0.3.68, the last version of VPX11. I have not experienced many stability issues. I have managed to crash the program occasionally when doing a lot of text editing, but it is rare. I have VPX on two computers and do not have stability issues on either.

Sometimes stability issues occur when trying to edit certain types of video files, like variable frame rate files, or something. You would have to determine what, when, and how stability issues occur for anyone to be able to confirm your problem, including Magix.

-Other serious stability issues in the program

Note: Every new update is breaking some features. Updates should be done more carefully.

Agree about updates, that is why I have maintained the bug list, however, we cannot reproduce your problems.

No idea what you mean by the following. I do not get any distortion after rendering. Without seeing your timeline and knowing what you did, it is impossible for anyone to respond.

(Image distortion and stuttering after some rendering.)

John CB

Firstly, thanks for your response. I have been using magix video pro x for about 10 years. Perhaps as often as no one uses it. I am aware that I have detected errors that even software engineers did not notice. It is good for you and us to take these things seriously. I am using the latest version 18.0.1.82

-These problems can appear at any time while using the program.

-When not using any effects, there is overflow from the screen area.

-The program restarts automatically when it crashes or I need to force it to close.

There may be errors, but they should be detected and corrected soon. These mistakes have been with us for a long time.

browj2 wrote on 8/6/2020, 12:10 PM

@ProMagixUser

It is extremely difficult for Magix to correct errors that it cannot identify. That is why it is important to document as best as possible exactly what happens, when it happens, and what may be the cause. You say that "There may be errors, but they should be detected and corrected soon," but if others here cannot replicate the problems then it is unlikely that Magix will be able to.

So far, you have given us insufficient information to check anything, and you didn't answer our questions.

Check the list in the first message of this thread, and go through the other comments about VPX12.

Note that I have documented everything in detail in the pdf file, along with screen shots and links to videos showing the problems.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/6/2020, 2:30 PM

@ProMagixUser

It is extremely difficult for Magix to correct errors that it cannot identify. That is why it is important to document as best as possible exactly what happens, when it happens, and what may be the cause. You say that "There may be errors, but they should be detected and corrected soon," but if others here cannot replicate the problems then it is unlikely that Magix will be able to.

So far, you have given us insufficient information to check anything, and you didn't answer our questions.

Check the list in the first message of this thread, and go through the other comments about VPX12.

Note that I have documented everything in detail in the pdf file, along with screen shots and links to videos showing the problems.

John CB

I sent the videos of these errors to the support team by opening tickets. Unfortunately, a solution could not be found.

ProMagixUser wrote on 8/12/2020, 6:27 AM

@ProMagixUser

It is extremely difficult for Magix to correct errors that it cannot identify. That is why it is important to document as best as possible exactly what happens, when it happens, and what may be the cause. You say that "There may be errors, but they should be detected and corrected soon," but if others here cannot replicate the problems then it is unlikely that Magix will be able to.

So far, you have given us insufficient information to check anything, and you didn't answer our questions.

Check the list in the first message of this thread, and go through the other comments about VPX12.

Note that I have documented everything in detail in the pdf file, along with screen shots and links to videos showing the problems.

John CB

I sent the videos of these errors to the support team by opening tickets. Unfortunately, a solution could not be found.

@browj2 

-Left justified texts during collective editing,

-Moving text off the screen even though "fit to tv screen" is selected

 

Now that the problems are clear, hopefully they will be fixed soon. because it makes our job difficult. thank you.

johnebaker wrote on 8/12/2020, 8:13 AM

@ProMagixUser, @browj2, @emmrecs

Hi

. . . . Left justified texts during collective editing. . . .

Cannot determine exactly what you are trying to doing in the video with this or what you mean.

. . . . Moving text off the screen even though "fit to tv screen" is selected . . . .

I believe this may be a new design behaviour and not the real bug that is the issue - this is what used to happen (I had to use MEP 2015 as I do not have an older version of VPX installed).

However with VPX 12, and MEP 2020 - there appears to be a new added function - when you deliberately move the text - Size & Position key frame are added to the clip - you can see this in VPX 12 below.

The real bug is that it does not switch to the Size & Position effect dialog, which I believe is the desired behaviour, as you cannot add key frames while in the Title dialog.

I have filed a bug report on this issue linking to this topic.

John EB
Forum Moderator

Last changed by johnebaker on 8/12/2020, 8:27 AM, changed a total of 5 times.

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021 and Music Maker 2020.

Running Windows 10 2004 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 3 x 2Tb internal HDD + 60Gb internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

browj2 wrote on 8/12/2020, 8:43 AM

@ProMagixUser

Hi,

Actually, it's not clear, but enough to try it out. You really need to learn how to take a screen shot and save it as a jpeg. We do not use a camera to do that. You images are blurry, so of little use. Also, to be able to properly identify the problem, you have to describe what you are doing, in detail. Just giving a result does not do that.

First, under Effects, Movie Effects Settings, TV Cropping, it set to the default of 10% all round, All tracks selected. Second, under Titles, centre justify is on by default to start, and "Only use visible TV area" is checked.

I tried dragging the text to the left off of the screen. It bounces back. I clicked left justify, and the multi-line text was left justified and the text box was as far to the left as possible - leaving the 10% edge. Right justify does the same but at the right. Nothing goes off-screen.

I suspect that your preview window is not set to 100%. In the image below, my Preview window is set to 150% and the text is off of the screen to the left like in your example.

Click on the menu (3 bar button at the top left). What is yours set at? If nothing, then it is probably not at 100%. Mine shows 150%. If I zoom in or out, the zoom factor does not show.

Click on 100%.

Problem solved?

Do you understand about the Preview Window settings?

I asked other questions, like what do you mean by bulk editing? You have not explained, thus we cannot help you. Go back and look at the questions and provide complete descriptions of what you did and complete answers.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/12/2020, 9:02 AM

@ProMagixUser

Hi,

Actually, it's not clear, but enough to try it out. You really need to learn how to take a screen shot and save it as a jpeg. We do not use a camera to do that. You images are blurry, so of little use. Also, to be able to properly identify the problem, you have to describe what you are doing, in detail. Just giving a result does not do that.

First, under Effects, Movie Effects Settings, TV Cropping, it set to the default of 10% all round, All tracks selected. Second, under Titles, centre justify is on by default to start, and "Only use visible TV area" is checked.

I tried dragging the text to the left off of the screen. It bounces back. I clicked left justify, and the multi-line text was left justified and the text box was as far to the left as possible - leaving the 10% edge. Right justify does the same but at the right. Nothing goes off-screen.

I suspect that your preview window is not set to 100%. In the image below, my Preview window is set to 150% and the text is off of the screen to the left like in your example.

Click on the menu (3 bar button at the top left). What is yours set at? If nothing, then it is probably not at 100%. Mine shows 150%. If I zoom in or out, the zoom factor does not show.

Click on 100%.

Problem solved?

Do you understand about the Preview Window settings?

I asked other questions, like what do you mean by bulk editing? You have not explained, thus we cannot help you. Go back and look at the questions and provide complete descriptions of what you did and complete answers.

John CB

-I have been using this application for years. this setting was broken by update 18. screen ratio 100%

-When we update all posts to the right, the centered posts are aligned to the left. It's a very simple bug to understand. I cannot understand why you have had such a hard time.

johnebaker wrote on 8/12/2020, 9:21 AM

@browj2

Hi John

If you look at your first and last image you can see the Size & Position effect is applied to the title as shown in my second video clip above - this is a new behaviour.

John EB

Lateral thinking can get things done!

VPX 12, MEP Premium 2021, and earlier versions 2015 and 2016, Music Maker Premium 2021 and Music Maker 2020.

Running Windows 10 2004 64bit on Intel i7-8700K 3.2 GHz, 16Gb RAM, 3 x 2Tb internal HDD + 60Gb internal SSD, + 6 ext backup HDDs, Sony FDR-AX53 Video camera, Contour HD 1080 and Sony HDR-AS30V Sports cams.

browj2 wrote on 8/12/2020, 9:25 AM

@ProMagixUser

-When we update all posts to the right, the centered posts are aligned to the left. It's a very simple bug to understand. I cannot understand why you have had such a hard time.

Because we cannot replicate your problem.

Did you actually click again on the 100% for the preview monitor? There is nothing that says "screen ratio" in the menu. Look at my image. Open the menu, click on 100%.

The way that I showed is the only way that I can replicate what you show.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/12/2020, 9:45 AM

@ProMagixUser

-When we update all posts to the right, the centered posts are aligned to the left. It's a very simple bug to understand. I cannot understand why you have had such a hard time.

Because we cannot replicate your problem.

Did you actually click again on the 100% for the preview monitor? There is nothing that says "screen ratio" in the menu. Look at my image. Open the menu, click on 100%.

The way that I showed is the only way that I can replicate what you show.

John CB

"Only use visible tv are" option does not work.

browj2 wrote on 8/12/2020, 10:25 AM

@johnebaker

Hi John,

The OP says that this has been going on for a year, so I don't think that the new "feature" is the problem as VPX12 is very recent.

Using VPX 12 to do what you did in your first video, just using the text button, not a template, are you immediately able to drag the text off of the screen without it bouncing back? If so, drag it to the right side, partially off of the screen. Now click on right justify. What happens? Does it jump to the right side of the screen but equally off of the screen?

I get exactly what you show in your second video with VPX11. When you drag the text box to the left or right, can you get it to go off of the screen? I cannot.

What are your TV cropping settings?

Also, in his case, he appears to be starting with the title centred. Try that with a couple of words with just the default text settings (centred). Then click on left justify. Does the text go partially off screen? That is what I understand is happening with the OP and the only way that I can think of to make this happen is to be zoomed in a bit on the Preview Monitor.

I will post a video shortly.

John CB

 

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

browj2 wrote on 8/12/2020, 10:28 AM

"Only use visible tv are" option does not work.

@ProMagixUser

Once again, you are not answering my questions and I don't know what you did. You have to actually do what I say and then confirm that you did it. Did you click on the 100% in the Preview Window menu?

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/12/2020, 10:40 AM

"Only use visible tv are" option does not work.

@ProMagixUser

Once again, you are not answering my questions and I don't know what you did. You have to actually do what I say and then confirm that you did it. Did you click on the 100% in the Preview Window menu?

John CB

the screen size is 100% and the problem persists.

browj2 wrote on 8/12/2020, 11:23 AM

@ProMagixUser @johnebaker

Here is the video.

John CB

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/12/2020, 11:46 AM

@ProMagixUser @johnebaker

Here is the video.

John CB

it was a good video but this is an old version right? These actions do not work in the new version. I tried all you did.

browj2 wrote on 8/12/2020, 12:20 PM

@ProMagixUser

I used VPX11, not 12. You said that you have had this problem for a year. VPX12 came out on June 8 - 2 months ago. So if you have had this problem, you would have had it in VPX11.

Also, you say that "these actions do not work in the new version." Yes, they do - as shown by John Baker. All I did differently was drag the titles over to the right and zoomed into the Preview window, and switch to Size/Position, move the text box, switch back to the Text dialogue and move the text box. If not of this can be done or doesn't work in VPX 12, then we are all in big trouble. Once again, you give no detail. I cannot continue to try to help if you do not contribute properly.

So, what actions do not work? Show us a video like the one that I produced. Use a screen capture program, not a camera.

John CB

 

 

John C.B.

Desktop System - Windows 10 Home 1903; 16Gb RAM; i7 CPU 860@2.80Gz; ATI Radeon HD5770 w1GB; SSD 500GB, HD 2TB; others 1.5TB, 3TB, 500GB, 4TB, 5TB, 6TB; dual monitors - 27" main, 25" secondary; Casio WK-225 piano keyboard; M-Audio M-Track USB mixer; Notebook - Microsoft Surface Pro 4, i5, 8 GB RAM, 256 SSD, W10 Pro 1903

ProMagixUser wrote on 8/12/2020, 12:52 PM

@ProMagixUser

I used VPX11, not 12. You said that you have had this problem for a year. VPX12 came out on June 8 - 2 months ago. So if you have had this problem, you would have had it in VPX11.

Also, you say that "these actions do not work in the new version." Yes, they do - as shown by John Baker. All I did differently was drag the titles over to the right and zoomed into the Preview window, and switch to Size/Position, move the text box, switch back to the Text dialogue and move the text box. If not of this can be done or doesn't work in VPX 12, then we are all in big trouble. Once again, you give no detail. I cannot continue to try to help if you do not contribute properly.

So, what actions do not work? Show us a video like the one that I produced. Use a screen capture program, not a camera.

John CB

 

 

When you select a text box and click "apply title setting to all flowing", all the text centered is left aligned. this bug has not been fixed for 1 year.